Koozali.org: home of the SME Server

webmail mods

Offline lucho115

  • ****
  • 209
  • +0/-0
    • http://www.elac.com.ar
webmail mods
« on: July 19, 2006, 02:18:01 PM »
hi, iam looking for a howto or somebody to tellme how to change some things of the webmail:
1 - I want to change the login form of horde, where are the files thats i needs to change and what more i have to do to this change no to be modified by an update.
2 - How can i force sme to use no ssl on horde webpages, i really no need that and it eat my cpu.
3 - How can i change the name of the webmail, so instead to call http://severname/horde, i want to use http://servername/webmail or other name that i want

OK, i will be waiting for a response, thanks and sorry about my english , iam from argentina¡¡¡¡

bye

Offline lucho115

  • ****
  • 209
  • +0/-0
    • http://www.elac.com.ar
webmail mods
« Reply #1 on: July 21, 2006, 09:17:51 PM »
Quote
1 - I want to change the login form of horde, where are the files thats i needs to change and what more i have to do to this change no to be modified by an update.


/home/httpd/html/horde/imp/config/motd.php
/home/httpd/html/horde/imp/templates/login/login.inc

Quote
3 - How can i change the name of the webmail, so instead to call http://severname/horde, i want to use http://servername/webmail or other name that i want


its work by default

Quote
2 - How can i force sme to use no ssl on horde webpages, i really no need that and it eat my cpu.


This question has not a fix to me, i cant have horde without https yet, can somebody help me?
thanks

bye[/code]

KDB9000

webmail mods
« Reply #2 on: September 25, 2006, 09:14:46 PM »
How do I change the name so it doesn't say "Welcome to horde"?

-Edit- Nevermind, I found out how.

http://forums.contribs.org/index.php?topic=32212.0

Offline cactus

  • *
  • 4,880
  • +3/-0
    • http://www.snetram.nl
webmail mods
« Reply #3 on: September 26, 2006, 09:56:26 AM »
Quote from: lucho115
Quote

Quote
2 - How can i force sme to use no ssl on horde webpages, i really no need that and it eat my cpu.


This question has not a fix to me, i cant have horde without https yet, can somebody help me?[/code]

You will probably have to modify the httpd.conf file temp[lates for either httpd or httpd-admin. Somewhere there has to be a rewrite rule that forces webmail to only be accessible by SSL.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline william_syd

  • ****
  • 1,608
  • +0/-0
  • Nothing to see here.
    • http://www.magicwilly.info
webmail mods
« Reply #4 on: September 26, 2006, 01:17:51 PM »
Quote
Quote

Quote
2 - How can i force sme to use no ssl on horde webpages, i really no need that and it eat my cpu.


This question has not a fix to me, i cant have horde without https yet, can somebody help me?[/code]

You will probably have to modify the httpd.conf file temp[lates for either httpd or httpd-admin. Somewhere there has to be a rewrite rule that forces webmail to only be accessible by SSL.


Have a look at
Code: [Select]
db configuration show | more
at the imp property.

It gets used at least in
Code: [Select]
/etc/e-smith/templates/etc/httpd/conf/httpd.conf/VirtualHosts/30WebmailAliases

At a wild guess
Code: [Select]
db configuration delprop imp access


might do it.

Probably have to expand the httpd.conf template and restart httpd.

Edit: Actually the default is SSL so you may need to change it to something else...
Code: [Select]
db configuration setprop imp access noSSL
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
service httpd-e-smith restart


And you may have to do it to horde in the same db as well.
Regards,
William

IF I give advise.. It's only if it was me....

Offline byte

  • *
  • 2,183
  • +2/-0
webmail mods
« Reply #5 on: September 26, 2006, 01:55:35 PM »
Quote from: "william_syd"
Quote
Quote

Quote
2 - How can i force sme to use no ssl on horde webpages, i really no need that and it eat my cpu.


This question has not a fix to me, i cant have horde without https yet, can somebody help me?[/code]

You will probably have to modify the httpd.conf file temp[lates for either httpd or httpd-admin. Somewhere there has to be a rewrite rule that forces webmail to only be accessible by SSL.


Have a look at
Code: [Select]
db configuration show | more
at the imp property.

It gets used at least in
Code: [Select]
/etc/e-smith/templates/etc/httpd/conf/httpd.conf/VirtualHosts/30WebmailAliases

At a wild guess
Code: [Select]
db configuration delprop imp access


might do it.

Probably have to expand the httpd.conf template and restart httpd.

Edit: Actually the default is SSL so you may need to change it to something else...
Code: [Select]
db configuration setprop imp access noSSL
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
service httpd-e-smith restart


And you may have to do it to horde in the same db as well.


Or just do a search as I answered this in depth a while a go.
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

Offline lucho115

  • ****
  • 209
  • +0/-0
    • http://www.elac.com.ar
webmail mods
« Reply #6 on: October 02, 2006, 02:03:06 PM »
i need to know how to change the theme, anybody knows?

Offline Smitro

  • *
  • 348
  • +0/-0
webmail mods
« Reply #7 on: October 04, 2006, 11:00:59 AM »
This is how you change the default theme:

Code: [Select]
mkdir -p /etc/e-smith/templates-custom/home/httpd/html/horde/config/prefs.php

cd /etc/e-smith/templates-custom/home/httpd/html/horde/config/prefs.php

cp /etc/e-smith/templates/home/httpd/html/horde/config/prefs.php/200personal .

pico -w 200personal

Edit The following lines:
// UI theme
$_prefs['theme'] = array(
    'value' => 'bluewhite',
    'locked' => false,
    'shared' => true,
    'type' => 'select',
    'desc' => _("Select your color scheme.")
);

(Change 'value' to the name of the theme you want).

/sbin/e-smith/expand-template /home/httpd/html/horde/config/prefs.php


More info can be taken from here:
http://wiki.horde.org/Doc/Dev/Layout

Hope that helps.
.........