Koozali.org, home of the SME Server

Update from sme8b5 to sme8b6

Offline fpausp

  • *
  • 728
  • +0/-0
Update from sme8b5 to sme8b6
« on: August 21, 2010, 02:43:17 PM »
Hi,

I like to update a sme8b5 to sme8b6, can anyone help me please ?

Code: [Select]
[root@sme8b5vm ~]# yum update
Loaded plugins: fastestmirror, protect-packages, smeserver
Loading mirror speeds from cached hostfile
 * base: gd.tuwien.ac.at
 * smeaddons: distro.ibiblio.org
 * smeextras: distro.ibiblio.org
 * smeos: distro.ibiblio.org
 * smeupdates: distro.ibiblio.org
 * updates: gd.tuwien.ac.at
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package clamav.i386 0:0.96.2-2.el5.rf set to be updated
---> Package clamav-db.i386 0:0.96.2-2.el5.rf set to be updated
---> Package clamd.i386 0:0.96.2-2.el5.rf set to be updated
---> Package dstat.noarch 0:0.7.2-1.el5.rf set to be updated
---> Package e-smith-backup.noarch 0:2.2.0-44.el5.sme set to be updated
---> Package e-smith-base.i386 0:5.2.0-28.el5.sme set to be updated
---> Package e-smith-devtools.noarch 0:2.2.0-4.el5.sme set to be updated
---> Package e-smith-email.noarch 0:5.2.0-9.el5.sme set to be updated
---> Package e-smith-horde.noarch 0:4.2.0-13.el5.sme set to be updated
---> Package e-smith-hosts.noarch 0:2.2.0-2.el5.sme set to be updated
---> Package e-smith-imp.noarch 0:5.2.0-9.el5.sme set to be updated
---> Package e-smith-ingo.noarch 0:2.2.0-4.el5.sme set to be updated
---> Package e-smith-ldap.noarch 0:5.2.0-23.el5.sme set to be updated
---> Package e-smith-manager.noarch 0:2.2.0-6.el5.sme set to be updated
---> Package e-smith-mysql.noarch 0:2.2.0-4.el5.sme set to be updated
---> Package e-smith-ntp.noarch 0:2.2.0-2.el5.sme set to be updated
---> Package e-smith-php.noarch 0:2.2.0-3.el5.sme set to be updated
---> Package e-smith-portforwarding.noarch 0:2.2.0-6.el5.sme set to be updated
---> Package e-smith-proxy.noarch 0:5.2.0-2.el5.sme set to be updated
---> Package e-smith-quota.noarch 0:2.2.0-3.el5.sme set to be updated
---> Package e-smith-samba.noarch 0:2.2.0-18.el5.sme set to be updated
--> Processing Dependency: samba3x-common >= 3.3.8 for package: e-smith-samba
--> Processing Dependency: samba3x-client >= 3.3.8 for package: e-smith-samba
--> Processing Dependency: samba3x >= 3.3.8 for package: e-smith-samba
--> Processing Dependency: /usr/bin/tdbbackup for package: e-smith-samba
---> Package e-smith-tinydns.noarch 0:2.2.0-2.el5.sme set to be updated
---> Package e-smith-turba.noarch 0:3.2.0-15.el5.sme set to be updated
---> Package horde.noarch 0:3.3.8-1.el5.sme set to be updated
---> Package imp-h3.noarch 0:4.3.7-1.el5.sme set to be updated
---> Package ingo-h3.noarch 0:1.2.4-1.el5.sme set to be updated
---> Package maildrop.i386 0:2.5.0-13.el5 set to be updated
---> Package mtr.i386 2:0.80-1.el5.rf set to be updated
---> Package nut.i386 0:2.2.0-7.el5 set to be updated
---> Package nut-client.i386 0:2.2.0-7.el5 set to be updated
---> Package perl-Authen-PAM.i386 0:0.16-8.el5 set to be updated
---> Package perl-DBI.i386 0:1.611-1.el5.rf set to be updated
---> Package perl-HTML-Tabulate.noarch 0:0.35-1.el5.rf set to be updated
---> Package perl-IO-Socket-SSL.noarch 0:1.31-2.el5.rf set to be updated
---> Package perl-Net-SMTP-SSL.noarch 0:1.01-4.el5 set to be updated
---> Package python-paste.noarch 0:1.7.4-1.el5 set to be updated
---> Package python-simplejson.i386 0:2.0.9-2.el5 set to be updated
---> Package qpsmtpd.noarch 0:0.84-0.1.el5.sme set to be updated
---> Package rssh.i386 0:2.3.3-1.el5.rf set to be updated
--> Processing Dependency: samba-common = 3.4.3-1.1.el5.sme for package: samba-winbind
---> Package smeserver-clamav.noarch 0:2.2.0-12.el5.sme set to be updated
---> Package smeserver-locale-bg.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-da.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-de.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-el.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-es.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-et.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-fr.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-hu.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-id.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-it.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-ja.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-nb.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-nl.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-pl.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-pt.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-pt_BR.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-ro.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-ru.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-sl.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-sv.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-th.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-tr.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-zh_CN.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-qpsmtpd.noarch 0:2.2.0-7.el5.sme set to be updated
---> Package smeserver-release.noarch 26:8.0-0.beta6.el5.sme set to be updated
---> Package smeserver-spamassassin.noarch 0:2.2.0-6.el5.sme set to be updated
---> Package smeserver-support.noarch 0:2.2.0-18.el5.sme set to be updated
--> Processing Dependency: smeserver-locale-zh_TW for package: smeserver-support
--> Processing Dependency: smeserver-locale-he for package: smeserver-support
---> Package smeserver-yum.noarch 0:2.2.0-17.el5.sme set to be updated
---> Package spamassassin.i386 0:3.3.1-52.el5 set to be updated
---> Package turba-h3.noarch 0:2.3.4-1.el5.sme set to be updated
--> Running transaction check
--> Processing Dependency: samba-common = 3.4.3-1.1.el5.sme for package: samba-winbind
---> Package samba3x.i386 0:3.3.8-0.52.el5_5 set to be updated
---> Package samba3x-client.i386 0:3.3.8-0.52.el5_5 set to be updated
---> Package samba3x-common.i386 0:3.3.8-0.52.el5_5 set to be updated
--> Processing Dependency: samba3x-winbind = 3.3.8-0.52.el5_5 for package: samba3x-common
--> Processing Dependency: libsmbclient for package: samba3x-common
---> Package smeserver-locale-he.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-zh_TW.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package tdb-tools.i386 0:1.1.2-52.el5_5 set to be updated
--> Processing Dependency: libtdb = 1.1.2-52.el5_5 for package: tdb-tools
--> Running transaction check
---> Package libsmbclient.i386 0:3.0.33-3.29.el5_5 set to be updated
--> Processing Dependency: samba-common = 3.4.3-1.1.el5.sme for package: samba-winbind
---> Package samba3x-winbind.i386 0:3.3.8-0.52.el5_5 set to be updated
---> Package tdb-tools.i386 0:1.1.2-52.el5_5 set to be updated
--> Processing Dependency: libtdb = 1.1.2-52.el5_5 for package: tdb-tools
--> Finished Dependency Resolution
samba-winbind-3.4.3-1.1.el5.sme.i386 from installed has depsolving problems
  --> Missing Dependency: samba-common = 3.4.3-1.1.el5.sme is needed by package samba-winbind-3.4.3-1.1.el5.sme.i386 (installed)
tdb-tools-1.1.2-52.el5_5.i386 from smeos has depsolving problems
  --> Missing Dependency: libtdb = 1.1.2-52.el5_5 is needed by package tdb-tools-1.1.2-52.el5_5.i386 (smeos)
Error: Missing Dependency: samba-common = 3.4.3-1.1.el5.sme is needed by package samba-winbind-3.4.3-1.1.el5.sme.i386 (installed)
Error: Missing Dependency: libtdb = 1.1.2-52.el5_5 is needed by package tdb-tools-1.1.2-52.el5_5.i386 (smeos)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Viribus unitis

Offline mmccarn

  • *
  • 2,573
  • +5/-0
Re: Update from sme8b5 to sme8b6
« Reply #1 on: August 21, 2010, 03:01:21 PM »
There is some discussion of this here: http://bugs.contribs.org/show_bug.cgi?id=5964

Offline janet

  • ****
  • 4,812
  • +0/-0
Re: Update from sme8b5 to sme8b6
« Reply #2 on: August 21, 2010, 04:28:41 PM »
fpausp

Do
yum clean all
and then try update again
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Offline CharlieBrady

  • *
  • 6,918
  • +3/-0
Re: Update from sme8b5 to sme8b6
« Reply #3 on: August 21, 2010, 04:52:40 PM »
I like to update a sme8b5 to sme8b6, can anyone help me please ?

Please report all problems with sme8b6 via the bug tracker. Thanks.

Offline fpausp

  • *
  • 728
  • +0/-0
Re: Update from sme8b5 to sme8b6
« Reply #4 on: August 21, 2010, 10:35:47 PM »
Hi mary,

Code: [Select]
[root@sme8b5vm ~]# yum clean all
Loaded plugins: fastestmirror, protect-packages, smeserver
Cleaning up Everything
[root@sme8b5vm ~]# yum update
Loaded plugins: fastestmirror, protect-packages, smeserver
Determining fastest mirrors
 * base: gd.tuwien.ac.at
 * smeaddons: ftp.nluug.nl
 * smeextras: ftp.nluug.nl
 * smeos: ftp.nluug.nl
 * smeupdates: ftp.nluug.nl
 * updates: ftp.plusline.de
base                                                                                     | 2.1 kB     00:00
base/primary_db                                                                          | 1.6 MB     00:05
smeaddons                                                                                | 1.9 kB     00:00
smeaddons/primary_db                                                                     | 5.5 kB     00:00
smeextras                                                                                | 1.9 kB     00:00
smeextras/primary_db                                                                     |  83 kB     00:00
smeos                                                                                    | 2.1 kB     00:00
smeos/primary_db                                                                         | 613 kB     00:01
smeupdates                                                                               | 1.9 kB     00:00
smeupdates/primary_db                                                                    | 1.1 kB     00:00
updates                                                                                  | 1.9 kB     00:00
updates/primary_db                                                                       | 455 kB     00:01
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package clamav.i386 0:0.96.2-2.el5.rf set to be updated
---> Package clamav-db.i386 0:0.96.2-2.el5.rf set to be updated
---> Package clamd.i386 0:0.96.2-2.el5.rf set to be updated
---> Package dstat.noarch 0:0.7.2-1.el5.rf set to be updated
---> Package e-smith-backup.noarch 0:2.2.0-44.el5.sme set to be updated
---> Package e-smith-base.i386 0:5.2.0-28.el5.sme set to be updated
---> Package e-smith-devtools.noarch 0:2.2.0-4.el5.sme set to be updated
---> Package e-smith-email.noarch 0:5.2.0-9.el5.sme set to be updated
---> Package e-smith-horde.noarch 0:4.2.0-13.el5.sme set to be updated
---> Package e-smith-hosts.noarch 0:2.2.0-2.el5.sme set to be updated
---> Package e-smith-imp.noarch 0:5.2.0-9.el5.sme set to be updated
---> Package e-smith-ingo.noarch 0:2.2.0-4.el5.sme set to be updated
---> Package e-smith-ldap.noarch 0:5.2.0-23.el5.sme set to be updated
---> Package e-smith-manager.noarch 0:2.2.0-6.el5.sme set to be updated
---> Package e-smith-mysql.noarch 0:2.2.0-4.el5.sme set to be updated
---> Package e-smith-ntp.noarch 0:2.2.0-2.el5.sme set to be updated
---> Package e-smith-php.noarch 0:2.2.0-3.el5.sme set to be updated
---> Package e-smith-portforwarding.noarch 0:2.2.0-6.el5.sme set to be updated
---> Package e-smith-proxy.noarch 0:5.2.0-2.el5.sme set to be updated
---> Package e-smith-quota.noarch 0:2.2.0-3.el5.sme set to be updated
---> Package e-smith-samba.noarch 0:2.2.0-18.el5.sme set to be updated
--> Processing Dependency: samba3x-common >= 3.3.8 for package: e-smith-samba
--> Processing Dependency: samba3x-client >= 3.3.8 for package: e-smith-samba
--> Processing Dependency: samba3x >= 3.3.8 for package: e-smith-samba
--> Processing Dependency: /usr/bin/tdbbackup for package: e-smith-samba
---> Package e-smith-tinydns.noarch 0:2.2.0-2.el5.sme set to be updated
---> Package e-smith-turba.noarch 0:3.2.0-15.el5.sme set to be updated
---> Package horde.noarch 0:3.3.8-1.el5.sme set to be updated
---> Package imp-h3.noarch 0:4.3.7-1.el5.sme set to be updated
---> Package ingo-h3.noarch 0:1.2.4-1.el5.sme set to be updated
---> Package maildrop.i386 0:2.5.0-13.el5 set to be updated
---> Package mtr.i386 2:0.80-1.el5.rf set to be updated
---> Package nut.i386 0:2.2.0-7.el5 set to be updated
---> Package nut-client.i386 0:2.2.0-7.el5 set to be updated
---> Package perl-Authen-PAM.i386 0:0.16-8.el5 set to be updated
---> Package perl-DBI.i386 0:1.611-1.el5.rf set to be updated
---> Package perl-HTML-Tabulate.noarch 0:0.35-1.el5.rf set to be updated
---> Package perl-IO-Socket-SSL.noarch 0:1.31-2.el5.rf set to be updated
---> Package perl-Net-SMTP-SSL.noarch 0:1.01-4.el5 set to be updated
---> Package python-paste.noarch 0:1.7.4-1.el5 set to be updated
---> Package python-simplejson.i386 0:2.0.9-2.el5 set to be updated
---> Package qpsmtpd.noarch 0:0.84-0.1.el5.sme set to be updated
---> Package rssh.i386 0:2.3.3-1.el5.rf set to be updated
--> Processing Dependency: samba-common = 3.4.3-1.1.el5.sme for package: samba-winbind
---> Package smeserver-clamav.noarch 0:2.2.0-12.el5.sme set to be updated
---> Package smeserver-locale-bg.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-da.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-de.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-el.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-es.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-et.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-fr.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-hu.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-id.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-it.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-ja.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-nb.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-nl.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-pl.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-pt.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-pt_BR.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-ro.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-ru.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-sl.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-sv.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-th.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-tr.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-zh_CN.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-qpsmtpd.noarch 0:2.2.0-7.el5.sme set to be updated
---> Package smeserver-release.noarch 26:8.0-0.beta6.el5.sme set to be updated
---> Package smeserver-spamassassin.noarch 0:2.2.0-6.el5.sme set to be updated
---> Package smeserver-support.noarch 0:2.2.0-18.el5.sme set to be updated
--> Processing Dependency: smeserver-locale-zh_TW for package: smeserver-support
--> Processing Dependency: smeserver-locale-he for package: smeserver-support
---> Package smeserver-yum.noarch 0:2.2.0-17.el5.sme set to be updated
---> Package spamassassin.i386 0:3.3.1-52.el5 set to be updated
---> Package turba-h3.noarch 0:2.3.4-1.el5.sme set to be updated
--> Running transaction check
--> Processing Dependency: samba-common = 3.4.3-1.1.el5.sme for package: samba-winbind
---> Package samba3x.i386 0:3.3.8-0.52.el5_5 set to be updated
---> Package samba3x-client.i386 0:3.3.8-0.52.el5_5 set to be updated
---> Package samba3x-common.i386 0:3.3.8-0.52.el5_5 set to be updated
--> Processing Dependency: samba3x-winbind = 3.3.8-0.52.el5_5 for package: samba3x-common
--> Processing Dependency: libsmbclient for package: samba3x-common
---> Package smeserver-locale-he.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package smeserver-locale-zh_TW.noarch 0:2.2.0-34.el5.sme set to be updated
---> Package tdb-tools.i386 0:1.1.2-52.el5_5 set to be updated
--> Processing Dependency: libtdb = 1.1.2-52.el5_5 for package: tdb-tools
--> Running transaction check
---> Package libsmbclient.i386 0:3.0.33-3.29.el5_5 set to be updated
--> Processing Dependency: samba-common = 3.4.3-1.1.el5.sme for package: samba-winbind
---> Package samba3x-winbind.i386 0:3.3.8-0.52.el5_5 set to be updated
---> Package tdb-tools.i386 0:1.1.2-52.el5_5 set to be updated
--> Processing Dependency: libtdb = 1.1.2-52.el5_5 for package: tdb-tools
--> Finished Dependency Resolution
samba-winbind-3.4.3-1.1.el5.sme.i386 from installed has depsolving problems
  --> Missing Dependency: samba-common = 3.4.3-1.1.el5.sme is needed by package samba-winbind-3.4.3-1.1.el5.sme.i386 (installed)
tdb-tools-1.1.2-52.el5_5.i386 from smeos has depsolving problems
  --> Missing Dependency: libtdb = 1.1.2-52.el5_5 is needed by package tdb-tools-1.1.2-52.el5_5.i386 (smeos)
Error: Missing Dependency: samba-common = 3.4.3-1.1.el5.sme is needed by package samba-winbind-3.4.3-1.1.el5.sme.i386 (installed)
Error: Missing Dependency: libtdb = 1.1.2-52.el5_5 is needed by package tdb-tools-1.1.2-52.el5_5.i386 (smeos)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[root@sme8b5vm ~]#
Viribus unitis

Offline janet

  • ****
  • 4,812
  • +0/-0
Re: Update from sme8b5 to sme8b6
« Reply #5 on: August 22, 2010, 12:55:51 AM »
fpausp

Please review comments 16 - 21 in the bug report referred to earlier.
Comment 21 says everything should be fine.

Upgrades should work correctly, although as this is a beta release there are no guarantees.

Please report your problem to the bug tracker, as you have already been asked to do.
For further understanding why, read
http://wiki.contribs.org/Lodge_bug_request_explanation
« Last Edit: August 22, 2010, 01:02:43 AM by mary »
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Offline janet

  • ****
  • 4,812
  • +0/-0
Re: Update from sme8b5 to sme8b6
« Reply #6 on: August 22, 2010, 01:11:49 AM »
fpausp

There is now a sme8 forum category, please use that for sme8 issues in future.

Would a moderator please move this thread, thanks.
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Offline CharlieBrady

  • *
  • 6,918
  • +3/-0
Re: Update from sme8b5 to sme8b6
« Reply #7 on: August 22, 2010, 01:25:46 AM »
There is now a sme8 forum category, please use that for sme8 issues in future.

No, not so. Problems such as this should be reported (only) via the bug tracker. Thanks.

Offline janet

  • ****
  • 4,812
  • +0/-0
Re: Update from sme8b5 to sme8b6
« Reply #8 on: August 22, 2010, 01:34:45 AM »
No, not so. Problems such as this should be reported (only) via the bug tracker. Thanks.

Well yes of course. Anything that is a potential bug or already identifiable bug should be initially reported to bugzilla. As sme8 is still beta, then theoretically all issues should be reported to bugzilla in the first instance, and then taken back to the forum if not deemed to be a bugzilla matter.
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Offline cactus

  • *
  • 4,880
  • +3/-0
    • http://www.snetram.nl
Re: Update from sme8b5 to sme8b6
« Reply #9 on: August 22, 2010, 02:19:55 AM »
Well yes of course. Anything that is a potential bug or already identifiable bug should be initially reported to bugzilla. As sme8 is still beta, then theoretically all issues should be reported to bugzilla in the first instance, and then taken back to the forum if not deemed to be a bugzilla matter.
Thanks for explaining Mary, indeed please post all issues with SME Server 8 in the bugtracker. Locking this thread.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)