Koozali.org, home of the SME Server

beta7 upgrade - dependency problem with pear-Razor-Agents

Offline maicz

  • *
  • 26
  • +0/-0
beta7 upgrade - dependency problem with pear-Razor-Agents
« on: January 04, 2012, 03:08:09 PM »
Hi all,
i'm trying to upgrade my SMEb6 to SMEb7.
If i try from server-manager, got this error:

Code: [Select]
---> Package perl-Compress-Raw-Bzip2.i386 0:2.037-1.el5.rf set to be updated
--> Processing Dependency: php-common = 5.3.3-1.el5.sme.1.0 for package: php-soap
--> Finished Dependency Resolution
php-soap-5.3.3-1.el5.sme.1.0.i386 from installed has depsolving problems
  --> Missing Dependency: php-common = 5.3.3-1.el5.sme.1.0 is needed by package php-soap-5.3.3-1.el5.sme.1.0.i386 (installed)
--> Running transaction check
---> Package kernel-PAE.i686 0:2.6.18-238.19.1.el5 set to be erased
--> Processing Dependency: php-common = 5.3.3-1.el5.sme.1.0 for package: php-soap
--> Finished Dependency Resolution
php-soap-5.3.3-1.el5.sme.1.0.i386 from installed has depsolving problems
  --> Missing Dependency: php-common = 5.3.3-1.el5.sme.1.0 is needed by package php-soap-5.3.3-1.el5.sme.1.0.i386 (installed)
Error: Missing Dependency: php-common = 5.3.3-1.el5.sme.1.0 is needed by package php-soap-5.3.3-1.el5.sme.1.0.i386 (installed)

So i've try to ssh, and run yum enabling all repos.

Code: [Select]
[root@sme ~]# yum --enablerepo=* update
got this other error:

Code: [Select]
--> Processing Dependency: perl-Razor-Agent = 2.84-1.el5.rf for package: razor-agents
--> Finished Dependency Resolution
razor-agents-2.84-1.el5.rf.i386 from installed has depsolving problems
  --> Missing Dependency: perl-Razor-Agent = 2.84-1.el5.rf is needed by package razor-agents-2.84-1.el5.rf.i386 (installed)
--> Running transaction check
---> Package kernel-PAE.i686 0:2.6.18-238.19.1.el5 set to be erased
--> Processing Dependency: perl-Razor-Agent = 2.84-1.el5.rf for package: razor-agents
--> Finished Dependency Resolution
razor-agents-2.84-1.el5.rf.i386 from installed has depsolving problems
  --> Missing Dependency: perl-Razor-Agent = 2.84-1.el5.rf is needed by package razor-agents-2.84-1.el5.rf.i386 (installed)
Error: Missing Dependency: perl-Razor-Agent = 2.84-1.el5.rf is needed by package razor-agents-2.84-1.el5.rf.i386 (installed)

I've try to remove perl-Razor-Agents, but server says that i couldn't because is a critical package.
If i exclude the "epel" repo, ore use --skip-broken, I can correctly update, but wouldn't use this practice...
Also tried "yum clean all" and "yum update", which doesn't work.
Note that this is not a "clean" install of SME, but there are some contribs installed (fetchmail, sysmon, qmailhandle, awstats, and more..).

Any idea?

Some info:
Code: [Select]
[root@sme ~]# /sbin/e-smith/audittools/repositories
addons: disabled
base: enabled
centosplus: disabled
contrib: disabled
epel: disabled
extras: disabled
sme7contribs: disabled
smeaddons: enabled
smecontribs: disabled
smedev: disabled
smeextras: enabled
smeos: enabled
smetest: disabled
smeupdates: enabled
smeupdates-testing: disabled
updates: enabled
virtualbox: disabled

Code: [Select]
[root@sme ~]# /sbin/e-smith/audittools/newrpms
Loaded plugins: fastestmirror, protect-packages, smeserver
Loading mirror speeds from cached hostfile
 * base: it.centos.contactlab.it
 * smeaddons: mirror.ovh.ifec.net
 * smeos: mirror.ovh.ifec.net
 * smeupdates: mirror.ovh.ifec.net
 * updates: it.centos.contactlab.it
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
Extra Packages
VirtualBox-4.1.i386                4.1.4_74291_rhel5-1                 installed
aspell.i386                        12:0.60.3-7.1.el5.sme               installed
awstats.noarch                     7.0-2.el5.rf                        installed
clamav.i386                        0.97.2-1.el5.rf                     installed
clamav-db.i386                     0.97.2-1.el5.rf                     installed
clamd.i386                         0.97.2-1.el5.rf                     installed
dimp-h3.noarch                     1.1.6-1.el5.sme                     installed
dkms.noarch                        2.1.1.2-1.el5.rf                    installed
e-smith-base.i386                  5.2.0-62.el5.sme                    installed
e-smith-email.noarch               5.2.0-14.el5.sme                    installed
e-smith-ibays.noarch               2.2.0-9.el5.sme                     installed
e-smith-ntp.noarch                 2.2.0-4.el5.sme                     installed
e-smith-proxy.noarch               5.2.0-4.el5.sme                     installed
fping.i386                         2.4b2-7.el5                         installed
kernel-PAE.i686                    2.6.18-238.19.1.el5                 installed
kernel-PAE.i686                    2.6.18-274.3.1.el5.centos.plus      installed
kronolith-h3.noarch                2.3.5-1.el5.sme                     installed
lua.i386                           5.0.2-1.el5.rf                      installed
mimp-h3.noarch                     1.1.3-1.el5.sme                     installed
mtr.i386                           2:0.80-1.el5.rfx                    installed
perl-Geo-IP.i386                   1.38-1.el5.rf                       installed
perl-rrdtool.i386                  1.4.4-1.el5.rf                      installed
php.i386                           5.3.3-1.el5.sme.1.0                 installed
php-cli.i386                       5.3.3-1.el5.sme.1.0                 installed
php-common.i386                    5.3.3-1.el5.sme.1.0                 installed
php-devel.i386                     5.3.3-1.el5.sme.1.0                 installed
php-gd.i386                        5.3.3-1.el5.sme.1.0                 installed
php-imap.i386                      5.3.3-1.el5.sme.1.0                 installed
php-ldap.i386                      5.3.3-1.el5.sme.1.0                 installed
php-mbstring.i386                  5.3.3-1.el5.sme.1.0                 installed
php-mysql.i386                     5.3.3-1.el5.sme.1.0                 installed
php-pdo.i386                       5.3.3-1.el5.sme.1.0                 installed
php-pear-Log.noarch                1.11.6-1.el5                        installed
php-soap.i386                      5.3.3-1.el5.sme.1.0                 installed
php-xml.i386                       5.3.3-1.el5.sme.1.0                 installed
proftpd.i386                       1.3.3e-1.el5                        installed
rrdtool.i386                       1.4.4-1.el5.rf                      installed
rsync.i386                         3.0.8-1.el5.rfx                     installed
smeserver-awstats.noarch           1.2-7.el4.sme                       installed
smeserver-dimp.noarch              1.0-2.el5.sme                       installed
smeserver-fetchmail.noarch         1.3.6-21.el4.sme                    installed
smeserver-kronolith.noarch         2.2-14.el5                          installed
smeserver-locale-bg.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-da.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-de.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-el.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-es.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-et.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-fr.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-he.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-hu.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-id.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-it.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-ja.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-nb.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-nl.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-pl.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-pt.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-pt_BR.noarch      2.2.0-38.el5.sme                    installed
smeserver-locale-ro.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-ru.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-sl.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-sv.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-th.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-tr.noarch         2.2.0-38.el5.sme                    installed
smeserver-locale-zh_CN.noarch      2.2.0-38.el5.sme                    installed
smeserver-locale-zh_TW.noarch      2.2.0-38.el5.sme                    installed
smeserver-mimp.noarch              1.1-3.el5.sme                       installed
smeserver-release.noarch           26:8.0-0.beta6.el5.sme              installed
smeserver-saco-qmHandle.noarch     1.3.4-3                             installed
smeserver-support.noarch           2.2.0-18.el5.sme                    installed
smeserver-sysmon.noarch            6.2-1.el5.sme                       installed

Code: [Select]
[root@sme ~]# uname -a
Linux sme 2.6.18-274.7.1.el5PAE #1 SMP Thu Oct 20 17:03:59 EDT 2011 i686 i686 i386 GNU/Linux

Code: [Select]
[root@sme ~]# uptime
 15:01:29 up 29 min,  1 user,  load average: 0.11, 0.08, 0.26

Offline CharlieBrady

  • *
  • 6,918
  • +3/-0
Re: beta7 upgrade - dependency problem with pear-Razor-Agents
« Reply #1 on: January 04, 2012, 07:07:23 PM »
Hi all,
i'm trying to upgrade my SMEb6 to SMEb7.
If i try from server-manager, got this error:

If you have an error use the "Bugs" link on this page to create a bug report.

http://bugs.contribs.org/

Reminder:

Don't report problems here - Please report bugs and potential bugs in the bug tracker

Offline maicz

  • *
  • 26
  • +0/-0
Re: beta7 upgrade - dependency problem with pear-Razor-Agents
« Reply #2 on: January 04, 2012, 07:27:10 PM »
Sorry, i'm opening a bug.

Offline cactus

  • *
  • 4,880
  • +3/-0
    • http://www.snetram.nl
Re: beta7 upgrade - dependency problem with pear-Razor-Agents
« Reply #3 on: January 04, 2012, 08:27:04 PM »
Sorry, i'm opening a bug.
If you have done so please post a reference for future readers.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline maicz

  • *
  • 26
  • +0/-0
Re: beta7 upgrade - dependency problem with pear-Razor-Agents
« Reply #4 on: January 04, 2012, 09:41:42 PM »
It seems that I solved with

Code: [Select]
[root@sme ~]# rpm -e --nodeps perl-Razor-Agent
that successfully removed the package so i can do yum clean all, and yum --enablerepo=* update

than again, when all system is updated, if i install the missing package:
Code: [Select]
[root@sme ~]# yum install perl-Razor-Agent i have already the problem when run yum update.

If useful, i can open a bug anyway.