Koozali.org: home of the SME Server

Windows 7 Domain Login - SME 8 B7

Offline j_radue

  • *
  • 30
  • +0/-0
Windows 7 Domain Login - SME 8 B7
« on: February 26, 2012, 07:29:31 PM »
Hello folks, long time lurker and first time posting. I recently switched my home server over to SME 8B7 from 7.5.1. I have used SME 7 for a number of years with no problems. After the changeover I was able to get my Windows 7 machine doing domain authentication by applying the register patch in server resources. However, Windows 7 will not let me browse the domain server directly. I can access folders via a mapped drive only. My server appears in the network list, but when I click on it to browse, I get the following:


"\\ATHLON-SERVER is not accessible. You might not have permission to use the network resource. Contact the administrator of this server to fin out if you have access permissions.  A device attached to the system is not functioning"

I realize this may be more of an issue with Windows and not SME, but any input would be helpful. Again, I can reach any ibay on the server via mapped network drive, but not by browsing.



Offline chris burnat

  • ****
  • 1,135
  • +2/-0
    • http://www.burnat.com
Re: Windows 7 Domain Login - SME 8 B7
« Reply #1 on: February 27, 2012, 12:39:37 AM »
I can reach any ibay on the server via mapped network drive, but not by browsing.

Please explain what you mean by "browsing", and how you set up your mapped drives.
Thanks
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Offline j_radue

  • *
  • 30
  • +0/-0
Re: Windows 7 Domain Login - SME 8 B7
« Reply #2 on: February 27, 2012, 01:03:40 AM »
Quote
Please explain what you mean by "browsing", and how you set up your mapped drives.

In Windows 7, I go to "Computer". It shows the Domain server as part of the Network on the left pane. When I click on the server, it gives me the message I posted above. I have since found out that if I enter the IP address of the server, \\10.10.1.1, if will show the contents. However, not when I enter the server name or click on the server icons.

To set up the mapped drives I simply right click on the "Computer" or "Network" options and manually enter the shared folder location.


Thanks for your rely..


Offline chris burnat

  • ****
  • 1,135
  • +2/-0
    • http://www.burnat.com
Re: Windows 7 Domain Login - SME 8 B7
« Reply #3 on: February 27, 2012, 01:18:04 AM »
OK, the next step would be to check how you moved from Version 7 to version 8, and so on and so forth. ..  This would best be carried out at Bugzilla, please open a bug and provide as much information as possible. Thanks.
chris
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Offline j_radue

  • *
  • 30
  • +0/-0
Re: Windows 7 Domain Login - SME 8 B7
« Reply #4 on: February 27, 2012, 01:28:35 AM »
Ok, one last thing I will add is that everything was working as expected before I changed my Win 7 machine to domain authentication.

Offline chris burnat

  • ****
  • 1,135
  • +2/-0
    • http://www.burnat.com
Re: Windows 7 Domain Login - SME 8 B7
« Reply #5 on: February 27, 2012, 01:40:05 AM »
Ok, one last thing I will add is that everything was working as expected before I changed my Win 7 machine to domain authentication.

Thanks.  Please open a bug.
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Offline j_radue

  • *
  • 30
  • +0/-0
Re: Windows 7 Domain Login - SME 8 B7
« Reply #6 on: February 27, 2012, 09:50:12 PM »

Offline mercyh

  • *
  • 824
  • +0/-0
    • http://mercyh.org
Re: Windows 7 Domain Login - SME 8 B7
« Reply #7 on: February 28, 2012, 10:18:04 PM »
do you have your SME set as the ONLY DNS server on your windows 7 machine? If you are set up to receive an IP address from a DHCP server and the DHCP server is not the SME box, you will need to set it to hand out your SME IP address as the DNS server.

The Domain Controller MUST be the DNS server on windows domains to allow proper browsing of the domain.

« Last Edit: February 28, 2012, 10:20:13 PM by mercyh »

Offline chris burnat

  • ****
  • 1,135
  • +2/-0
    • http://www.burnat.com
Re: Windows 7 Domain Login - SME 8 B7
« Reply #8 on: February 28, 2012, 10:42:48 PM »
do you have your SME set as the ONLY DNS server on your windows 7 machine? If you are set up to receive an IP address from a DHCP server and the DHCP server is not the SME box, you will need to set it to hand out your SME IP address as the DNS server.

The Domain Controller MUST be the DNS server on windows domains to allow proper browsing of the domain.

The issue in this post is not about browsing the internet, but "browsing" shared resources on the network.
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Offline mercyh

  • *
  • 824
  • +0/-0
    • http://mercyh.org
Re: Windows 7 Domain Login - SME 8 B7
« Reply #9 on: February 28, 2012, 11:03:56 PM »
Quote
The issue in this post is not about browsing the internet, but "browsing" shared resources on the network.

I understand this point. (Although I well may not understand the issue). If the OP can browse by server IP and not by server name, it would seem that the problem may be name resolution WITHIN the domain.

If there is a way to make a Domain controller work without it configured as the Primary DNS server on the domain clients I would love to know how to do it as this would allow me to work around an issue I have.

Offline j_radue

  • *
  • 30
  • +0/-0
Re: Windows 7 Domain Login - SME 8 B7
« Reply #10 on: February 28, 2012, 11:22:50 PM »
I thought is may be a local DNS issue also. When I type \\athlon-server, I get the error. If I type \\10.10.1.1, that works. However, the system will map \\athlon-server\shared_files, so if is understanding the DNS at some point.

Offline mercyh

  • *
  • 824
  • +0/-0
    • http://mercyh.org
Re: Windows 7 Domain Login - SME 8 B7
« Reply #11 on: February 28, 2012, 11:27:34 PM »
Do you have 10.10.1.1 set as the DNS server on the windows 7 machine?


Offline j_radue

  • *
  • 30
  • +0/-0
Re: Windows 7 Domain Login - SME 8 B7
« Reply #12 on: February 28, 2012, 11:37:46 PM »
Yes, when I look at the adapter properties the IPV4 DNS is 10.10.1.1, but IPV6 DNS is blank, even though I have an IPV6 address.

Offline mercyh

  • *
  • 824
  • +0/-0
    • http://mercyh.org
Re: Windows 7 Domain Login - SME 8 B7
« Reply #13 on: February 28, 2012, 11:58:02 PM »
the problem is not your DNS settings then. Your settings sound correct.