Koozali.org: home of the SME Server

Phpmyadmin is breaken

Offline Jean-Philippe Pialasse

  • *
  • 2,207
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Phpmyadmin is breaken
« Reply #15 on: September 24, 2012, 05:40:39 PM »
well in fact they are in place (just checked)

Indeed old one is still there i will have a look with Shad to remove the old one from repo.


When you do a clean install which ones are installed :
smeserver-phpmyadmin-3.5.2.2-2.el5.sme.noarch.rpm
and

phpMyAdmin3-3.5.2.2-1.el5.noarch.rpm

or
phpmyadmin-2.11.11.3-2.el5.rf.noarch.rpm

if you update it should also remove all old package .


a
Code: [Select]
rpm -qa|grep -i 'phpmyadmin' should only  return after installation or update
Code: [Select]
smeserver-phpmyadmin-3.5.2.2-1.el5.sme
phpMyAdmin3-3.5.2.2-1.el5

i also need to update the wiki

Offline Jean-Philippe Pialasse

  • *
  • 2,207
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Phpmyadmin is breaken
« Reply #16 on: September 24, 2012, 05:53:44 PM »
wiki updated : http://wiki.contribs.org/PHPMyAdmin

and also : http://wiki.contribs.org/SME8.0_Contribs_QA#smeserver-phpmyadmin



sorry for phpmyadmin multiuser adept do not have the time right now to adapt it, maybe in the next month.

Offline Mntsnow

  • **
  • 59
  • +0/-0
    • http://www.mntsnow.com
Re: Phpmyadmin is breaken
« Reply #17 on: September 24, 2012, 07:03:53 PM »
On my SME 8.0 64bit Clean install it returned
phpMyAdmin3-3.5.2.2-1.el5
smeserver-phpmyadmin-3.5.2.2-2.el5.sme

On my SME 8.0 32bit Clean install it returned
phpMyAdmin3-3.5.2.2-1.el5
smeserver-phpmyadmin-3.5.2.2-2.el5.sme

So it looks like the packages came through ok to my new installs over the weekend (did the 32bit Saturday and then the 64bit on Sunday)



SME-8 64bit
PowerEdge 1950 III
(2) Quad Core Xeon x5460 @ 3.16GHz
24Gb Memory
PERC 5i raid controller
4 x 500Gb SAS 7.2K Drives in Raid 5
Dual 1Gb Nics

Offline Jean-Philippe Pialasse

  • *
  • 2,207
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Phpmyadmin is breaken
« Reply #18 on: September 24, 2012, 07:56:14 PM »
so everything is good.

they were release in smecontribs on 9 /9/2012

Offline mike_mattos

  • *
  • 313
  • +0/-0
Re: Phpmyadmin is breaken
« Reply #19 on: September 26, 2012, 03:29:43 PM »
I've been using  adminer  instead of phpmyadmin  lately due to the above issues

http://www.adminer.org/en/phpmyadmin/

anyone have any experience on it?
...

Offline davidS

  • ***
  • 80
  • +0/-0
Re: Phpmyadmin is breaken
« Reply #20 on: September 28, 2012, 02:07:14 PM »
hello
is this version support multi user login ???
Because after installation I can only login with Admin

Offline Jean-Philippe Pialasse

  • *
  • 2,207
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Phpmyadmin is breaken
« Reply #21 on: September 28, 2012, 03:55:19 PM »
Hello,

hello
is this version support multi user login ???
Because after installation I can only login with Admin

as stated above:

sorry for phpmyadmin multiuser adept do not have the time right now to adapt it, maybe in the next month.

sorry for the inconvenients.

it is not a hard job to adapt it, but i am curently in a rush .


Offline newburns

  • *
  • 345
  • +0/-0
  • A good plumber, noob developer
    • Mt. Rose MEdia
Re: Phpmyadmin is breaken
« Reply #22 on: September 28, 2012, 04:08:55 PM »
I have SME 8 x64 and received the following error. I also get a similar error during my normal updates, but that's a different issue.
Code: [Select]
php-process-5.3.3-1.el5.sme.6.x86_64 from installed has depsolving problems
  --> Missing Dependency: php-common = 5.3.3-1.el5.sme.6 is needed by package php-process-5.3.3-1.el5.sme.6.x86_64 (installed)
Error: Missing Dependency: php-common = 5.3.3-1.el5.sme.6 is needed by package php-process-5.3.3-1.el5.sme.6.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

I ran
Code: [Select]
yum --enablerepo=smecontribs install smeserver-phpmyadmin
« Last Edit: September 28, 2012, 04:13:46 PM by newburns »
SME 8.0
Quad 6600
8gb DDR2 800
8 TB RAID 5
Dual Gigabit NIC
I Still Don't KNOW WHAT I AM DOING. Please, don't assume I know anything about Linux or Centos, I just know hardware

Offline Jean-Philippe Pialasse

  • *
  • 2,207
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Phpmyadmin is breaken
« Reply #23 on: September 28, 2012, 04:35:34 PM »
I have SME 8 x64 and received the following error. I also get a similar error during my normal updates, but that's a different issue.
Code: [Select]
php-process-5.3.3-1.el5.sme.6.x86_64 from installed has depsolving problems
  --> Missing Dependency: php-common = 5.3.3-1.el5.sme.6 is needed by package php-process-5.3.3-1.el5.sme.6.x86_64 (installed)
Error: Missing Dependency: php-common = 5.3.3-1.el5.sme.6 is needed by package php-process-5.3.3-1.el5.sme.6.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

they are related, your php package is not up to date


if you have this for update  (excluding smecontribs repo) and for installation of phpmyadmin . please raise a bug in order to investigate add me in cc for the bug

i would alsofirst try update your php process as it is out dated

yum install php-process
 php-process                             x86_64                             5.3.3-13.el5.sme.1                              smeaddons                              40 k


so try
Code: [Select]
yum update php
« Last Edit: September 28, 2012, 04:56:18 PM by unnilennium »

Offline animare

  • *
  • 29
  • +0/-0
Re: Phpmyadmin is breaken
« Reply #24 on: September 29, 2012, 09:26:54 PM »
I've downloaded and placed phpmyadmin in an ibay. And it runs great.

I have a very basic understanding for the sme server, could someone explain to me why there is a need for a phpmyadmin sme package?

Thanks

Offline pwarren

  • 7
  • +0/-0
Re: Phpmyadmin is breaken
« Reply #25 on: October 10, 2012, 01:28:42 AM »
The Wiki instructions appear to not be correct, the expand-template command needs to be

expand-template /etc/phpMyAdmin/config.inc.php

After doing that, phpmyadmin started working fine for me. Before that, I would be repeatedly asked to log in, and even with the correct username and password, I couldn't get in.
« Last Edit: October 10, 2012, 01:31:34 AM by pwarren »

Offline Jean-Philippe Pialasse

  • *
  • 2,207
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Phpmyadmin is breaken
« Reply #26 on: October 10, 2012, 06:24:27 AM »
true for sme8 the config file is not at the same place

i update the wiki