Koozali.org: home of the SME Server

SharedFolder access problem with Win7 via webdav

Offline alext

  • ***
  • 91
  • +0/-0
SharedFolder access problem with Win7 via webdav
« on: November 11, 2012, 06:32:31 PM »
I am running SME 7.6 and SharedFolders V1.74 as advised by VIP-ire in topic,

http://forums.contribs.org/index.php/topic,49158.0.html in this forum.

I am using webdav and https to access ther shared folders.

Up to now I have been testing with Windows XP prof. SP3 and I have been able to create a network location to my shared folders successfully.

I then attempted to create the same network  location on a Windows 7 Home 64-bit workstation using exactly the same parameters and user as on the XP workstation. This fails with an error stating "The folder you entered does not appearto be valid. Please choose another".

I checked around on the Internet and found an interesting comment in the folowing site,


Here the author suggests that Widows 7 uses AuthDigest for authentication rather than Basic.

I have tried his suggestion to modify a parameter in the Windows 7 registry but that didn't work.

But in any case, as I don't know what OS the remote workstations are using, changing registry parameters on workstations is not a workable solution.

Is there a workaround for the SME server to accept both Basic and AuthDigest authentication?

Has anybody else run into this problem?


Offline daniel

  • ***
  • 146
  • +0/-0
  • Platinum Sponsor
    • http://www.charton-mgmt.com
Re: SharedFolder access problem with Win7 via webdav
« Reply #1 on: November 30, 2012, 04:45:00 AM »
I found a program for win7  www.netdrive.net  This worked on my home smeserver 8 and loading up windows 7 drives and it supports https connections too.

Offline alext

  • ***
  • 91
  • +0/-0
Re: SharedFolder access problem with Win7 via webdav
« Reply #2 on: December 09, 2012, 03:23:36 PM »
Thanks Daniel.

Haven't had time to reply up to now.

I downloaded NETDRIVE and tried it first on a Win XP workstation - success!

I then tried it on a Win 7 workstation and that went well too.
Only problem was that on startup the Win7 system reported that there was another instance of NETDRIVE running.
I attempted to look at the NETDRIVE forums but they were FULL of spam adverts so I Googled the problem and found that the fix was to run MSCONFIG, look in the Startup tag and check for two instances of NETDRIVE. This I found and deleted the second one.

Many thanks for your help,

Offline mmccarn

  • *
  • 2,588
  • +8/-0
Re: SharedFolder access problem with Win7 via webdav
« Reply #3 on: December 09, 2012, 03:50:15 PM »
Barracuda thinks the 'digest auth' issue is really a bug in windows:
Many Windows computers have a bug in the digest authentication process and thus authenticating using the above procedure will fail. You have the bug in your computer if the "Windows credentials dialogue" reappears after you have entered the correct username and password. It is possible to circumvent this bug by mapping the drive from the command line. Note, if the "Windows credentials dialogue" reappears, you must reboot your Windows computer before using the command line. Windows will continue to fail if you do not reboot. This is also true if you accidently enter the wrong credentials.

Do the following to map a drive and authenticate from the command line:

Open a command window (DOS Window) by clicking the Windows start button and typing in the command "cmd" in the "run" or "search programs ..." box.
Type the following command in the command window:
Code: [Select]
NET USE * http://servername/fs/ password /USER:username

Also, years ago I needed to setup a persistent webdav shortcut to a Microsoft Exchange public folder.  I found out then that you have to change the properties of the "WebClient" service in Windows 7 to "Automatic" or your mapped drive (or share) will not re-open easily after you reboot, but will give you the auth dialog over and over...

I have just verified that Windows 7 home premium 64 bit fails to connect to a microsoft webdav server through the GUI, but succeeds at a command prompt.

However, after a failed GUI login attempt, I had to stop and restart the "webclient" service before the command line method would work.  To stop and restart "webclient", I had to:
* open CMD "as administrator"
* net stop webclient
* net start webclient
« Last Edit: December 09, 2012, 04:16:01 PM by mmccarn »

Offline chris burnat

  • ****
  • 1,135
  • +2/-0
    • http://www.burnat.com
Re: SharedFolder access problem with Win7 via webdav
« Reply #4 on: December 09, 2012, 11:37:25 PM »
Barracuda thinks the 'digest auth' issue is really a bug in windows:
Great post, I experienced this and could not really figure it out. Thanks!
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.