Koozali.org: home of the SME Server

[SOLVED] No Mail Delivery since last Update

Offline soundrolf

  • *
  • 38
  • +0/-0
[SOLVED] No Mail Delivery since last Update
« on: April 22, 2013, 02:47:33 PM »
Saturday April 20 I did Update SME Server 7.6  28 Updates and 11 new packages
Sice them no email delivery from one to another.
The working people using groupoffice. They do need email to make appointments to each other.
I need help.
I made after update signal-event post-upgrade; signal-event reboot
as well I did today monday april 22 signal-event user-modify and signal-event email-update
no changes. still no email delivery.
What can I do else

Rolf
« Last Edit: April 24, 2013, 03:39:13 PM by soundrolf »

Offline Stefano

  • *
  • 10,852
  • +2/-0
Re: No Mail Delivery since last Update
« Reply #1 on: April 22, 2013, 07:34:01 PM »
you should start telling us how is your server configured..
then, do you see something wrong in /var/log/qpsmtpd/current?

Offline soundrolf

  • *
  • 38
  • +0/-0
Re: No Mail Delivery since last Update
« Reply #2 on: April 23, 2013, 01:43:43 PM »
Server is a standalone one behind a wlan router, with static IP and no DHCP. Groupwaresolution is Groupoffice

Since Update I have these messages in /var/log/qpsmtpd/current

@400000005175312f05a3c384 4331 cleaning up after 497
@400000005175324f2bb47bf4 4322 tls plugin (init): ciphers: HIGH:!SSLv2
@400000005175324f2f2b5334 4322 Listening on 0.0.0.0:25
@400000005175324f2f2b5b04 4322 Running as user qpsmtpd, group qpsmtpd
@400000005175324f2f2b5eec 4322 Initializing spool_dir
@400000005175324f2f2b66bc 4322 Permissions on spool_dir /var/spool/qpsmtpd/ are not 0700
@400000005175324f2f2b6aa4 4322 size_threshold set to 0
@40000000517536b301269804 method Net::DNS::Header::nextid undefined at /usr/bin/qpsmtpd-forkserver line 292
@40000000517536b3018f77ac 4322 cleaning up after 5966

-------------------

the Tail of these messages

@400000005176502b1074c6b4 method Net::DNS::Header::nextid undefined at /usr/bin/qpsmtpd-forkserver line 292
@400000005176502b10f25354 4322 cleaning up after 2084
@400000005176502b11070fec method Net::DNS::Header::nextid undefined at /usr/bin/qpsmtpd-forkserver line 292
@400000005176502c10eb5e14 4322 cleaning up after 2085

Some suggestions ?

Offline Stefano

  • *
  • 10,852
  • +2/-0
Re: No Mail Delivery since last Update
« Reply #3 on: April 23, 2013, 03:22:37 PM »
well.. it should not happen

I suspect you update your server with some repo enabled that should not..

please raise a bug in bugzilla  and report here the reference, thank you

Offline soundrolf

  • *
  • 38
  • +0/-0
Re: No Mail Delivery since last Update
« Reply #4 on: April 23, 2013, 03:27:03 PM »
I did not update with any enabled repo. this sever is a working server of my sister in her office.
The same has happen to my personal server here at my home. as well NOT enabled any repo.
If this will happen to other people, they will have fun !

Offline Stefano

  • *
  • 10,852
  • +2/-0
Re: No Mail Delivery since last Update
« Reply #5 on: April 23, 2013, 03:36:34 PM »
then you MUST file a bug because an update should NOT break anyone server..

you are the only that can open a bug because it seems you are the only with this issue and so the only that can give any useful info to the devs

thank you

Offline soundrolf

  • *
  • 38
  • +0/-0
Re: No Mail Delivery since last Update
« Reply #6 on: April 23, 2013, 03:58:02 PM »

Offline Stefano

  • *
  • 10,852
  • +2/-0
Re: No Mail Delivery since last Update
« Reply #7 on: April 23, 2013, 03:58:57 PM »
thank you

Offline soundrolf

  • *
  • 38
  • +0/-0
Re: [SOLVED] No Mail Delivery since last Update
« Reply #8 on: April 24, 2013, 03:41:33 PM »
rpm -Uhv --oldpackage \
http://distro.ibiblio.org/smeserver/releases/7/smeos/i386/SME/RPMS/perl-Net-DNS-0.68-1.el4.rfx.i386.rpm

sv t /service/qpsmtpd /service/sqpsmtpd

Problem Solved; Email delivery works as expected. Perfect

Thanks to Stefano Zamboni, Chris Burnat and Charlie Brady


http://bugs.contribs.org/show_bug.cgi?id=7554
« Last Edit: April 24, 2013, 06:07:38 PM by soundrolf »