Koozali.org: home of the SME Server

Last Update

Offline yythoss

  • *
  • 500
  • +0/-0
    • http://www.hylafax-client.de
Last Update
« on: November 20, 2018, 01:23:17 AM »
yum update tries to install a wrong rpm

Code: [Select]
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Package clamav.x86_64 0:0.100.2-1.el6.sme will be aktualisiert
---> Package clamav.x86_64 0:0.100.2-4.el6.sme will be an update
---> Package clamav-db.x86_64 0:0.100.2-1.el6.sme will be aktualisiert
---> Package clamav-db.x86_64 0:0.100.2-4.el6.sme will be an update
---> Package clamd.x86_64 0:0.100.2-1.el6.sme will be aktualisiert
---> Package clamd.x86_64 0:0.100.2-4.el6.sme will be an update
---> Package e-smith-base.noarch 0:5.6.0-31.el6.sme will be aktualisiert
---> Package e-smith-base.x86_64 0:5.8.0-38.el7.sme will be an update
---> Package e-smith-ntp.noarch 0:2.4.0-6.el6.sme will be aktualisiert
---> Package e-smith-ntp.noarch 0:2.4.0-7.el6.sme will be an update
---> Package e-smith-samba.noarch 0:2.4.0-25.el6.sme will be aktualisiert
---> Package e-smith-samba.noarch 0:2.4.0-26.el6.sme will be an update
---> Package perl-Mail-DMARC.noarch 0:1.20141206-1.el6.sme will be aktualisiert
---> Package perl-Mail-DMARC.noarch 0:1.20141206-2.el6.sme will be an update
--> Abhängigkeitsauflösung beendet

Abhängigkeiten aufgelöst

================================================================================================================================================================
 Paket                                   Arch                           Version                                        Repository                         Grösse
================================================================================================================================================================
Aktualisieren:
 clamav                                  x86_64                         0.100.2-4.el6.sme                              smeupdates                         1.3 M
 clamav-db                               x86_64                         0.100.2-4.el6.sme                              smeupdates                         162 M
 clamd                                   x86_64                         0.100.2-4.el6.sme                              smeupdates                         234 k
 e-smith-base                            x86_64                         5.8.0-38.el7.sme                               smeupdates                         348 k
 e-smith-ntp                             noarch                         2.4.0-7.el6.sme                                smeupdates                          52 k
 e-smith-samba                           noarch                         2.4.0-26.el6.sme                               smeupdates                         107 k
 perl-Mail-DMARC                         noarch                         1.20141206-2.el6.sme                           smeupdates                         994 k

Vorgangsübersicht
================================================================================================================================================================
Upgrade       7 Package(s)

Gesamte Downloadgrösse: 165 M
Ist dies in Ordnung? [j/N] :j
Lade Pakete herunter:
(1/7): clamav-0.100.2-4.el6.sme.x86_64.rpm                                                                                               | 1.3 MB     00:00
(2/7): clamav-db-0.100.2-4.el6.sme.x86_64.rpm                                                                                            | 162 MB     01:36
(3/7): clamd-0.100.2-4.el6.sme.x86_64.rpm                                                                                                | 234 kB     00:00
(4/7): e-smith-base-5.8.0-38.el7.sme.x86_64.rpm                                                                                          | 348 kB     00:00
(5/7): e-smith-ntp-2.4.0-7.el6.sme.noarch.rpm                                                                                            |  52 kB     00:00
(6/7): e-smith-samba-2.4.0-26.el6.sme.noarch.rpm                                                                                         | 107 kB     00:00
(7/7): perl-Mail-DMARC-1.20141206-2.el6.sme.noarch.rpm                                                                                   | 994 kB     00:01
----------------------------------------------------------------------------------------------------------------------------------------------------------------
Gesamt                                                                                                                          1.6 MB/s | 165 MB     01:40
warning: rpmts_HdrFromFdno: Header V4 RSA/SHA1 Signature, key ID 56873151: NOKEY


Öffentlicher Schlüssel für e-smith-base-5.8.0-38.el7.sme.x86_64.rpm ist nicht installiert


Package e-smith-base.x86_64 0:5.8.0-38.el7.sme is for CentOS7

Offline TerryF

  • grumpy old man
  • *
  • 1,717
  • +2/-0
Re: Last Update
« Reply #1 on: November 20, 2018, 01:48:27 AM »
Damn, wrong ver moved, please

Exclude e-smith-base for time being until a higher power can fix it

You are doing well there, I am not even seeing the updates yet down here
--
qui scribit bis legit

Offline TerryF

  • grumpy old man
  • *
  • 1,717
  • +2/-0
Re: Last Update
« Reply #2 on: November 20, 2018, 02:00:20 AM »
Yep a SME10 update and a SME9 update its been a long couple of days, not an excuse just a fact..

I don't have power to resolve, need a higher power than I :-)

It will be fixed in a few hours

In meantime #
yum update --exclude e-smith-base

Added: Timezones aren't helping here
« Last Edit: November 20, 2018, 02:11:07 AM by TerryF »
--
qui scribit bis legit

Offline ReetP

  • *
  • 3,291
  • +5/-0
Re: Last Update
« Reply #3 on: November 20, 2018, 09:56:41 AM »
I'm not sure how I did that :-( Sorry.

I have pulled the update.

Just trying to kick buildsys to build a new v9 version as the original is not there.

I'll get the correct version over as soon as I can but it might be a few hours as I have to go out this morning.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline TerryF

  • grumpy old man
  • *
  • 1,717
  • +2/-0
Re: Last Update
« Reply #4 on: November 20, 2018, 11:24:04 AM »
No biggy, no sheep stations are at risk... :-)
--
qui scribit bis legit

Offline ReetP

  • *
  • 3,291
  • +5/-0
Re: Last Update
« Reply #5 on: November 20, 2018, 11:42:03 AM »
LOLz....
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline ReetP

  • *
  • 3,291
  • +5/-0
Re: Last Update
« Reply #6 on: November 20, 2018, 02:12:29 PM »
OK - and released and in a mirror near you soon I hope.

smeserver/9/updates/e-smith-base-5.6.0-34.el6.sme.noarch.rpm

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Mophilly

  • ****
  • 381
  • +0/-0
    • Mophilly
Re: Last Update
« Reply #7 on: November 20, 2018, 06:06:59 PM »
Nov 20, 9 AM Pacific time. yum update failed.
Code: [Select]
Error Downloading Packages:
  e-smith-base-5.8.0-38.el7.sme.x86_64: failure: RPMS/e-smith-base-5.8.0-38.el7.sme.x86_64.rpm from smeupdates: [Errno 256] No more mirrors to try.

I notice that this message refers to e-smith-base-5.8.0, while ReetP's post mentions e-smith-base-5.6.0. Perhaps a dependency in clamd-0.100?
« Last Edit: November 20, 2018, 06:16:05 PM by Mophilly »
- Mark

Offline ReetP

  • *
  • 3,291
  • +5/-0
Re: Last Update
« Reply #8 on: November 20, 2018, 06:36:41 PM »
No - the el7 version (which was wrong) is 5.8.x whereas the correct el6 version should be 5.6.x

If anyone gets stuck you might want to try :

Code: [Select]
yum clean metadata
yum update

Apologies once again :-(
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Mophilly

  • ****
  • 381
  • +0/-0
    • Mophilly
Re: Last Update
« Reply #9 on: November 20, 2018, 06:52:54 PM »
yum clean then update worked for me!
Thanks!
- Mark

Offline slicknic

  • *
  • 23
  • +0/-0
    • http://www.oasisdriving.co.uk
Re: Last Update
« Reply #10 on: November 22, 2018, 10:28:28 PM »
Hello,

Also having some issues with the latest updates. This time with dependencies.

[root@gateway ~]# yum update
Loaded plugins: fastestmirror, smeserver
Setting up Update Process
Loading mirror speeds from cached hostfile
 * smeaddons: smeserver.de-labrusse.fr
 * smeextras: smeserver.de-labrusse.fr
 * smeos: smeserver.de-labrusse.fr
 * smeupdates: smeserver.de-labrusse.fr
Resolving Dependencies
--> Running transaction check
---> Package clamav.x86_64 0:0.99.3-1.el6.sme will be updated
---> Package clamav.x86_64 0:0.100.2-4.el6.sme will be an update
---> Package clamav-db.x86_64 0:0.99.3-1.el6.sme will be updated
---> Package clamav-db.x86_64 0:0.100.2-4.el6.sme will be an update
---> Package clamd.x86_64 0:0.99.3-1.el6.sme will be updated
---> Package clamd.x86_64 0:0.100.2-4.el6.sme will be an update
---> Package djbdns.x86_64 0:1.05-8.el6.sme will be updated
---> Package djbdns.x86_64 0:1.05-11.el6.sme will be an update
---> Package e-smith-base.noarch 0:5.6.0-31.el6.sme will be updated
---> Package e-smith-base.noarch 0:5.6.0-34.el6.sme will be an update
---> Package e-smith-ntp.noarch 0:2.4.0-6.el6.sme will be updated
---> Package e-smith-ntp.noarch 0:2.4.0-7.el6.sme will be an update
---> Package e-smith-pop3.noarch 0:2.4.0-6.el6.sme will be updated
---> Package e-smith-pop3.noarch 0:2.4.0-8.el6.sme will be an update
---> Package e-smith-qmail.noarch 0:2.4.0-7.el6.sme will be updated
---> Package e-smith-qmail.noarch 0:2.4.0-8.el6.sme will be an update
---> Package e-smith-samba.noarch 0:2.4.0-24.el6.sme will be updated
---> Package e-smith-samba.noarch 0:2.4.0-26.el6.sme will be an update
---> Package perl-Mail-DMARC.noarch 0:1.20141206-1.el6.sme will be updated
---> Package perl-Mail-DMARC.noarch 0:1.20141206-2.el6.sme will be an update
---> Package qpsmtpd.noarch 0:0.96-10.el6.sme will be updated
---> Package qpsmtpd.noarch 0:0.96-11.el6.sme will be an update
---> Package smeserver-yum.noarch 0:2.4.0-15.el6.sme will be updated
---> Package smeserver-yum.noarch 0:2.4.0-17.el6.sme will be an update
--> Processing Dependency: yum-plugin-post-transaction-actions for package: smeserver-yum-2.4.0-17.el6.sme.noarch
--> Finished Dependency Resolution
Error: Package: smeserver-yum-2.4.0-17.el6.sme.noarch (smeupdates)
           Requires: yum-plugin-post-transaction-actions
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



...
Oasis Driving School - Bristol
www.oasisdriving.co.uk

Offline TerryF

  • grumpy old man
  • *
  • 1,717
  • +2/-0
Re: Last Update
« Reply #11 on: November 22, 2018, 11:02:57 PM »
Not my work, I would have gotten there eventually but I am sloowwww..

Thanks John..

You do not have the updates repo enabled

# db yum_repositories setprop updates status enabled;signal-event yum-modify
--
qui scribit bis legit

Offline ReetP

  • *
  • 3,291
  • +5/-0
Re: Last Update
« Reply #12 on: November 22, 2018, 11:40:40 PM »
Chortle.

Just happened to get to my desk and have a server that hadn't been updated....
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline slicknic

  • *
  • 23
  • +0/-0
    • http://www.oasisdriving.co.uk
Re: Last Update
« Reply #13 on: November 23, 2018, 11:50:09 AM »

You do not have the updates repo enabled

# db yum_repositories setprop updates status enabled;signal-event yum-modify

Ah thank you. Ok now.
...
Oasis Driving School - Bristol
www.oasisdriving.co.uk