Koozali.org: home of the SME Server

Another Letsencrypt error

Offline j_radue

  • *
  • 30
  • +0/-0
Another Letsencrypt error
« on: January 19, 2021, 06:38:13 PM »
I installed Letsencrypt a while ago and it was working perfectly. My SSL expired and when I tried to renew, but received the following error:


ERROR: Challenge is invalid! (returned: invalid) (result: {
  "type": "http-01",
  "status": "invalid",
  "error": {
    "type": "urn:ietf:params:acme:error:unauthorized",
    "detail": "Invalid response from http://raduehome.net/.well-known/acme-challenge/B6Wu7Emgy_auJyg1ko4jJzO6XRI5B9et1zEflDX-2-8 [184.21.5.186]: \"\u003c!DOCTYPE HTML PUBLIC \\\"-//IETF//DTD HTML 2.0//EN\\\"\u003e\\n\u003chtml\u003e\u003chead\u003e\\n\u003ctitle\u003e403 Forbidden\u003c/title\u003e\\n\u003c/head\u003e\u003cbody\u003e\\n\u003ch1\u003eForbidden\u003c/h1\u003e\\n\u003cp\"",
    "status": 403
  },
  "url": "https://acme-staging-v02.api.letsencrypt.org/acme/chall-v3/194945635/Wq-Guw",
  "token": "(removed)",
  "validationRecord": [
    {
      "url": "http://raduehome.net/.well-known/acme-challenge/(removed)",
      "hostname": "raduehome.net",
      "port": "80",
      "addressesResolved": [
        "184.21.5.186"
      ],
      "addressUsed": "184.21.5.186"
    }
  ]
})


The httpd error log shows:

[error] [client 18.224.20.83] access to /home/e-smith/files/ibays/Primary/html/.well-known/acme-challenge/{removed) failed, reason: SSL connection required

Now I have tried all the fixed posted in other topics about similar issues, but none have fixed the problem. It appears the problem occurs when the primary domain challenge is initiated and it bombs because of a lack of an SSL connection. How do I remove the requirement for an SSL connections?

Offline TerryF

  • grumpy old man
  • *
  • 1,717
  • +2/-0
Re: Another Letsencrypt error
« Reply #1 on: January 19, 2021, 09:07:33 PM »
--
qui scribit bis legit

Offline j_radue

  • *
  • 30
  • +0/-0
Re: Another Letsencrypt error
« Reply #2 on: January 19, 2021, 09:19:05 PM »
Wow! That was simple. It worked perfectly.  Thank you so much for the response!