Koozali.org: home of the SME Server

smeserver V10 "Warning: a reconfigure and reboot is required before proceeding"

Offline adili

  • *
  • 15
  • +0/-0
Bonjour,

J'ai ce message qui persiste sur la page server-manager malgré plusieurs signal-event post-upgrade
Hormis ce message le serveur fonctionne normalement sauf le partage imprimante qui n'est plus accessible depuis une des dernière mise a jour, je ne sais pas laquelle exactement car l'imprimante usb est très peu utilisée.
Avec un poste windows 11 cette imprimante est vue dans le voisinage réseau mais reste inaccessible pour l'installer, idem avec un poste sous ubuntu

PS: le partage de fichiers fonctionne.

Cordialement
A.diligent

Offline Jean-Philippe Pialasse

  • *
  • 2,166
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
post-upgrade doit etre suivit IMMEDIATEMENT d’un signal-event reboot. 

C’est lors du reboot que tout est reconfiguré et que le message disparait.
Garder un serveur sans reboot apres l’event post-upgrade laisse le serveur non fonctionnel et avec plusieurs services éteints. 

Offline adili

  • *
  • 15
  • +0/-0
post-upgrade doit etre suivit IMMEDIATEMENT d’un signal-event reboot. 

C’est lors du reboot que tout est reconfiguré et que le message disparait.
Garder un serveur sans reboot apres l’event post-upgrade laisse le serveur non fonctionnel et avec plusieurs services éteints.
Je ne l'ai pas indiqué mais j'ai passé la commande complète
Code: [Select]
signal-event post-upgrade; signal-event rebootà chaque fois.
Je viens de repasser cette commande pour la 5ème ou 6ème fois et là c'est correct, il reste le problème de partage imprimante.

Offline Jean-Philippe Pialasse

  • *
  • 2,166
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
il faut installer les drivers soit sur le poste soit les rendre disponible sur samba, cf la documentation de samba.

Offline adili

  • *
  • 15
  • +0/-0

Les drivers sont bien installés sur tous les postes du réseau, cette imprimante était accessible par tous les postes et subitement depuis environ 2 semaines impossible d'y accéder ou d'en configurer un nouveau.

Offline Jean-Philippe Pialasse

  • *
  • 2,166
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
alors il faut verifier le status du service linux d’impression et son log

Offline adili

  • *
  • 15
  • +0/-0
alors il faut verifier le status du service linux d’impression et son log

Problème résolu avec un reboot hard du serveur

Offline gieres

  • *
  • 170
  • +0/-0
Bonsoir,
C'est quoi un « reboot hard » ?
Ou quelle différence par rapport à « signal-event reboot » ?
D'avance merci.

Offline adili

  • *
  • 15
  • +0/-0
Bonsoir,
C'est quoi un « reboot hard » ?
Ou quelle différence par rapport à « signal-event reboot » ?
D'avance merci.

C'est un shutdown -h arrêt et mise hors tension.
Dans la page du server-manager j'avais toujours l'avertissement en rouge indiquant de reconfigurer le serveur malgré plusieurs commandes
Code: [Select]
signal-event post-upgrade; signal-event reboot et aussi l'imprimante usb n'était plus accessible.
Maintenant tout est OK

Offline Jean-Philippe Pialasse

  • *
  • 2,166
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
ce qui me fait dire que le reboot n'a jamais eu lieu...

un simple arret et redemarrer si le signal-event post-upgrade n'a as ete emis avant ne changera pas ce message.

lorsqu'un post-upgrade est emis sans reboot plusieurs sevrices sont arretés eb attendant le reboot.

il serait important d'investiguer pourquoi le server n'a jamais rebooté lors des signal-event reboot.

Offline marsa_matruh

  • ****
  • 238
  • +0/-0
Je rencontre ça assez fréquemment que le serveur ne reboote pas après application des mises à jour depuis le server-manager. Toujours dans le server-manager, je vais dans Arrêt/Redémarrage, je demande un reconfigure. Ça reboote, ça reconfigure et je n'ai pas plus le message d'alerte en rouge.