Koozali.org: home of the SME Server

recreated user mailbox unable to received mail

Offline GadoF

  • *
  • 31
  • +0/-0
recreated user mailbox unable to received mail
« on: February 26, 2024, 12:48:28 AM »
hi,

 I have this issue , mailbox was deleted and then recreated it again. However i encounter this issue no email was found on the user mailbox. Checking the logs and found this:
   deferral: Unable_to_switch_to_/home/e-smith/files/users/abc_mailbox:_access_denied._(#4.3.0).

Does anyone encounter this issue ?

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: recreated user mailbox unable to received mail
« Reply #1 on: February 26, 2024, 02:50:00 AM »
if user deleted and recreated :
- content of /home/e-smith/files/user/username will be deleted then recreated from scratch
- uid and gid it will not be the same

hence if you have restored a backup of the user home folder, you need to do

chown username:username -R /home/e-smith/files/user/username

Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #2 on: February 26, 2024, 03:06:47 AM »
i recreated the user account and did not restore from the backukp and encountered the issue, should I run the command you gave me ?
« Last Edit: February 26, 2024, 03:25:09 AM by GadoF »

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: recreated user mailbox unable to received mail
« Reply #3 on: February 26, 2024, 04:23:29 AM »
well it would be interesting to first know what says

ll -d /home/e-smith/files/user/username


Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #4 on: February 26, 2024, 05:49:21 AM »
here's the result

drwx------ 5 abc_userfolder abc_userfolder 142 Feb 25 10:23 /home/e-smith/files/users/abc_userfolder

Offline bunkobugsy

  • *
  • 283
  • +4/-0
Re: recreated user mailbox unable to received mail
« Reply #5 on: February 26, 2024, 11:19:00 AM »
for me

drwx--x---+ 4 username           username           141 Feb  4 18:45 username

Offline bunkobugsy

  • *
  • 283
  • +4/-0
Re: recreated user mailbox unable to received mail
« Reply #6 on: February 26, 2024, 07:42:30 PM »
inside that

drwxr-xr-x   2 username username   10 Sep 19  2013 home
drwxrwsr-x+ 18 username username 4096 Feb 26 15:49 Maildir

in Maildir

drwxrwsr-x+ 2 username username  684032 Feb 26 15:49 cur
-rw-rw-r--+ 1 username username       0 Apr 22  2020 dovecot-acl-list

and in cur (mail) files are

-rw-r--r--+ 1 username username     7355 Feb 26 15:36 1708954581.28602

everything should be owned username:username

mailforders seem to be 775 and files 644 or 664

Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #7 on: February 27, 2024, 12:48:15 AM »
yeah same level of rights , but i am just wondering the email i sent to the mailbox was denied or not being delivered.

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: recreated user mailbox unable to received mail
« Reply #8 on: February 27, 2024, 01:45:35 AM »
what about


ll -a /home/e-smith/files/user/username

and

ll /var/spool/username

Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #9 on: February 27, 2024, 03:51:11 AM »
ll -a /home/e-smith/files/user/username

result :

total 52
drwx------    5 user user   142 Feb 25 10:23 .
drwxr-xr-x. 726 root    root    20480 Feb 27 08:48 ..
drwxr-xr-x    2 user user     6 Jan 31  2013 home
drwxr-xr-x    6 user user   167 Feb 25 10:17 Maildir
-rw-------    1 user user   675 Feb 25 09:50 .mailfilter
-rw-------    1 user user   806 Feb 25 09:50 .procmailrc
-rw-r--r--    1 user user   556 Feb 25 10:18 .qmail
lrwxrwxrwx    1 root    admin       6 Feb 25 09:50 .qmail-default -> .qmail
-rw-r--r--    1 user user   482 Feb 25 09:50 .qmail-junkmail
drwx------    2 user user     6 Jan 31  2013 .ssh

ll /var/spool/mail/username

-rw-rw---- 1 user mail 0 Feb 25 09:50 /var/spool/mail/user
 

Offline bunkobugsy

  • *
  • 283
  • +4/-0
Re: recreated user mailbox unable to received mail
« Reply #10 on: February 27, 2024, 06:02:42 AM »
You could do it by the book again:
-save all emails and files
-delete user
-create it again
-don't mess with emails/folders from console
From a work pc:
-rename every email to *.eml
-drop them into mail folders (inbox/sent/etc) via imap email client
-restore files

Offline bunkobugsy

  • *
  • 283
  • +4/-0
Re: recreated user mailbox unable to received mail
« Reply #11 on: February 27, 2024, 06:10:30 AM »
drwxr-xr-x    6 user user   167 Feb 25 10:17 Maildir

for me

drwxrwsr-x+ 18 username username 4096 Feb 26 15:49 Maildir

would explain " deferral: Unable_to_switch_to_/home/e-smith/files/users/abc_mailbox:_access_denied._(#4.3.0)."

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: recreated user mailbox unable to received mail
« Reply #12 on: February 27, 2024, 06:17:00 AM »
you have the default values. I see no evident cause.  Have you restarted qmail?

Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #13 on: February 27, 2024, 06:48:59 AM »
I restarted the server multiple times. the mailbox is not able to receive the test mail I am sending.

you have the default values. I see no evident cause.  Have you restarted qmail?

Offline bunkobugsy

  • *
  • 283
  • +4/-0
Re: recreated user mailbox unable to received mail
« Reply #14 on: February 27, 2024, 08:00:48 AM »
Try saving the user from server-manager then running from reboot or shutdown > reconfigure.

Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #15 on: February 28, 2024, 03:05:18 AM »
same result. Cannot receive all mails it is just queueing

Try saving the user from server-manager then running from reboot or shutdown > reconfigure.

Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #16 on: April 03, 2024, 09:48:08 AM »
just to update, i have deleted several users and now when someone email to them instead of the sytem giving a bounce mail error, the email stuck in que. Any help will be appreciated

Offline ReetP

  • *
  • 3,805
  • +5/-0
Re: recreated user mailbox unable to received mail
« Reply #17 on: April 03, 2024, 01:11:35 PM »
just to update, i have deleted several users and now when someone email to them instead of the sytem giving a bounce mail error, the email stuck in que. Any help will be appreciated

You would help yourself by solving one problem at a time instead of compounding it by performing more actions.

Have you read your logs?

What do they say?

Might be better to rewind a bit as well.

Please follow this.

https://forums.koozali.org/index.php/topic,54724.0.html

Lets have a look at your server and see what is going on.

Start at "Documenting things"

Post the output from these:

Was your server an upgrade or clean install?

Have a look in your server manager lower left in Miscellaneous for "Report a bug" and then do "Create configuration report" and post us some of the network details, less things like passwords.

Also:

Code: [Select]
/sbin/e-smith/audittools/newrpms
/sbin/e-smith/audittools/templates

We need to find how you got into this mess in the first place.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #18 on: May 11, 2024, 02:18:29 AM »
Sorry been away for a while trying my luck if i can solve the issue on my own, but unfortunately i wasn't

here's the log, i will be filing a bug so someone can help me:

Loaded plugins: fastestmirror, post-transaction-actions, priorities, smeserver
Loading mirror speeds from cached hostfile
 * base: mirror.sabay.com.kh
 * smeaddons: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * updates: mirror.sabay.com.kh
Extra Packages
clamav.x86_64                            0.103.8-3.el7              installed   
clamav-data.noarch                       0.103.8-3.el7              installed   
clamav-filesystem.noarch                 0.103.8-3.el7              installed   
clamav-lib.x86_64                        0.103.8-3.el7              installed   
clamav-update.x86_64                     0.103.8-3.el7              installed   
clamd.x86_64                             0.103.8-3.el7              installed   
e-smith-base.x86_64                      5.8.1-23.el7.sme           installed   
e-smith-ldap.noarch                      5.6.0-16.el7.sme           installed   
fail2ban-sendmail.noarch                 0.11.2-3.el7               @smecontribs
fail2ban-server.noarch                   0.11.2-3.el7               @smecontribs
jpgraph.noarch                           4.3.4-1.el7.sme            @smecontribs
libzstd.x86_64                           1.5.4-1.el7                installed   
msttcorefonts.noarch                     2.1-1.of.el7               @smecontribs
perl-Data-Validate-IP.noarch             0.27-13.el7                @smecontribs
perl-MIME-Lite.noarch                    3.030-1.el7                @smecontribs
perl-Unicode-IMAPUtf7.noarch             2.01-1.of.el7              @smecontribs
php55-php-pecl-zip.x86_64                1.21.1-1.el7.remi          installed   
php56-php.x86_64                         5.6.40-36.el7.remi         installed   
php56-php-bcmath.x86_64                  5.6.40-36.el7.remi         installed   
php56-php-cli.x86_64                     5.6.40-36.el7.remi         installed   
php56-php-common.x86_64                  5.6.40-36.el7.remi         installed   
php56-php-enchant.x86_64                 5.6.40-36.el7.remi         installed   
php56-php-fpm.x86_64                     5.6.40-36.el7.remi         installed   
php56-php-gd.x86_64                      5.6.40-36.el7.remi         installed   
php56-php-imap.x86_64                    5.6.40-36.el7.remi         installed   
php56-php-intl.x86_64                    5.6.40-36.el7.remi         installed   
php56-php-ldap.x86_64                    5.6.40-36.el7.remi         installed   
php56-php-mbstring.x86_64                5.6.40-36.el7.remi         installed   
php56-php-mcrypt.x86_64                  5.6.40-36.el7.remi         installed   
php56-php-mysqlnd.x86_64                 5.6.40-36.el7.remi         installed   
php56-php-opcache.x86_64                 5.6.40-36.el7.remi         installed   
php56-php-pdo.x86_64                     5.6.40-36.el7.remi         installed   
php56-php-pecl-zip.x86_64                1.21.1-1.el7.remi          installed   
php56-php-process.x86_64                 5.6.40-36.el7.remi         installed   
php56-php-snmp.x86_64                    5.6.40-36.el7.remi         installed   
php56-php-soap.x86_64                    5.6.40-36.el7.remi         installed   
php56-php-tidy.x86_64                    5.6.40-36.el7.remi         installed   
php56-php-xml.x86_64                     5.6.40-36.el7.remi         installed   
php56-php-xmlrpc.x86_64                  5.6.40-36.el7.remi         installed   
php70-php.x86_64                         7.0.33-37.el7.remi         installed   
php70-php-bcmath.x86_64                  7.0.33-37.el7.remi         installed   
php70-php-cli.x86_64                     7.0.33-37.el7.remi         installed   
php70-php-common.x86_64                  7.0.33-37.el7.remi         installed   
php70-php-enchant.x86_64                 7.0.33-37.el7.remi         installed   
php70-php-fpm.x86_64                     7.0.33-37.el7.remi         installed   
php70-php-gd.x86_64                      7.0.33-37.el7.remi         installed   
php70-php-imap.x86_64                    7.0.33-37.el7.remi         installed   
php70-php-intl.x86_64                    7.0.33-37.el7.remi         installed   
php70-php-json.x86_64                    7.0.33-37.el7.remi         installed   
php70-php-ldap.x86_64                    7.0.33-37.el7.remi         installed   
php70-php-mbstring.x86_64                7.0.33-37.el7.remi         installed   
php70-php-mcrypt.x86_64                  7.0.33-37.el7.remi         installed   
php70-php-mysqlnd.x86_64                 7.0.33-37.el7.remi         installed   
php70-php-opcache.x86_64                 7.0.33-37.el7.remi         installed   
php70-php-pdo.x86_64                     7.0.33-37.el7.remi         installed   
php70-php-pecl-zip.x86_64                1.21.1-1.el7.remi          installed   
php70-php-process.x86_64                 7.0.33-37.el7.remi         installed   
php70-php-snmp.x86_64                    7.0.33-37.el7.remi         installed   
php70-php-soap.x86_64                    7.0.33-37.el7.remi         installed   
php70-php-tidy.x86_64                    7.0.33-37.el7.remi         installed   
php70-php-xml.x86_64                     7.0.33-37.el7.remi         installed   
php70-php-xmlrpc.x86_64                  7.0.33-37.el7.remi         installed   
php71-php.x86_64                         7.1.33-24.el7.remi         installed   
php71-php-bcmath.x86_64                  7.1.33-24.el7.remi         installed   
php71-php-cli.x86_64                     7.1.33-24.el7.remi         installed   
php71-php-common.x86_64                  7.1.33-24.el7.remi         installed   
php71-php-enchant.x86_64                 7.1.33-24.el7.remi         installed   
php71-php-fpm.x86_64                     7.1.33-24.el7.remi         installed   
php71-php-gd.x86_64                      7.1.33-24.el7.remi         installed   
php71-php-imap.x86_64                    7.1.33-24.el7.remi         installed   
php71-php-intl.x86_64                    7.1.33-24.el7.remi         installed   
php71-php-json.x86_64                    7.1.33-24.el7.remi         installed   
php71-php-ldap.x86_64                    7.1.33-24.el7.remi         installed   
php71-php-mbstring.x86_64                7.1.33-24.el7.remi         installed   
php71-php-mcrypt.x86_64                  7.1.33-24.el7.remi         installed   
php71-php-mysqlnd.x86_64                 7.1.33-24.el7.remi         installed   
php71-php-opcache.x86_64                 7.1.33-24.el7.remi         installed   
php71-php-pdo.x86_64                     7.1.33-24.el7.remi         installed   
php71-php-pecl-zip.x86_64                1.21.1-1.el7.remi          installed   
php71-php-process.x86_64                 7.1.33-24.el7.remi         installed   
php71-php-snmp.x86_64                    7.1.33-24.el7.remi         installed   
php71-php-soap.x86_64                    7.1.33-24.el7.remi         installed   
php71-php-tidy.x86_64                    7.1.33-24.el7.remi         installed   
php71-php-xml.x86_64                     7.1.33-24.el7.remi         installed   
php71-php-xmlrpc.x86_64                  7.1.33-24.el7.remi         installed   
php72-php.x86_64                         7.2.34-16.el7.remi         installed   
php72-php-bcmath.x86_64                  7.2.34-16.el7.remi         installed   
php72-php-cli.x86_64                     7.2.34-16.el7.remi         installed   
php72-php-common.x86_64                  7.2.34-16.el7.remi         installed   
php72-php-enchant.x86_64                 7.2.34-16.el7.remi         installed   
php72-php-fpm.x86_64                     7.2.34-16.el7.remi         installed   
php72-php-gd.x86_64                      7.2.34-16.el7.remi         installed   
php72-php-imap.x86_64                    7.2.34-16.el7.remi         installed   
php72-php-intl.x86_64                    7.2.34-16.el7.remi         installed   
php72-php-json.x86_64                    7.2.34-16.el7.remi         installed   
php72-php-ldap.x86_64                    7.2.34-16.el7.remi         installed   
php72-php-mbstring.x86_64                7.2.34-16.el7.remi         installed   
php72-php-mysqlnd.x86_64                 7.2.34-16.el7.remi         installed   
php72-php-opcache.x86_64                 7.2.34-16.el7.remi         installed   
php72-php-pdo.x86_64                     7.2.34-16.el7.remi         installed   
php72-php-pecl-zip.x86_64                1.21.1-1.el7.remi          installed   
php72-php-process.x86_64                 7.2.34-16.el7.remi         installed   
php72-php-snmp.x86_64                    7.2.34-16.el7.remi         installed   
php72-php-soap.x86_64                    7.2.34-16.el7.remi         installed   
php72-php-tidy.x86_64                    7.2.34-16.el7.remi         installed   
php72-php-xml.x86_64                     7.2.34-16.el7.remi         installed   
php72-php-xmlrpc.x86_64                  7.2.34-16.el7.remi         installed   
php73-php.x86_64                         7.3.33-8.el7.remi          installed   
php73-php-bcmath.x86_64                  7.3.33-8.el7.remi          installed   
php73-php-cli.x86_64                     7.3.33-8.el7.remi          installed   
php73-php-common.x86_64                  7.3.33-8.el7.remi          installed   
php73-php-enchant.x86_64                 7.3.33-8.el7.remi          installed   
php73-php-fpm.x86_64                     7.3.33-8.el7.remi          installed   
php73-php-gd.x86_64                      7.3.33-8.el7.remi          installed   
php73-php-imap.x86_64                    7.3.33-8.el7.remi          installed   
php73-php-intl.x86_64                    7.3.33-8.el7.remi          installed   
php73-php-json.x86_64                    7.3.33-8.el7.remi          installed   
php73-php-ldap.x86_64                    7.3.33-8.el7.remi          installed   
php73-php-mbstring.x86_64                7.3.33-8.el7.remi          installed   
php73-php-mysqlnd.x86_64                 7.3.33-8.el7.remi          installed   
php73-php-opcache.x86_64                 7.3.33-8.el7.remi          installed   
php73-php-pdo.x86_64                     7.3.33-8.el7.remi          installed   
php73-php-pecl-zip.x86_64                1.21.1-1.el7.remi          installed   
php73-php-process.x86_64                 7.3.33-8.el7.remi          installed   
php73-php-snmp.x86_64                    7.3.33-8.el7.remi          installed   
php73-php-soap.x86_64                    7.3.33-8.el7.remi          installed   
php73-php-tidy.x86_64                    7.3.33-8.el7.remi          installed   
php73-php-xml.x86_64                     7.3.33-8.el7.remi          installed   
php73-php-xmlrpc.x86_64                  7.3.33-8.el7.remi          installed   
php74-php.x86_64                         7.4.33-4.el7.remi          installed   
php74-php-bcmath.x86_64                  7.4.33-4.el7.remi          installed   
php74-php-cli.x86_64                     7.4.33-4.el7.remi          installed   
php74-php-common.x86_64                  7.4.33-4.el7.remi          installed   
php74-php-enchant.x86_64                 7.4.33-4.el7.remi          installed   
php74-php-fpm.x86_64                     7.4.33-4.el7.remi          installed   
php74-php-gd.x86_64                      7.4.33-4.el7.remi          installed   
php74-php-imap.x86_64                    7.4.33-4.el7.remi          installed   
php74-php-intl.x86_64                    7.4.33-4.el7.remi          installed   
php74-php-json.x86_64                    7.4.33-4.el7.remi          installed   
php74-php-ldap.x86_64                    7.4.33-4.el7.remi          installed   
php74-php-mbstring.x86_64                7.4.33-4.el7.remi          installed   
php74-php-mysqlnd.x86_64                 7.4.33-4.el7.remi          installed   
php74-php-opcache.x86_64                 7.4.33-4.el7.remi          installed   
php74-php-pdo.x86_64                     7.4.33-4.el7.remi          installed   
php74-php-pecl-zip.x86_64                1.21.1-1.el7.remi          installed   
php74-php-process.x86_64                 7.4.33-4.el7.remi          installed   
php74-php-snmp.x86_64                    7.4.33-4.el7.remi          installed   
php74-php-soap.x86_64                    7.4.33-4.el7.remi          installed   
php74-php-sodium.x86_64                  7.4.33-4.el7.remi          installed   
php74-php-tidy.x86_64                    7.4.33-4.el7.remi          installed   
php74-php-xml.x86_64                     7.4.33-4.el7.remi          installed   
php74-php-xmlrpc.x86_64                  7.4.33-4.el7.remi          installed   
php80-php.x86_64                         8.0.28-1.el7.remi          installed   
php80-php-bcmath.x86_64                  8.0.28-1.el7.remi          installed   
php80-php-cli.x86_64                     8.0.28-1.el7.remi          installed   
php80-php-common.x86_64                  8.0.28-1.el7.remi          installed   
php80-php-enchant.x86_64                 8.0.28-1.el7.remi          installed   
php80-php-fpm.x86_64                     8.0.28-1.el7.remi          installed   
php80-php-gd.x86_64                      8.0.28-1.el7.remi          installed   
php80-php-imap.x86_64                    8.0.28-1.el7.remi          installed   
php80-php-intl.x86_64                    8.0.28-1.el7.remi          installed   
php80-php-ldap.x86_64                    8.0.28-1.el7.remi          installed   
php80-php-mbstring.x86_64                8.0.28-1.el7.remi          installed   
php80-php-mysqlnd.x86_64                 8.0.28-1.el7.remi          installed   
php80-php-opcache.x86_64                 8.0.28-1.el7.remi          installed   
php80-php-pdo.x86_64                     8.0.28-1.el7.remi          installed   
php80-php-pecl-zip.x86_64                1.21.1-1.el7.remi          installed   
php80-php-process.x86_64                 8.0.28-1.el7.remi          installed   
php80-php-snmp.x86_64                    8.0.28-1.el7.remi          installed   
php80-php-soap.x86_64                    8.0.28-1.el7.remi          installed   
php80-php-sodium.x86_64                  8.0.28-1.el7.remi          installed   
php80-php-tidy.x86_64                    8.0.28-1.el7.remi          installed   
php80-php-xml.x86_64                     8.0.28-1.el7.remi          installed   
php81-php.x86_64                         8.1.18-1.el7.remi          installed   
php81-php-bcmath.x86_64                  8.1.18-1.el7.remi          installed   
php81-php-cli.x86_64                     8.1.18-1.el7.remi          installed   
php81-php-common.x86_64                  8.1.18-1.el7.remi          installed   
php81-php-enchant.x86_64                 8.1.18-1.el7.remi          installed   
php81-php-fpm.x86_64                     8.1.18-1.el7.remi          installed   
php81-php-gd.x86_64                      8.1.18-1.el7.remi          installed   
php81-php-imap.x86_64                    8.1.18-1.el7.remi          installed   
php81-php-intl.x86_64                    8.1.18-1.el7.remi          installed   
php81-php-ldap.x86_64                    8.1.18-1.el7.remi          installed   
php81-php-mbstring.x86_64                8.1.18-1.el7.remi          installed   
php81-php-mysqlnd.x86_64                 8.1.18-1.el7.remi          installed   
php81-php-opcache.x86_64                 8.1.18-1.el7.remi          installed   
php81-php-pdo.x86_64                     8.1.18-1.el7.remi          installed   
php81-php-pecl-zip.x86_64                1.21.1-1.el7.remi          installed   
php81-php-process.x86_64                 8.1.18-1.el7.remi          installed   
php81-php-snmp.x86_64                    8.1.18-1.el7.remi          installed   
php81-php-soap.x86_64                    8.1.18-1.el7.remi          installed   
php81-php-sodium.x86_64                  8.1.18-1.el7.remi          installed   
php81-php-tidy.x86_64                    8.1.18-1.el7.remi          installed   
php81-php-xml.x86_64                     8.1.18-1.el7.remi          installed   
qmail-notify.x86_64                      0.93-5                     @smecontribs
smeserver-autodiscover.noarch            1.0.0-0.el7.sme            @smecontribs
smeserver-certificate.noarch             0.0.4-13.el7.sme           @smecontribs
smeserver-domains.noarch                 1.4-5                      @smecontribs
smeserver-email-management.noarch        1.3-5.el7.sme              @smecontribs
smeserver-fail2ban.noarch                9:0.1.18-30.el7.sme        @smecontribs
smeserver-lazy_admin_tools.noarch        1.1-6.el7.sme              @smecontribs
smeserver-mailsorting.noarch             1.4-14.el7.sme             @smecontribs
smeserver-mxbackup-utf8.noarch           0.1.0-03                   installed   
smeserver-mysql.noarch                   2.7.0-17.el7.sme           installed   
smeserver-password.noarch                1.2.0-14.el7.sme           @smecontribs
smeserver-php.x86_64                     3.0.0-44.el7.sme           installed   
smeserver-qmHandle.noarch                1.4-24.el7.sme             @smecontribs
smeserver-qmail-notify.noarch            2.0.0-4                    @smecontribs
smeserver-unjunkmgr.noarch               3.1-6.el7.sme              @smecontribs
smeserver-userpanel.noarch               1.4-6.el7.sme              @smecontribs
smeserver-vacation.noarch                1.1-34.el7.sme             @smecontribs
smeserver-wbl.noarch                     0.5.0-7.el7.sme            @smecontribs
smeserver-yum.noarch                     2.6.2-2.el7.sme            installed   [


ase: enabled
centosplus: disabled
extras: disabled
fasttrack: disabled
remi-safe: enabled
smeaddons: enabled
smecontribs: disabled
smedev: disabled
smeextras: enabled
smeos: enabled
smetest: disabled
smeupdates: enabled
smeupdates-testing: disabled


/etc/e-smith/templates-custom/etc/pam.d/system-auth/40password: OWNED_BY_RPM, OVERRIDE
/etc/e-smith/templates-custom/var/service/qpsmtpd/config/peers/local/17check_basicheaders: MANUALLY_ADDED, ADDITION
/etc/e-smith/templates-custom/var/service/qpsmtpd/config/peers/0/17check_basicheaders: MANUALLY_ADDED, ADDITION
/etc/e-smith/templates-custom/var/service/qpsmtpd/config/relayclients/80custom: MANUALLY_ADDED, ADDITIO

You would help yourself by solving one problem at a time instead of compounding it by performing more actions.

Have you read your logs?

What do they say?

Might be better to rewind a bit as well.

Please follow this.

https://forums.koozali.org/index.php/topic,54724.0.html

Lets have a look at your server and see what is going on.

Start at "Documenting things"

Post the output from these:

Was your server an upgrade or clean install?

Have a look in your server manager lower left in Miscellaneous for "Report a bug" and then do "Create configuration report" and post us some of the network details, less things like passwords.

Also:

Code: [Select]
/sbin/e-smith/audittools/newrpms
/sbin/e-smith/audittools/templates

We need to find how you got into this mess in the first place.

Offline ReetP

  • *
  • 3,805
  • +5/-0
Re: recreated user mailbox unable to received mail
« Reply #19 on: May 11, 2024, 10:33:24 AM »
Quote
here's the log, i will be filing a bug so someone can help me:

There is not yet any evidence of a bug sp don't open one yet.

Note. The same few people work on the bugs as they do here.... A bug won't solve it faster.

That info not a log.

Did you look at Logs section here?

https://forums.koozali.org/index.php/topic,54724.0.html

You probably need to look at /var/log/qpsmtpd and /var/log/qmail and messages to start with.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline ReetP

  • *
  • 3,805
  • +5/-0
Re: recreated user mailbox unable to received mail
« Reply #20 on: May 11, 2024, 10:38:13 AM »
Ah you've already done it.

Note this will not get it fixed any faster.

https://bugs.koozali.org/show_bug.cgi?id=12683

See my comments above about logs. They are required.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: recreated user mailbox unable to received mail
« Reply #21 on: May 11, 2024, 09:30:21 PM »
uninstall that
smeserver-mxbackup-utf8.noarch           0.1.0-03                   installed   


this has not been maintained since sme7. this is incompatible with current SME 10.

Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #22 on: May 13, 2024, 02:01:31 AM »
Some logs:
  see  logs below:

May 13 02:20:21 pop3 esmith::event[10693]: adjust-services=action|Event|fail2ban-update|Action|adjust-services|Start|1715541621 146222|End|1715541621 593738|Elapsed|0.447516
May 13 02:20:21 pop3 /sbin/e-smith/smeserver-fail2ban[10876]: /home/e-smith/db/fail2ban: OLD 93szp1ntj1fu58q=(undefined)
May 13 02:20:21 pop3 /sbin/e-smith/smeserver-fail2ban[10876]: /home/e-smith/db/fail2ban: NEW 93szp1ntj1fu58q=ban|BanTimestamp|1715541621|Host|194.169.175.17|UnbanTimestamp|1716146421
May 13 02:20:21 pop3 esmith::event[10877]: Processing event: fail2ban-update
May 13 02:20:21 pop3 esmith::event[10877]: generic_template_expand=action|Event|fail2ban-update|Action|generic_template_expand|Start|1715541621 707034|End|1715541621 816354|Elapsed|0.10932
May 13 02:20:22 pop3 esmith::event[10877]: adjust-services=action|Event|fail2ban-update|Action|adjust-services|Start|1715541621 816744|End|1715541622 298128|Elapsed|0.481384
May 13 02:48:11 pop3 kernel: [89464.938502] cvm-unix[7104]: segfault at 0 ip 00007f522e570037 sp 00007ffeef9e17f8 error 4 in libc-2.17.so[7f522e431000+1c4000]
May 13 02:48:11 pop3 kernel: cvm-unix[7104]: segfault at 0 ip 00007f522e570037 sp 00007ffeef9e17f8 error 4 in libc-2.17.so[7f522e431000+1c4000]
May 13 02:50:20 pop3 /sbin/e-smith/smeserver-fail2ban[11737]: /home/e-smith/db/fail2ban: DELETE dofe6fu2pjhat0l=ban|BanTimestamp|1715541620|Host|194.169.175.17|Port|25,465|Protocol|tcp|UnbanTimestamp|1715543420
May 13 02:50:20 pop3 esmith::event[11738]: Processing event: fail2ban-update
May 13 02:50:21 pop3 esmith::event[11738]: generic_template_expand=action|Event|fail2ban-update|Action|generic_template_expand|Start|1715543420 947095|End|1715543421 55091|Elapsed|0.107996
May 13 02:50:21 pop3 esmith::event[11738]: adjust-services=action|Event|fail2ban-update|Action|adjust-services|Start|1715543421 55510|End|1715543421 494777|Elapsed|0.439267
May 13 03:03:17 pop3 kernel: [90371.098872] cvm-unix[11692]: segfault at 0 ip 00007f924059d037 sp 00007ffc7e32e3e8 error 4 in libc-2.17.so[7f924045e000+1c4000]
May 13 03:03:17 pop3 kernel: cvm-unix[11692]: segfault at 0 ip 00007f924059d037 sp 00007ffc7e32e3e8 error 4 in libc-2.17.so[7f924045e000+1c4000]
May 13 03:13:09 pop3 kernel: [90963.447079] cvm-unix[12693]: segfault at 0 ip 00007fb81c9f8037 sp 00007ffdfd055738 error 4 in libc-2.17.so[7fb81c8b9000+1c4000]
May 13 03:13:09 pop3 kernel: cvm-unix[12693]: segfault at 0 ip 00007fb81c9f8037 sp 00007ffdfd055738 error 4 in libc-2.17.so[7fb81c8b9000+1c4000]
May 13 04:11:19 pop3 kernel: [94453.437120] cvm-unix[12944]: segfault at 0 ip 00007fa2092befd6 sp 00007fffd14ecc28 error 4 in libc-2.17.so[7fa209180000+1c4000]
May 13 04:11:19 pop3 kernel: cvm-unix[12944]: segfault at 0 ip 00007fa2092befd6 sp 00007fffd14ecc28 error 4 in libc-2.17.so[7fa209180000+1c4000]
May 13 06:41:46 pop3 kernel: [103479.984408] cvm-unix[14518]: segfault at 0 ip 00007f9439ace037 sp 00007ffd43a4dd58 error 4 in libc-2.17.so[7f943998f000+1c4000]
May 13 06:41:46 pop3 kernel: cvm-unix[14518]: segfault at 0 ip 00007f9439ace037 sp 00007ffd43a4dd58 error 4 in libc-2.17.so[7f943998f000+1c4000]





Ah you've already done it.

Note this will not get it fixed any faster.

https://bugs.koozali.org/show_bug.cgi?id=12683

See my comments above about logs. They are required.

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: recreated user mailbox unable to received mail
« Reply #23 on: May 13, 2024, 02:48:57 AM »
all what says this random log is that your server need updating for more than one year!
an up to date server should not have cvm unix since first trimester of 2023. 


so :
start to uninstall incompatible rpm that has the potential to  break your incoming mail system
yum remove smeserver-mxbackup-utf8

then
yum update
signal-event post-upgrade
signal-event reboot


then please start to be systematic if you want help. 
do not sens random log, but start by opening the log before deleting a user and then recreate the same user. that is the way to work.

Offline GadoF

  • *
  • 31
  • +0/-0
Re: recreated user mailbox unable to received mail
« Reply #24 on: May 13, 2024, 04:25:05 AM »
the server is running in prod, so thats why i am not updating it since most of the  issue  was cause by an update. Do you really think it is the cause of the issue.

all what says this random log is that your server need updating for more than one year!
an up to date server should not have cvm unix since first trimester of 2023. 


so :
start to uninstall incompatible rpm that has the potential to  break your incoming mail system
yum remove smeserver-mxbackup-utf8

then
yum update
signal-event post-upgrade
signal-event reboot


then please start to be systematic if you want help. 
do not sens random log, but start by opening the log before deleting a user and then recreate the same user. that is the way to work.

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: recreated user mailbox unable to received mail
« Reply #25 on: May 13, 2024, 05:11:22 AM »
the server is running in prod, so thats why i am not updating it since most of the  issue  was cause by an update. Do you really think it is the cause of the issue.

that is the very reason why you should update frequently, a prod server is not a toy forgotten on a shelf. This is an important asset that you should protect from any security flaw, eg from allowing an external actor to ddos your server exploiting a segfaulting service. Not to mention all CVE that have been fixed in the last 15 months.

Contrary to an ubuntu or fedora servers we work hard not to create breaking update inside a release.


i think one part of the issue is mxbackup installed. 
I think no one will ever help you with any system out of date, whether you look in closed or open source. 

so start by removing this old contrib and updating, as you just demonstrated there the server is broken and not because you updated. 

Offline ReetP

  • *
  • 3,805
  • +5/-0
Re: recreated user mailbox unable to received mail
« Reply #26 on: May 13, 2024, 04:57:20 PM »
Quote
so thats why i am not updating it since most of the  issue  was cause by an update

Mate, this is not Fedora or Ubuntu.

You are using a LTS distro. Updates are because you need them, for your own good. They are not for fun.

Until you update your system I am not wasting any more of my time on this.

Update now so you stop wasting your own time too.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation