Koozali.org: home of the SME Server

421 per host concurrency limit reached

Offline Agent86

  • ****
  • 592
  • +0/-0
    • http://www.iclbiz.com
421 per host concurrency limit reached
« on: April 28, 2006, 12:43:07 PM »
When loggin to ftp ibays etc. I sometime get this message popup window

421 per host concurrency limit reached

I get this message both locally and remotely for ftp to ibays.

What does this mean ?

Please advise

Offline byte

  • *
  • 2,183
  • +2/-0
421 per host concurrency limit reached
« Reply #1 on: April 28, 2006, 12:50:07 PM »
That means what it mean's there are too many connections trying to connect
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

Offline Agent86

  • ****
  • 592
  • +0/-0
    • http://www.iclbiz.com
1 connection is too many ?
« Reply #2 on: April 28, 2006, 02:15:38 PM »
This is strange, how many can connect, just one or more ?

Thanks for the help

Offline meanpenguin

  • ***
  • 138
  • +0/-0
421 per host concurrency limit reached
« Reply #3 on: April 29, 2006, 06:59:49 PM »
Hi,

"Search Site" is very useful....

The limit is set by using the tcpsvd program that is used to launch the
applications.

So, look in the /service directory and check if there is a ftpd dir or something like that.  In there should be a file named "run".  Look in there for the limit.

Ed

Offline Agent86

  • ****
  • 592
  • +0/-0
    • http://www.iclbiz.com
Thanks
« Reply #4 on: April 29, 2006, 10:43:44 PM »
I'll look Thanks

What is the SME limit by default ?

Offline NickR

  • *
  • 283
  • +0/-0
    • http://www.witzendcs.co.uk/
Re: Thanks
« Reply #5 on: April 30, 2006, 12:03:28 PM »
Quote from: "Agent86"
What is the SME limit by default ?


4
--
Nick......

Offline Agent86

  • ****
  • 592
  • +0/-0
    • http://www.iclbiz.com
Thanks
« Reply #6 on: April 30, 2006, 04:09:24 PM »
Thanks, must just be my attempts too many in a short time.

Cause no one else was accessing the ftp for sure, but me.

Thanks again.

Offline Tillebeck

  • ***
  • 76
  • +0/-0
    • http://opengate.dk
Re: 421 per host concurrency limit reached
« Reply #7 on: April 24, 2009, 11:16:12 AM »
Have the same issue. I was the only one accessing a ftp-server. Lets say I started a trasferr of 1000 files with my client set up to max. 2 connections. Then maybe after 200 files suddenly only one file could transferr at the time and the other would get a 421. Then after a while both would get a 421 and no files could be transferred. Seems connections are not closed properly why the "connections per host" need to be higher to compensate for this problem.

Reading this thread made me look in the file "run" located:
/service/ftp (symlink to: /var/service/proftpd)

For the per host var called C it said:
Code: [Select]
-C ${PER_IP_INSTANCES:-4}:'421 per host concurrency limit reached\r\n' \
I changed that to these three with no effect:
Code: [Select]
-C 8:'421 per host concurrency limit reached\r\n' \
-C ${PER_IP_INSTANCES:-8}:'421 per host concurrency limit reached\r\n' \

I have increased the settings for IMAP and IMAPS with success (db setprop etc.). This issue is only regarding ftp and how to increase it for ftp. Can anyone help with this?

BR. Anders

Offline Stefano

  • *
  • 10,820
  • +1/-0
Re: 421 per host concurrency limit reached
« Reply #8 on: April 24, 2009, 11:24:04 AM »
Have the same issue. I was the only one accessing a ftp-server. Lets say I started a trasferr of 1000 files with my client set up to max. 2 connections. Then maybe after 200 files suddenly only one file could transferr at the time and the other would get a 421. Then after a while both would get a 421 and no files could be transferred. Seems connections are not closed properly why the "connections per host" need to be higher to compensate for this problem.

Reading this thread made me look in the file "run" located:
/service/ftp (symlink to: /var/service/proftpd)

For the per host var called C it said:
Code: [Select]
-C ${PER_IP_INSTANCES:-4}:'421 per host concurrency limit reached\r\n' \
I changed that to these three with no effect:
Code: [Select]
-C 8:'421 per host concurrency limit reached\r\n' \
-C ${PER_IP_INSTANCES:-8}:'421 per host concurrency limit reached\r\n' \

I have increased the settings for IMAP and IMAPS with success (db setprop etc.). This issue is only regarding ftp and how to increase it for ftp. Can anyone help with this?

BR. Anders

yes.. the dev team.. please raise a bug for that.. and post here the reference..

Thank you
Ciao
Stefano

Offline Tillebeck

  • ***
  • 76
  • +0/-0
    • http://opengate.dk
Re: 421 per host concurrency limit reached
« Reply #9 on: April 24, 2009, 12:00:25 PM »
ok. I will do that.

Files as:
http://bugs.contribs.org/show_bug.cgi?id=5187

My post in the forum is not a bug report but a "am I doing this the right way?". If I am doing it the wrong way and ftp concurrency limit is edited in another way then the dev team will turn down the bug with "support request" and the question will go back to this forum.

With your answer I guess that you back my solution up and we now are two that think this may be a bug. Correct?

BR. Anders

Offline Tillebeck

  • ***
  • 76
  • +0/-0
    • http://opengate.dk
Re: 421 per host concurrency limit reached
« Reply #10 on: May 01, 2009, 04:52:32 PM »
Ok. It was not a bug - so bug was closed as INVALID

There need to be made a template file that will fix it.

Message from Charlie Brady was:
Quote
Resolving INVALID. You need to make a custom template file:

/etc/e-smith/templates-custom/var/service/ftp/peers/local/ConcurrencyPerIP
containing 'C8'.

And it is that simple. Just a new textfile that contain the "C8" and it should work just fine :-)

If you think "it can't be that simple" then have a look at the original template file where you will see a "C4"
/etc/e-smith/templates/var/service/ftp/peers/local/ConcurrencyPerIP

BR. Anders