Koozali.org: home of the SME Server

Get your own webmail Logon name

Offline billi

  • *
  • 46
  • +0/-0
    • http://applitec.net
Get your own webmail Logon name
« on: May 29, 2006, 01:03:49 AM »
I found an anwer on how to change the "Welcome to Horde" to your own name but found it not entirely accurate for SME 7.sr2 so here is one that should works.

How to change the name on the logon screen in Webmail
We are going to make a new directory in the templates-custom folder to ensure our changes do not get nixed on restart or upgrade

mkdir -p /etc/e-smith/templates-custom/home/httpd/html/horde/config/registry.php

Next is to copy the base code to the templates custom directory

cp /etc/e-smith/templates/home/httpd/html/horde/config/registry.php/110AppRegistryHorde /etc/e-smith/templates-custom/home/httpd/html/horde/config/registry.php

Edit (vi)
vi /etc/e-smith/templates-custom/home/httpd/html/horde/config/registry.php/110AppRegistryHorde

It should look something like this

// 110AppRegistryHorde
$this->applications['horde'] = array(
    'fileroot' => dirname(__FILE__) . '/..',
    'webroot' => $webroot,
    'initial_page' => 'login.php',
    'name' => _("Horde"),
    'status' => 'active',
    'templates' => dirname(__FILE__) . '/../templates',
    'provides' => 'horde'
);
 
Put your desired name in the name line replacing Horde.

Expand the template by doing

/sbin/e-smith/expand-template /home/httpd/html/horde/config/registry.php

It worked for me. Please let me know if there are any problems or better ways to do this.

Offline AaronG

  • ***
  • 90
  • +0/-0
    • http://www.healthinc.com.au
Worked a Treat!
« Reply #1 on: June 14, 2006, 06:29:41 AM »
Thanks it worked fine.

Now if you can find out how to add some custom branding to it :) eg: Own company logo etc

Thanks again

By the way... i am using SME V7 RC3 - not that I expected it to be any different in regards to this, but I just thought I would make note of it for anyone else wondering if it will work for RC3
...

Offline TrevorB

  • *
  • 259
  • +0/-0
    • http://www.batley.id.au
Re: Worked a Treat!
« Reply #2 on: June 14, 2006, 09:53:09 AM »
Quote from: "AaronG"
Now if you can find out how to add some custom branding to it :) eg: Own company logo etc

Create your own theme (under /home/httpd/html/horde/themes).

Kolab is a good one to copy as it uses a logo.

KDB9000

Get your own webmail Logon name
« Reply #3 on: September 26, 2006, 02:08:42 PM »
What about changing the Login Theme?

Offline lucho115

  • ****
  • 209
  • +0/-0
    • http://www.elac.com.ar
Get your own webmail Logon name
« Reply #4 on: September 29, 2006, 09:55:57 PM »
Quote from: "KDB9000"
What about changing the Login Theme?


yes i need to know how to change the theme, anybody knows?

i had changed the favicon of horde and the pics of horde in imp by my own logo, but when the package horde was updated its change me the files, how can i use other pics but no tobe overwrited by an update?
thks

Offline Smitro

  • *
  • 348
  • +0/-0
Get your own webmail Logon name
« Reply #5 on: October 04, 2006, 11:04:41 AM »
.........

Offline del

  • *
  • 765
  • +0/-0
Get your own webmail Logon name
« Reply #6 on: October 05, 2006, 02:27:23 PM »
Hi Billi,

Just tried it and it works good.

Thanks,
Del
If at first you don't succeed, then sky-diving is not for you!
"Life is like a coin. You can spend it anyway you wish, but you can only spend it once." --Author Unknown

Offline mmccarn

  • *
  • 2,574
  • +6/-0
Get your own webmail Logon name
« Reply #7 on: July 26, 2007, 12:05:31 AM »
http://bugs.contribs.org/show_bug.cgi?id=3181
Quote from: "Bug 3181"
After upgrading to SME 7.2, webmail returns error 404 "/imp/redirect.php was
not found on this server"

...

Anyone that has a custom-template of 110AppRegistryHorde is going to be
affected, because of the webroot detection changes in horde 3.1.4.  It doesn't
work as advertised.  Copying the new 110AppRegistryHorde to templates-custom
and then making your changes will allow you to customize your setup once again.

Offline billi

  • *
  • 46
  • +0/-0
    • http://applitec.net
Get your own webmail Logon name
« Reply #8 on: July 29, 2007, 07:05:37 PM »
Had the problem with the Webmail that seems to be an unavoidable bug on the upgrade from 7.13 to 7.2
So I read the Bugzilla  Bug#:3181
http://bugs.contribs.org/show_bug.cgi?id=3181

Deleted the template custom entry that I created in the original post

rm /etc/e-smith/templates-custom/home -Rf

Used the instructions from the original post and all is back to normal again.

Please be careful with the rm if you have other customizations in the
/etc/e-smith/templates-custom/home directory.

Offline william_syd

  • ****
  • 1,608
  • +0/-0
  • Nothing to see here.
    • http://www.magicwilly.info
Re: Worked a Treat!
« Reply #9 on: July 30, 2007, 06:53:21 AM »
Quote from: "AaronG"
Thanks it worked fine.

Now if you can find out how to add some custom branding to it :) eg: Own company logo etc

Thanks again

By the way... i am using SME V7 RC3 - not that I expected it to be any different in regards to this, but I just thought I would make note of it for anyone else wondering if it will work for RC3


/home/httpd/html/horde/imp/config/motd.php
Regards,
William

IF I give advise.. It's only if it was me....

Offline edb

  • *
  • 536
  • +0/-0
Re: Get your own webmail Logon name
« Reply #10 on: August 30, 2007, 07:38:08 AM »
William

I tried the motd.php edit and changed the image name to reflect my company logo and it all seemed to work fine until I made the changes to 110AppRegistryHorde and expanded the template.
I now have Welcome to my company name but my logo no longer shows up just an Xed out image so not sure about the relationship between the 110AppRegistryHorde edit and the motd.php edit?

Any ideas appreciated.

edb
......

Offline edb

  • *
  • 536
  • +0/-0
Re: Get your own webmail Logon name
« Reply #11 on: August 30, 2007, 04:48:54 PM »
Never mind it all works fine!

The only thing I had to change was the 'name' => _("My Company Name"), and I did not have to change the 'webroot' => from the default setting of '/horde',

I expanded the template and everything is working fine now.

Thanks to all who contributed to this thread!!

edb
......

Offline nefkho

  • ****
  • 183
  • +0/-0
    • http://www.cagothonglines.com
Re: Get your own webmail Logon name
« Reply #12 on: June 26, 2008, 09:27:02 AM »
hi,

can i change the login name to the base on the domain i have coz i am hposting multi domain.

www.primary.com/webmail  ----> login company should be primary
www.seconday.org/webmail  ----> login company should be seconday

would it be possible?

thanks,

Nef Kho  :-) .........

Offline Teviot

  • *
  • 610
  • +0/-0
Re: Get your own webmail Logon name
« Reply #13 on: December 18, 2008, 12:41:22 AM »
Having the system come up with the appropriate webname for each domain would be good.

Can it be done?
Regards
M0GLJ
......................................................
I am new to SAIL SME Server v8b6 and have been using SME for many years.
I have already done some research and only ask questions if I still can't work it out.

Offline David Harper

  • *
  • 653
  • +0/-0
  • Watch this space
    • Workgroup Technology Solutions
Re: Get your own webmail Logon name
« Reply #14 on: December 18, 2008, 12:59:16 AM »
As of SME Server 7.4, there is a db setting that controls the webmail name, so you don't need to edit the templates any more.

I don't think there's any way of setting the name differently per domain, however.