Koozali.org: home of the SME Server

Upgrade to squeezeboxserver from squeezecenter - service won't start

Offline chrislaurie

  • *
  • 96
  • +0/-0
I want to upgrade my squeezecenter to the new squeezeboxserver. So far I have uninstallled squeezecenter via yum and then installed squeezeboxserver via yum, using the wiki http://wiki.contribs.org/SqueezeCenter and replacing the names etc as I go along.

The result looks good but the service won't start - I get the following in the log file:

Use of uninitialized value in subroutine entry at /usr/share/squeezeboxserver/CPAN/YAML/Syck.pm line 75

Does anybody have any idea on how to overcome this?

Offline chrislaurie

  • *
  • 96
  • +0/-0
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #1 on: November 13, 2009, 12:04:38 PM »
Seems to be an issue with SqueezeBoxServer:
http://forums.slimdevices.com/showthread.php?t=70120
http://forums.slimdevices.com/showthread.php?t=69507
http://forums.slimdevices.com/showthread.php?t=70472

The /var/lib/squeezeboxserver/prefs/server.prefs file is empty. I don't know why, bt seems like the RH/Centos install via yum is wonky.

I tried to copy and edit my old server.prefs  from squeezecenter but no luck.

Offline markleman

  • **
  • 64
  • +0/-0
    • http://www.leman.net
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #2 on: November 27, 2009, 01:06:48 AM »
Did you find any solution to this? I'm stuck with the same problem :-(

Regards, Mark Leman

Offline chrislaurie

  • *
  • 96
  • +0/-0
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #3 on: November 27, 2009, 07:58:39 AM »
Not yet. I uninstalled SqueezeboxServer and reverted back to 7.33. I just checked the above slimdevices forum threads and on 21 Nov 2009 some guy said the problem is still there.

I'll try again in a month or so to see if they fixed it. I think there is something amiss with rpm, a file is being left out or was not initialised properly.

Offline markleman

  • **
  • 64
  • +0/-0
    • http://www.leman.net
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #4 on: November 27, 2009, 04:49:18 PM »
I did get a bit further by

Code: [Select]
touch  /var/lib/squeezeboxserver/prefs/server.prefs
chown squeezeboxserver:squeezeboxserver /var/lib/squeezeboxserver/prefs/server.prefs
service squeezeboxserver start

I did at one point edit server.prefs and put a space in it so it was not zero bytes long, I can't recall if that was needed ;-)

But at some point I noticed server.prefs had filled up with lots of config values.
 
I noticed "allowedHosts:" line in server.prefs was set to my external IP so I changed that to my internal one.
 
now the service starts, /var/log/messages contains no problems, but it must have died because "service squeezeboxserver stop" does not find the service to stop :-(

I found the squeezebox wiki page on debugging install issues and am working through that, will report back later....

Regards, Mark Leman

Offline chrislaurie

  • *
  • 96
  • +0/-0
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #5 on: November 27, 2009, 05:43:37 PM »
I also got that far. Have you checked /var/log/squeezeboxserver ?

Offline markleman

  • **
  • 64
  • +0/-0
    • http://www.leman.net
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #6 on: November 27, 2009, 08:18:41 PM »
Having looked in /etc/rc.d/init.d/squeezeboxserver and  /etc/sysconfig/squeezeboxserver I found the squeezeboxserver executable in /usr/libexec
 
So I tried:
Code: [Select]
/usr/libexec/squeezeboxserver --prefsdir=/var/lib/squeezeboxserver/prefs --logdir=/var/log/squeezeboxserver --cachedir=/var/lib/squeezeboxserver/cache --charset=utf8
but it does not like running as root, so I tried
Code: [Select]
sudo -u squeezeboxserver /usr/libexec/squeezeboxserver --prefsdir=/var/lib/squeezeboxserver/prefs --logdir=/var/log/squeezeboxserver --cachedir=/var/lib/squeezeboxserver/cache --charset=utf8
and got:
Code: [Select]
[09-11-27 16:38:31.9852] main::init (320) Starting Squeezebox Server (v7.4.1, r28947, Tue Oct 20 07:59:38 PDT 2009) perl 5.008005
Segmentation fault

Hum, no clue in /var/log/messages or /var/log/squeezeboxserver :-( and just to make it worse I tried to install the rpm using yum on a Fedora12 virtual machine I made the other day and it worked first go :-( :-(

(and now this reply is not appearing properly in IE8 but is in chrome - prehaps this is not a good day to debug ;) )
« Last Edit: November 27, 2009, 08:22:37 PM by markleman »

Offline markleman

  • **
  • 64
  • +0/-0
    • http://www.leman.net
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #7 on: November 27, 2009, 11:16:56 PM »
Just to rub salt in to the wounds, I quickly tried an install on an SME8b4 virtual machine using my notes from yesterday and it worked!

Notes on install of Squeezebox server to SME8b4 based on Contribs.org howto:

Read http://wiki.contribs.org/SqueezeCenter
Saw http://www.mysqueezebox.com/download
Looked in http://repos.slimdevices.com/yum/squeezecenter/release/
Saw that 'SqueezeCenter' is now 'Squeezebox Server' so tried:

Code: [Select]
db yum_repositories set squeezecenter-release repository \
BaseURL http://repos.slimdevices.com/yum/squeezecenter/release/ \
EnableGroups no \
GPGCheck no \
GPGKey http://repos.slimdevices.com/yum/squeezecenter/RPM-GPG-KEY-SqueezeCenter \
Name 'SqueezeCenter Release Repository' \
Visible no \
status disabled

Code: [Select]
signal-event yum-modify

Code: [Select]
yum --enablerepo=squeezecenter-release install squeezeboxserver

Did not need 'ln -s /etc/rc.d/init.d/e-smith-service /etc/rc.d/rc7.d/S99squeezecenter' as RPM appears to do the job now
Code: [Select]
db configuration set squeezeboxserver service \
status enabled \
TCPPorts 9000,3483 \
UDPPorts 9000,3483 \
access private
Code: [Select]
signal-event remoteaccess-update
Code: [Select]
mkdir -p /opt/squeezeboxserver/playlists
mkdir -p /opt/squeezeboxserver/music
chown squeezeboxserver:squeezeboxserver /opt/squeezeboxserver/playlists
chown squeezeboxserver:squeezeboxserver /opt/squeezeboxserver/music
Code: [Select]
service squeezeboxserver start

Successfully navigated to http://myserver:9000/

Offline christian

  • *
  • 369
  • +0/-0
    • http://www.szpilfogel.com
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #8 on: November 29, 2009, 03:27:16 PM »
markleman,
Once you are comfortable with the changes for sme8, could you update the wiki accordingly?

and once that is done you can update status at:
http://wiki.contribs.org/SME8.0_Contribs_QA

Thanks. It will help others.
SME since 2003

Offline markleman

  • **
  • 64
  • +0/-0
    • http://www.leman.net
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #9 on: November 29, 2009, 09:36:43 PM »
Quote
Once you are comfortable with the changes for sme8, could you update the wiki accordingly?
Of course :-). I had the sme8b4 virtual machine ready because I was trying to check the howto I wrote for firefiymedia server ran. Unfortunatly that fell at the first hurdle and I have not had time to resolve the issue.

Regards, Mark Leman

Offline markleman

  • **
  • 64
  • +0/-0
    • http://www.leman.net
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #10 on: December 01, 2009, 07:29:17 PM »
I followed this up at http://forums.slimdevices.com/showthread.php?t=69507 and the advice there was that the version of perl on Centos4 is causing the problem.  I will try to check this out with a virgin install on SME and Centos4.x in two virtual machines followed by a test install of  squeezeboxserver.

If it turns out correct then I am not sure where it leaves  squeezeboxserver  on SME7. I can't recall seeing instructions for upgrading perl on SME and considering how much of SME uses perl it might be a bit risky. At least virtual machines are disposable  ;-)

Personally if I can't upgrade Perl I will probably migrate over to SME8b4.

Regards, Mark Leman

Offline markleman

  • **
  • 64
  • +0/-0
    • http://www.leman.net
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #11 on: December 04, 2009, 12:55:36 AM »
:) :) :) :)
Following a lot of help and advice from user mherger over on the slimdevices forums I have it working  - squeezeboxserver-7.4.1-1 on SME7 that is!
:) :) :) :)

The method is to install Perl 5.10.0 in parallel with the existing perl version on SME7 and then apply a few patches to make squeezeboxserver use it.

I will test procedure again on a fresh SME7 virtual machine and then write it up, if you can't wait have a look at http://forums.slimdevices.com/showthread.php?t=69507

Regards, Mark Leman

Offline markleman

  • **
  • 64
  • +0/-0
    • http://www.leman.net
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #12 on: December 08, 2009, 01:43:22 AM »
Tonight I have tested my install notes on a fresh virtual SME7. The notes are below but without much fancy formatting, instead I am creating a how-to page http://wiki.contribs.org/SqueezeBoxServer to document them.

ssh to server as root:

db yum_repositories set squeezecenter-release repository \
BaseURL http://repos.slimdevices.com/yum/squeezecenter/release/ \
EnableGroups no \
GPGCheck no \
GPGKey http://repos.slimdevices.com/yum/squeezecenter/RPM-GPG-KEY-SqueezeCenter \
Name 'SqueezeCenter Release Repository' \
Visible no \
status disabled

signal-event yum-modify

yum --enablerepo=squeezecenter-release install squeezeboxserver

db configuration set squeezeboxserver service \
status enabled \
TCPPorts 9000,3483 \
UDPPorts 9000,3483 \
access private

signal-event remoteaccess-update

mkdir -p /opt/squeezeboxserver/playlists
mkdir -p /opt/squeezeboxserver/music
chown squeezeboxserver:squeezeboxserver /opt/squeezeboxserver/playlists
chown squeezeboxserver:squeezeboxserver /opt/squeezeboxserver/music

cd /usr/local
wget http://www.herger.net/slim/perl510.tgz
tar -xzf perl510.tgz

check perl has installed ok with:
/usr/local/perl510/bin/perl5.10.0 -v

ln -s /usr/local/perl510/bin/perl5.10.0 /usr/local/bin/
ln -s /usr/share/squeezeboxserver/CPAN/ /usr/libexec/CPAN

Next 3 stages need to be repeated after any upgrade.

edit first line of '/usr/libexec/squeezeboxserver' and '/usr/libexec/squeezeboxserver-scanner'
from
#!/usr/bin/perl -w
to
#!/usr/local/bin/perl5.10.0 -w

edit '/usr/lib/perl5/vendor_perl/Slim/bootstrap.pm'

At line 142 add
@INC = grep { $_ !~ /5\.8/ } @INC;

To test:
sudo -u squeezeboxserver /usr/libexec/squeezeboxserver --prefsdir=/var/lib/squeezeboxserver/prefs --logdir=/var/log/squeezeboxserver --cachedir=/var/lib/squeezeboxserver/cache --charset=utf8 --d_startup --s_stdout

ctrl-c will stop

To start service
service squeezeboxserver start

access web interface at 'http://my_servers_ip:9000/'

logs are in /var/log/squeezeboxserver/

« Last Edit: December 09, 2009, 09:10:00 PM by markleman »

Offline markleman

  • **
  • 64
  • +0/-0
    • http://www.leman.net
Re: Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #13 on: December 08, 2009, 02:43:51 AM »
Chris - please could you edit the name of this thread and add [Solved] to it.
« Last Edit: December 08, 2009, 02:35:15 PM by markleman »

Offline chrislaurie

  • *
  • 96
  • +0/-0
[Solved] Upgrade to squeezeboxserver from squeezecenter - service won't start
« Reply #14 on: December 13, 2009, 09:43:16 AM »
I can confirm the methodology as put in the wiki works. I now have SqueezeboxServer running on SME7.4

Thanks A LOT to Mark Leman for sorting out this issue!

Now if I can figure out (or find someone who has already), how to add mplayer to SME, then I can alos listen to the BBC streams...