Koozali.org: home of the SME Server

How to configure Outlook 2013 to connect to SMEServer IMAP Account

Offline brianr

  • *
  • 978
  • +1/-0
I've just spent 40 minutes trying to get Outlook 2013 running on WIn8.1 to connect to an SMEServer V8.1 (fully up to date).

It will not let me me proceed through the configuration without doing the infamous "email test"  - which fails (not surprisingly - it always has). However the check box to suppress the test is greyed out, and I can find no way of getting it to be tickable.

I've found some internet discussions about it:

http://answers.microsoft.com/en-us/office/forum/office_2013_release-outlook/outlook-2013-how-to-disable-the-test-email-when/23bfc02b-3181-4bd5-bb2a-f45d872f7317?page=2

but no apparent solution.

Someone out there must have got this to work???

I ended up installing thunderbird (which is no bad thing), but promised to look into a solution...... :-)
Brian j Read
(retired, for a second time, still got 2 installations though)
The instrument I am playing is my favourite Melodeon.
.........

Offline Daniel B.

  • *
  • 1,699
  • +0/-0
    • Firewall Services, la sécurité des réseaux
Re: How to configure Outlook 2013 to connect to SMEServer IMAP Account
« Reply #1 on: May 22, 2014, 04:28:46 PM »
Edit /var/service/qpsmtpd/config/peers/local (or /var/service/qpsmtpd/config/peers/0 if the Outlook you want to configure isn't on the local network) and comment the line
Code: [Select]
check_basicheaders

Restart qpsmtpd
Code: [Select]
sv t /service/qpsmtpd
sv t /service/sqpsmtpd

Configure Outlook, the test will pass (as qpsmtpd no longer check if headers are valid). Once OL is configured, run

Code: [Select]
signal-event email-update

To re-enable the headers checks
C'est la fin du monde !!! :lol:

Offline Stefano

  • *
  • 10,820
  • +1/-0
Re: How to configure Outlook 2013 to connect to SMEServer IMAP Account
« Reply #2 on: May 22, 2014, 04:48:40 PM »
I've just spent 40 minutes trying to get Outlook 2013 running on WIn8.1 to connect to an SMEServer V8.1 (fully up to date).
...
I ended up installing thunderbird (which is no bad thing), but promised to look into a solution...... :-)

you already have the solution.. don't use outlook, it doesn't add any plus feature as a simple email/imap client  without exhange.. it only eats tons of ram and hd space and it's not standard compliant (doh..)

Offline brianr

  • *
  • 978
  • +1/-0
Re: How to configure Outlook 2013 to connect to SMEServer IMAP Account
« Reply #3 on: May 22, 2014, 05:51:34 PM »
you already have the solution.. don't use outlook, it doesn't add any plus feature as a simple email/imap client  without exhange.. it only eats tons of ram and hd space and it's not standard compliant (doh..)

yes, Stefano, I agree entirely, however many of my customers do not understand...... :???:
Brian j Read
(retired, for a second time, still got 2 installations though)
The instrument I am playing is my favourite Melodeon.
.........

Offline brianr

  • *
  • 978
  • +1/-0
Re: How to configure Outlook 2013 to connect to SMEServer IMAP Account
« Reply #4 on: May 22, 2014, 06:13:27 PM »
Edit /var/service/qpsmtpd/config/peers/local (or /var/service/qpsmtpd/config/peers/0 if the Outlook you want to configure isn't on the local network) and comment the line
Code: [Select]
check_basicheaders

Restart qpsmtpd
Code: [Select]
sv t /service/qpsmtpd
sv t /service/sqpsmtpd

Configure Outlook, the test will pass (as qpsmtpd no longer check if headers are valid). Once OL is configured, run

Code: [Select]
signal-event email-update

To re-enable the headers checks

oh yes - very good - many thanks.  I'll be able to let them know I can do it now (if they decide to not pursue Thunderbird)
Brian j Read
(retired, for a second time, still got 2 installations though)
The instrument I am playing is my favourite Melodeon.
.........

Offline brianr

  • *
  • 978
  • +1/-0
Re: How to configure Outlook 2013 to connect to SMEServer IMAP Account
« Reply #5 on: May 22, 2014, 06:31:16 PM »
Edit /var/service/qpsmtpd/config/peers/local (or /var/service/qpsmtpd/config/peers/0 if the Outlook you want to configure isn't on the local network) and comment the line
Code: [Select]
check_basicheaders

Restart qpsmtpd
Code: [Select]
sv t /service/qpsmtpd
sv t /service/sqpsmtpd

Configure Outlook, the test will pass (as qpsmtpd no longer check if headers are valid). Once OL is configured, run

Code: [Select]
signal-event email-update

To re-enable the headers checks

I've added this to the Wiki:

http://wiki.contribs.org/Email_-_Setting_up_E-mail_clients_for_SME_8.0#Set_encryption_and_authorisation_parameters
Brian j Read
(retired, for a second time, still got 2 installations though)
The instrument I am playing is my favourite Melodeon.
.........


Offline brianr

  • *
  • 978
  • +1/-0
Re: How to configure Outlook 2013 to connect to SMEServer IMAP Account
« Reply #7 on: May 22, 2014, 08:20:36 PM »
Wow. Oulook (or should I say Lookout!) is still that bad!!

I envy you Charlie not having to cope with it.
Brian j Read
(retired, for a second time, still got 2 installations though)
The instrument I am playing is my favourite Melodeon.
.........

Offline igloosys

  • 10
  • +0/-0
Re: How to configure Outlook 2013 to connect to SMEServer IMAP Account
« Reply #8 on: July 29, 2014, 12:00:06 PM »
if I can contribute, the work around to get rid of the outlook 2013 test email is to first update outlook 2013 to sp1
setup the email account like normal, only difference is in the outgoing smtp server, set it to google or local isp that allows "no Date header", under More Settings, Outgoing Server tab, provide the credentials OR untick for non authenticated mode. apply ok and Outlook will be ready to login to the imap server and attempt to send test email using another smtp server.
one the test email is sent, the email account will be registered in outlook. go back to the account setup, change the account setup to the correct outgoing smtp server. then you can configure under More Settings, Outgoing Server tab again, this time, tick the "My Outgoing Server (SMTP) requires authentication". Click ok, brings you back to the previous screen, this time, the "Automatically test account setting blah blah..." can be unticked unlike the first time you tried to setup the account. don't ask me why. but I think Microsoft have decided to make imap impossible to setup.

its for sure not the best method, but its a work around which I hope others can benefit from it. cos I tried many days and we are not getting any feedback from Microsoft. all listed solutions like above are all half baked or not even solutions. the army of Microsoft engineers are repeating themselves with half answers which doesn't work. but as with normal users, they demand outlook as they paid dollars for the whole office suite and they want to get their every penny work.

enough of ranting...

another issue that one have to take care, is that if user originally have a lot of folders and subfolders created, moving to outlook 2013 might face missing folders or incomplete emails. solution is to add "Inbox" as the root folder and do some testing to make sure you get the folders back. Depending on how the email account was utilised in previous outlook version, some "migration" of the folders are required to make sure the folders and emails are showing up correctly.

happy setting.....

Offline warren

  • *
  • 286
  • +0/-0
Re: How to configure Outlook 2013 to connect to SMEServer IMAP Account
« Reply #9 on: July 29, 2014, 04:04:44 PM »
Just had a query today about this and was busy finding info on it :

Another work around suggested :  Haven't tried this yet..

( http://www.sevenforums.com/microsoft-office/270128-outlook-2013-cannot-configure-imap-pop3-wen-away-home-isp-post2817298.html#post2817298

Quote
I'm also baffled as to why MS decided to implement it this way, or if it just "slipped under the rug", but I found a way around it

    Go to setup your email server manually.
    Go to "More Settings" and select the "Advanced" tab.
    Set the Outgoing server to port 465 and select "SSL" under "Use the following type of encrypted connection".
    Select OK and try again. It came up with an error that was stating it didn't have a valid certificate (continue anyway) and then it worked.
    Go back into the account options, and you'll find that the checkbox for "Automatically test account settings when Next is clicked" can be deselected. Deselect this, go back to where you changed the port and change it back to whatever it was before. Click OK, click Next, and you're good to go.


Again, it's ridiculous. But it worked for me. Hope it works for you guys.
Give me some rep if it does so I know I helped!


Luckily I dont use Lookout  :grin:

Offline igloosys

  • 10
  • +0/-0
Re: How to configure Outlook 2013 to connect to SMEServer IMAP Account
« Reply #10 on: July 29, 2014, 04:39:29 PM »
Thanks warren. But that method doesn't work. At least based on what I can try to replicate the steps mentioned. But still a good reference for whoever is having trouble setting up outlook 2013 against sme dovecot.