Koozali.org: home of the SME Server

SME 10 - passage en RAID 1 "après coup"

Offline _YO_

  • **
  • 45
  • +0/-0
SME 10 - passage en RAID 1 "après coup"
« on: December 11, 2021, 01:12:15 PM »
Bonjour à tous,

J'ai récemment migré de SME 9.2 à 10.
J'ai suivi la méthode de créer un "petit" fichier smeserver.tgz.
J'ai obtenu ce fichier après avoir temporairement déplacé les iBays et les fichiers utilisateurs que j'ai ensuite récupérés d'un backup sur un disque externe. Je suis maintenant en SME 10, mais ...

J'avais acheté 2 disques de 1Tb voulant passer en RAID 1. A la lecture des informations comme quoi l'install de Centos ne gère pas les doubles disques de la même manière que l'install de SME, je n'en ai monté qu'un pour créer le nouveau système.

J'ai tenté d'ajouter ce 2nd disque après coup. Mais l'option 5 de la console SME :"Gérer la redondance des disques" me dit "Aucun périphérique RAID configuré". Et c'est là que je vois que SME 10 gère un seul disque comme "No software RAID" au lieu de "Degraded RAID 1" auparavant.

Bref vous imaginez donc ma question :
Y aurait-il moyen de passer en RAID 1 sur un système en mode "No software RAID" ?
Je n'ai pas trouvé de tuto sur ce sujet. Ceux que je trouve partent toujours d'un système avec un RAID déjà configuré ce qui n'est pas mon cas.

Merci pour votre aide.                    .YO.
.YO.

Offline gieres

  • *
  • 180
  • +0/-0
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #1 on: December 11, 2021, 04:08:45 PM »
Bonjour,
Et là, vous n'avez pas trouvé votre réponse ?
https://wiki.koozali.org/Raid
Bonne fin de semaine.

Offline _YO_

  • **
  • 45
  • +0/-0
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #2 on: December 11, 2021, 04:25:21 PM »
Bonjour Gieres,

Je suis effectivement déjà passé par ce lien. Je l'ai re-parcouru.

Mais mon cas n'est pas cité : Le point de départ est toujours un système RAID configuré.
Dans mon cas, je n'ai aucun RAID configuré.
.YO.

Offline TerryF

  • grumpy old man
  • *
  • 1,728
  • +2/-0
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #3 on: December 11, 2021, 09:11:15 PM »
SME10 erstellt nur dann ein Raid, wenn bei der Installation zwei oder mehr Laufwerke vorhanden sind, siehe Wiki, https://wiki.koozali.org/SME_Server:10.0
und auch die Raid-Seiten wie oben gezeigt

  Die Installation eines einzelnen Laufwerks erstellt kein beschädigtes Array, wie dies bei früheren Versionen der Fall war.

Verwendeter Google-Übersetzer
--
qui scribit bis legit

Offline gieres

  • *
  • 180
  • +0/-0
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #4 on: December 11, 2021, 10:47:30 PM »
Hello Terry,
Sie sprechen auch deutsch ?
Auf wiedersehen !

Offline TerryF

  • grumpy old man
  • *
  • 1,728
  • +2/-0
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #5 on: December 11, 2021, 11:44:58 PM »
mate, unfortunately nada, english dialect of Oz :-) many struggle to understand...
--
qui scribit bis legit

Offline TerryF

  • grumpy old man
  • *
  • 1,728
  • +2/-0
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #6 on: December 12, 2021, 12:54:07 AM »
SME10 ne crée un raid que si deux disques ou plus sont présents lors de l'installation, voir Wiki, https://wiki.koozali.org/SME_Server:10.0
et aussi les pages de raid comme indiqué ci-dessus

   L'installation d'un seul lecteur ne crée pas une matrice endommagée comme c'était le cas dans les versions précédentes.

et avant que quelqu'un demande, je ne parle pas des sous-marins :-)

Traducteur Google utilisé

Ajouté: ma mauvaise première trans en allemand par erreur
--
qui scribit bis legit

Offline Jean-Philippe Pialasse

  • *
  • 2,274
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #7 on: December 12, 2021, 02:00:34 AM »
malheureusement ton choix de ne mettre qu’un disque lors de l’installation etait le mauvais choix et est exactement ce qui t’empêche d’avoir acces au raid car justement SME10 ne permet pas le raid dégradé lors de l’installation comme le permettait avant l’ancien installer.

il te reste l’option si tu as un troisieme disque de mettre tes données en raid sur les deux disques restant en creant manuellement un raid et en le montant sur  /home/e-smith/files.
ou recommencer ton installation … avec les deux disques !

Offline gieres

  • *
  • 180
  • +0/-0
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #8 on: December 12, 2021, 09:37:36 AM »
@Jean-Philippe
Bonjour,
Donc il y a une solution...
Est-ce qu'il faudrait la rajouter dans la page https://wiki.koozali.org/Raid ?
Et/Ou https://wiki.koozali.org/SME_Server:10.0
Et/Ou ailleurs ?
Bonne journée.

Offline Jean-Philippe Pialasse

  • *
  • 2,274
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #9 on: December 12, 2021, 10:52:32 AM »
je dirais pas une solution mais une alternative au moins pour une partie des données.

c’est deja referencé https://wiki.koozali.org/index.php?title=AddExtraHardDisk


il reste que le systeme et mysql er les données dans sa base sont toujours sur un disque sans raid… avec les risques associés.  Donc toutes les données ne sont pas aussi bien protégées à un echec de disque. 

la solution à choisir reste de reinstaller avec les 2 disques en place !

Offline _YO_

  • **
  • 45
  • +0/-0
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #10 on: December 12, 2021, 03:05:37 PM »
OK. Merci gieres, Terry and Jean-Philippe pour vos réponses.

Donc j'ai un disque de 1Tb d'avance
Je le saurais pour SME 11 : installer les 2 disques AVANT l'installation de SME. :?

Bis zum nächsten Mal, Terry :lol:
.YO.

Offline Jean-Philippe Pialasse

  • *
  • 2,274
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: SME 10 - passage en RAID 1 "après coup"
« Reply #11 on: December 12, 2021, 03:49:49 PM »
tu peux l’utiliser pour des backup automatisés.

Terry qui a pas sélectionné la bonne langue dans google translate.

errare humanum est