Koozali.org: home of the SME Server

openvpn-bridge not populating log ?

Offline nicolatiana

  • *
  • 703
  • +0/-0
openvpn-bridge not populating log ?
« on: December 24, 2021, 10:01:07 AM »
Installed on a SME10 VM test box created from scratch, configured as Affa server and then raised with Affa.
The previous machine had very few contribs installed (smeadmin, diskusage, sogo), surely not openvpn-bridge.
I've installed openvpn-bridge according to wiki then, configured certificates. The service according to control panel and systemctl query is fine (I'm able to connect too) but no log file in /var/log/openvpn-bridge.
Some symlink missing or some "hidden" db variable to configure ?

Quote
[root@fudge-10 e-smith]# config show openvpn-bridge
openvpn-bridge=service
    Cipher=AES-128-CBC
    ConfigRequired=disabled
    CrlUrl=http://localhost:940/phpki/index.php?stage=dl_crl_pem
    HMAC=SHA256
    UDPPort=1194
    access=public
    clientToClient=disabled
    endPool=192.168.35.30
    management=localhost:11194:iaf3Z6brrrW49CJ1nccuMXFifY
    maxClients=20
    redirectGW=PerClient
    startPool=192.168.35.10
    status=enabled
    tapIf=tap0
    userAuth=CrtOnly

Quote
[root@fudge-10 e-smith]# systemctl status openvpn-bridge
● openvpn-bridge.service - OpenVPN Server to Server
   Loaded: loaded (/usr/lib/systemd/system/openvpn-bridge.service; enabled; vendor preset: enabled)
   Active: active (running) since ven 2021-12-24 09:24:23 CET; 17min ago
 Main PID: 4928 (openvpn)
   Status: "Pre-connection initialization successful"
   Memory: 996.0K
   CGroup: /system.slice/openvpn-bridge.service
           └─4928 /usr/sbin/openvpn --status /var/log/openvpn-bridge/status.log --status-version 2 --ncp-ciphers AES-256-GCM:AES-128-GCM:AES-256-CBC:AES-128-CBC:BF-CBC --config /etc/openvpn/bridge/openvpn.conf --cd /etc/openvpn/bridge...


dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: UDPv4 link remote: [AF_UNSPEC]
dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: chroot to '/etc/openvpn/bridge' and cd to '/' succeeded
dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: GID set to nobody
dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: UID set to nobody
dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: MULTI: multi_init called, r=256 v=256
dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: IFCONFIG POOL: base=192.168.35.10 size=21, ipv6=0
dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: Initialization Sequence Completed
dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: MANAGEMENT: Client connected from [AF_INET]127.0.0.1:11194
dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: MANAGEMENT: CMD 'status 2'
dic 24 09:24:23 fudge-10.chester-perry.com openvpn[4928]: MANAGEMENT: Client disconnected

Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia.

Offline Gary Douglas

  • *
  • 43
  • +0/-0
Re: openvpn-bridge not populating log ?
« Reply #1 on: December 24, 2021, 03:11:46 PM »

to follow in realtime # journalctl -f -u openvpn-bridge.service

and see; Bug 11795 - make journald persistent;  https://bugs.koozali.org/show_bug.cgi?id=11795

hope this helps
« Last Edit: December 26, 2021, 10:29:19 AM by Gary Douglas »

Offline Jean-Philippe Pialasse

  • *
  • 2,166
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: openvpn-bridge not populating log ?
« Reply #2 on: December 24, 2021, 03:27:10 PM »
Code: [Select]
journalctl -u openvpn-bridge
should be better. you can add -f to follow nee entries. 

another fix is on the way to make it back to the usual log file and also is journald.

plan that sme11 will probably be only using journald as default. 

Offline nicolatiana

  • *
  • 703
  • +0/-0
Re: openvpn-bridge not populating log ?
« Reply #3 on: December 28, 2021, 09:00:08 AM »
Ok


Many thanks for reply.
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia.