Koozali.org: home of the SME Server

PHPki - Réinstallation - Impossible d'accéder à la création du certificat CA

Offline gieres

  • *
  • 192
  • +0/-0
Bonjour,
Après une première installation d'OpenVPN/PHPKi pour laquelle je n'ai pas réussi l'installation des certificats dans OpenVPN, j'ai désinstallé puis réinstallé PHPki en suivant les prescriptions décrite ici https://wiki.koozali.org/PHPki/fr#R.C3.A9installation
Mais lorsque l'on clique dans le gestionnaire du serveur, la fenêtre qui s'ouvre n'est pas celle de la création du certificat racine (CA) mais directement celle qui permet de gérer les certificats. Mais si on demande à voir le certificat CA, cela donne
Code: [Select]
cat: : No such file or directory.
Accessoirement, je n'ai pas réalisée la sauvegarde recommandée avant de désinstaller et de supprimer tous les fichiers et répertoires de /opt/PHPki.
Et la commande dans la réinstallation
Code: [Select]
cat config.php.rpmsave > config.php a un retour en erreur car le fichier config.php.rpmsave n'existe pas à la réinstallation.
D'avance merci.

Offline ReetP

  • *
  • 3,441
  • +5/-0
Were you trying to keep old certificates or start again?

The old ones are really not very secure now. It is much better to start again as the new certificates will be much stronger.

So, if you start new make sure everything in /opt/phpki is removed - just move it somewhere safe. The certificates should be in a separate directory  /opt/phpki-store - you might have deleted /opt/phpki but not /opt/phpki-store ?

When you go to the PHPki page the first time you should see the setup page for a new CA.

Complete that and then press Submit and then WAIT for several minutes - it can take a LONG time to generate the new CA.

You can then generate new certificates.

If you want to use the old certificates you will have to

Backup the NEW CA and data in  /opt/phpki-store
Restore the OLD CA and certificates to /opt/phpki-store


...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 2,474
  • +10/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
si tu n’as pas fair de backup tu ne peux pas utiliser la reinstallation.
Il faut simplement tout desinstaller. verifier que /opt/phpki* sont vides
reinstaller comme une premiere installation.

Offline gieres

  • *
  • 192
  • +0/-0
@ReetP
Start again.
I do all that you describe but not a backup before.
@JPP
Merci.
Effectivement, j'arrive à la page de création du certificat racine.
Je vais modifier le wiki en ce sens.
Mais le nouvel écran pour le certificat racine comporte plus de cases sur la première page.
File:Capture d’écran 2022-06-17 22-20-27.png
(je ne sais pas comment on joint une image dans le forum)
« Last Edit: June 17, 2022, 10:35:01 PM by gieres »

Offline Jean-Philippe Pialasse

  • *
  • 2,474
  • +10/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
dans le menu à gauche il y a la possibilité de telecharger une nouvelle image. Idealement la bonne chose serait de mettre à jour l’image existante en allant sur la page de l’image mais au pire telecharge une nouvelle image.  si tu es tres motivé fais le en fr et en en.

Offline gieres

  • *
  • 192
  • +0/-0
Pour le « idéalement », c'est loupé, je n'ai vu qu'après cette possibilité de mise à jour.
A part cela, c'est fait.