Koozali.org: home of the SME Server

Utilisation d'un scanner...

Offline gaetan30

  • 20
  • +0/-0
Utilisation d'un scanner...
« on: June 23, 2022, 12:46:31 PM »
Bonjour à tous,
Je rencontre un soucis pour l'installation d'un nouveau scanner à la boite (pas un scanner de port ou de fréquence mais un scanner à papier ;) )
J'ai crée un utilisateur "scan" et une iBays "i_scan" dans laquelle je souhaite y mettre tous les documents que je scanne.
Le scanner (une imprimante OKI mais j'ai le même soucis de config avec une xerox) permet d'enregistrer des "profils"
en donnant notamment l'url ou on veut enregistrer les documents scannés, dans mon cas: \\192.168.1.1\i_scan
Le protocol est CIFS, le port 445, l'utilisateur: "scan" et son mot de passe
Sauf que lorsque je veux scanné, l'imprimante me dit "erreur reseau" et puis c'est tout.
En gros, je pense que celle ci n'arrive pas à écrire dans l'ibays mais je ne comprends pas pourquoi.
Une petite idée?
Si vous avez un scanner en réseau, comment avez vous fait?
En vous remerciant pour votre aide.
Gaëtan

Offline Jean-Philippe Pialasse

  • *
  • 2,274
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Utilisation d'un scanner...
« Reply #1 on: June 23, 2022, 02:40:08 PM »
j’assume que tu ad un SME 10.
quelle version de SMB est elle prevu de supporter?
CIFS correspond normalement à SMB1 qui est obsolete, mais certains fabricants continuent utiliser le terme pour SMB2 et SMB3. Tu as besoin que ton imprimante scanner utilise SMB 2 ou 3.

Alternativement tu pourrais utiliser sane (il y a une contrib, cherche sur le wiki) pour utiliser le scanner depuis la base d’utilisateur du SME.

Offline gaetan30

  • 20
  • +0/-0
Re: Utilisation d'un scanner...
« Reply #2 on: June 23, 2022, 04:46:33 PM »
mmmm effectivement, je viens de regarder la doc, malgré le fait que l'imprimante soit neuve (OKI MC853), elle gère du SMB1

TCP/IPv4, TCP/IPv6, NetBIOS sur TCP, LPR, Port9100, IPP, FTP, HTTP, TELNET, SMTP, POP3, SNMPv1/v3, DHCP, DHCPv6, DNS, DDNS, UPnP, WINS, SLP, Bonjour, SNTP, LLTD, Web Services Discovery (WSD), SSL/TLS, IPSec, CIFS, SMB (Version 1.0), LDAPv3, Kerberos

J'ai refais des essais en TCP ou FTP mais même résultats. D'après vous, le soucis vient uniquement de SMB 1? Pas moyen de passer outre? Je n'ai pas envie d'envoyer les scans via mail ou d'utiliser une clé usb (que les utilisateurs vont perdre et en terme de securité, ce n'est pas safe du tout....)

Offline Jean-Philippe Pialasse

  • *
  • 2,274
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Utilisation d'un scanner...
« Reply #3 on: June 23, 2022, 07:43:53 PM »
le FTP serait a explorer, il faut par defaut que l'impriamnte supporte FTP avec TLS. (FTP(S) à ne pas confondre avec SFTP)
il faut regarder si dans ce cas elle supporte un mode implicite ou explicite de TLS et adapter SME pour cela au besoin

Je contacterais à ta place OKI ou ton revendeur pour une mise a jour du firmware de l'imprimante pour supporter une version de SMB qui soit encore supporté !!! Surtout pour une imprimante neuve.

Current firmware version:  A07.92_0_6(Released on:02/02/2022)

Encore une fois l'alternative serait D'utiliser smeserver-sane et de configurer l'imprimante en mode scaner TWAIN mais tu perdra probablement la facilité d 'utilisation avec le chargeur de document par exemple.
les drivers sont sur le site au besoin:
https://www.oki.com/me/printing/support/drivers-and-utilities/colour-multifunction/45850404/?os=ab33