Koozali.org: home of the SME Server

PHP version problem

Offline Yves

  • 3
  • +0/-0
PHP version problem
« on: July 29, 2022, 04:38:25 PM »
Hi, I'm trying to change the version of php so that it can be compatible for my wordpress site but no matter what the changes are, the commands I made by following https://wiki.koozali.org/PHP_Software_Collections
this site, the php version does not change.
That's why I would like to know what the problem is

Offline Jean-Philippe Pialasse

  • *
  • 2,296
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: PHP version problem
« Reply #1 on: July 29, 2022, 06:18:51 PM »
Have you red the big warning in the Requirement section on the wiki page you point?

Also i do not quite understand why you post this to the development section of the forum. 

Offline Yves

  • 3
  • +0/-0
Re: PHP version problem
« Reply #2 on: August 16, 2022, 05:38:21 PM »
Thank you for your response,
In the future, if I want to ask questions like this one I have to ask them in which category in the forum?

Offline Jean-Philippe Pialasse

  • *
  • 2,296
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: PHP version problem
« Reply #3 on: August 16, 2022, 10:58:18 PM »
in the forum section related to your SME, version. 

if no forum section is available, there are high chances the version is deprecated and the answer will be upgrade.

In doubt try the general discussion section.

Offline Yves

  • 3
  • +0/-0
Re: PHP version problem
« Reply #4 on: Yesterday at 02:27:12 PM »
One more question, I followed what was indicated in the red warning and so I upgraded to Horde 5.2 but my php version is still 5.4 and does not change to the latest version.
I then followed the steps said in the wiki page above to change my server's php version but it still doesn't work.

Offline ReetP

  • *
  • 3,343
  • +5/-0
Re: PHP version problem
« Reply #5 on: Yesterday at 03:01:50 PM »
One more question, I followed what was indicated in the red warning

Note the big red warning says this:

Only for SME Server 9 64 bit which is now EOL and deprecated.

If you are using Koozali SME v10 then it is not SME v9 so DO NOT USE THAT PAGE. You may well trash your server and need a restore to get it back to normal.

If you are using v10 then your Horde version is 5.2.23

If you are still using v9 then you must upgrade immediately. We do not offer support for outdated versions beyond upgrading it to v10.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation