Koozali.org: home of the SME Server

Server broken after update!

Offline groyk

  • *
  • 138
  • +0/-0
Server broken after update!
« on: July 14, 2023, 08:48:27 AM »
Yesterday i updated my sme box because of the domain login issue "did not check the forum first 😐"

Now i can't connect to my server. Seems like mail. Httpd ssh ect. Is down.

However i am able to ping local ip adresses from the server console.

Edit: also successfully pinging external ip's. But can't resolve url on yum.

I have tried almost everything including loading backup from the day before with no luck.

Any suggestions?
« Last Edit: July 14, 2023, 09:37:07 AM by groyk »

Offline groyk

  • *
  • 138
  • +0/-0
Re: Server broken after update!
« Reply #1 on: July 14, 2023, 09:37:33 AM »
Edit: also successfully pinging external ip's. But can't resolve url on yum.

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Server broken after update!
« Reply #2 on: July 14, 2023, 07:52:48 PM »
we need a little help to help you.
what is the server mode? I only assume gateway as you soeak of internal and external ip
how did your updated ? via manager or cli?
any power outage?
did you issue a signal-event post-upgrade and reboot?

have you given a try on the server keyboard/ monitor to try a
signal-event post-upgrade; signal-event reboot

Offline groyk

  • *
  • 138
  • +0/-0
Re: Server broken after update!
« Reply #3 on: July 14, 2023, 10:02:58 PM »
Sorry for the missing information.

SME is "server only" behind firewall.
Updated via webmanager

Firewall is ok and i can ping both internal and external ip' but can't ping hostnames

Just tried
signal-event post-upgrade;

I seems like server hangs. Waited for around 120 min. and still running.
« Last Edit: July 14, 2023, 11:03:32 PM by groyk »

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Server broken after update!
« Reply #4 on: July 15, 2023, 12:38:25 AM »
any contribs?
any template-custom?

are you able to open another terminal and check with htop what is running under this envent using the tree view (t key)

Offline groyk

  • *
  • 138
  • +0/-0
Re: Server broken after update!
« Reply #5 on: July 15, 2023, 07:47:23 AM »
Contribs
- fail2ban
- tw-logonscript
- whitelist blacklist
And a few more not network related.

Sorry no can't connect via ssh

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Server broken after update!
« Reply #6 on: July 15, 2023, 03:28:39 PM »
Accessing a TTY
Ctrl+Alt+F1: Opens TTY 1.
Ctrl+Alt+F2: Opens TTY 2.
Ctrl+Alt+F3: Opens TTY 3.
Ctrl+Alt+F4: Opens TTY 4.
Ctrl+Alt+F5: Opens TTY 5.
Ctrl+Alt+F6: Opens TTY 6.

https://www.howtogeek.com/428174/what-is-a-tty-on-linux-and-how-to-use-the-tty-command/amp/

Offline groyk

  • *
  • 138
  • +0/-0
Re: Server broken after update!
« Reply #7 on: July 15, 2023, 06:24:22 PM »
Only access is through novnc in proxmox 😐

Offline groyk

  • *
  • 138
  • +0/-0
Re: Server broken after update!
« Reply #8 on: July 15, 2023, 08:25:41 PM »
If i select earlier state on booting sme.

Would i then suffer dataloss?
Or only "installstate"?

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Server broken after update!
« Reply #9 on: July 16, 2023, 06:42:53 AM »
so another info the server is a vm on proxmox.

use the ctrl / alt button of the novnc interface


not sure of what you mean about installstate.

if you refer to a snapshot used by proxmox, i would say yes to data loss.

Offline groyk

  • *
  • 138
  • +0/-0
Re: Server broken after update!
« Reply #10 on: July 16, 2023, 08:35:30 AM »
I am thinking of selecting earlier version when booting smeserver. It boots with a menu where i can select earlier version. "Not proxmox snapshot"

I will try your suggestion when i have access to an pc again. Right now i only have my phone because i am on vacation.

Thank you for your help so far.

Offline ReetP

  • *
  • 3,704
  • +5/-0
Re: Server broken after update!
« Reply #11 on: July 16, 2023, 10:39:08 AM »
I am thinking of selecting earlier version when booting smeserver. It boots with a menu where i can select earlier version. "Not proxmox snapshot"

That's an earlier kernel version.

Won't change the data.

Quote
Yesterday i updated my sme box because of the domain login

That won't affect your domain logon issue as it is a Windows update that caused it, not a SME update.

You can test with a Windows pc without a domain logon.

There is no fix for SME currently. We are waiting for upstream. The only solution is in the other thread - remove the updates.

Quote
Now i can't connect to my server. Seems like mail. Httpd ssh ect. Is down.

I not sure those services would be affected by the domain issue?

First test with a pc without a domain logon.

Then have a look in your server logs for errors.

https://wiki.koozali.org/How_to_report_a_problem#History
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline groyk

  • *
  • 138
  • +0/-0
Re: Server broken after update!
« Reply #12 on: July 16, 2023, 11:22:24 AM »
Tried to uninstall fail2ban😀

Now everything is running😀

Offline ReetP

  • *
  • 3,704
  • +5/-0
Re: Server broken after update!
« Reply #13 on: July 16, 2023, 02:32:50 PM »
Tried to uninstall fail2ban😀

Now everything is running😀

Ahhhhh..... Explains a lot!
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Server broken after update!
« Reply #14 on: July 16, 2023, 03:50:08 PM »
what would help there is to check what rule has trigger the shutdown of network access. 
long event is also explained as during that event fail2ban will update and check the blacklist created and could take times with hundreds of entries (been there)