Koozali.org: home of the SME Server

update with smeserver-qpsmtpd-2.7.0-12

Offline Sergio Piñon

  • 14
  • +0/-0
update with smeserver-qpsmtpd-2.7.0-12
« on: August 14, 2023, 07:21:54 PM »
Good morning!!, Requesting your valuable help, I updated with smeserver-qpsmtpd-2.7.0-12 , and now no Outlook client can send emails, it says password error. I have the password as strong. what could i do to solve it. Thank you so much!

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #1 on: August 14, 2023, 07:44:06 PM »
a new update should be available shortly  see bug https://bugs.koozali.org/show_bug.cgi?id=12395


waiting for it this should help:

yum update perl-Net-IMAP-Simple --enablerepo=smeupdates-testing

then
systemctl restart qpsmtpd
systemctl restart sqpsmtpd

Offline ReetP

  • *
  • 3,704
  • +5/-0
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Sergio Piñon

  • 14
  • +0/-0
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #3 on: August 14, 2023, 07:54:04 PM »
It didn't work, so I'll wait for the new update. Thank you so much.

Offline Sergio Piñon

  • 14
  • +0/-0
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #4 on: August 15, 2023, 01:14:35 AM »
"fixed rpm is in smeupdates-testing
yum update smeserver-qpsmtpd --enablerepo=smeupdates-testing"


Unfortunately this patch did not work for me.

Offline TerryF

  • grumpy old man
  • *
  • 1,819
  • +6/-0
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #5 on: August 15, 2023, 02:23:35 AM »
It was I who released the smeserver-qpsmtpd update, should have also included the perl-Net-IMAP-Simple as well, although as the semserver-qpsmtpd update stood it would not have pulled the perl-Net-IMAP-Simple package, would have needed to be included in the overall updating flow..anyway, this is what I did to confirm what should be happening, as an aside these updates have been sitting in the updates-testing for some months, needed a properly configured test resource, so looking at below, mostly for your info..follow your own procedures for updating, ie wait until all have been released to updates

for anyone caught who has been caught..I did this to make sure..you may be less concerned and go your merry way :-)

Shouldnt be necessary however I already had the perl-Net-IMAP-Simple installed, for purposes of example took it back to default

# yum downgrade smeserver-qpsmtpd  perl-Net-IMAP-Simple

then

# yum update smeserver-qpsmtpd --enablerepo=smeupdates-testing
---snip---
Resolving Dependencies
--> Running transaction check
---> Package smeserver-qpsmtpd.noarch 0:2.7.0-11.el7.sme will be updated
---> Package smeserver-qpsmtpd.noarch 0:2.7.0-13.el7.sme will be an update
--> Processing Dependency: perl(Net::IMAP::Simple) >= 1.2212 for package: smeserver-qpsmtpd-2.7.0-13.el7.sme.noarch
--> Running transaction check
---> Package perl-Net-IMAP-Simple.noarch 0:1.1916-3.el7.sme will be updated
---> Package perl-Net-IMAP-Simple.noarch 0:1.2212-1.of.el7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================
 Package                           Arch                Version                        Repository                       Size
===========================================================
Updating:
 smeserver-qpsmtpd        noarch              2.7.0-13.el7.sme         smeupdates-testing         150 k
Updating for dependencies:
 perl-Net-IMAP-Simple     noarch              1.2212-1.of.el7            smeupdates-testing         54 k

Transaction Summary
===========================================================
Upgrade  1 Package (+1 Dependent package)

Total download size: 204 k
Is this ok [y/d/N]: y
Downloading packages:
(1/2): perl-Net-IMAP-Simple-1.2212-1.of.el7.noarch.rpm  |  54 kB  00:00:00
(2/2): smeserver-qpsmtpd-2.7.0-13.el7.sme.noarch.rpm  | 150 kB  00:00:00
-------------
Total                                                                                       224 kB/s | 204 kB  00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : perl-Net-IMAP-Simple-1.2212-1.of.el7.noarch                                                              1/4
  Updating   : smeserver-qpsmtpd-2.7.0-13.el7.sme.noarch                                                                2/4
  Cleanup    : smeserver-qpsmtpd-2.7.0-11.el7.sme.noarch                                                                3/4
  Cleanup    : perl-Net-IMAP-Simple-1.1916-3.el7.sme.noarch                                                             4/4
Initializing databases
---snip---
Executing signal-event temp ...........
Reload yum db for server-manager
  Verifying  : perl-Net-IMAP-Simple-1.2212-1.of.el7.noarch                                                              1/4
  Verifying  : smeserver-qpsmtpd-2.7.0-13.el7.sme.noarch                                                                2/4
  Verifying  : smeserver-qpsmtpd-2.7.0-11.el7.sme.noarch                                                                3/4
  Verifying  : perl-Net-IMAP-Simple-1.1916-3.el7.sme.noarch                                                             4/4

Updated:
  smeserver-qpsmtpd.noarch 0:2.7.0-13.el7.sme

Dependency Updated:
  perl-Net-IMAP-Simple.noarch 0:1.2212-1.of.el7

Complete!
--
qui scribit bis legit

Offline TerryF

  • grumpy old man
  • *
  • 1,819
  • +6/-0
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #6 on: August 15, 2023, 02:29:21 AM »
left a bit off, as shown in other places, follow that up with

# systemctl restart qpsmtpd
and
# systemctl restart sqpsmtpd

and if want to be satisfied can check with

# systemctl status qpsmtpd
and
# systemctl status sqpsmtpd
--
qui scribit bis legit

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #7 on: August 15, 2023, 03:42:31 AM »
left a bit off, as shown in other places, follow that up with

# systemctl restart qpsmtpd
and
# systemctl restart sqpsmtpd

and if want to be satisfied can check with

# systemctl status qpsmtpd
and
# systemctl status sqpsmtpd
part of the update process does the restart the services

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #8 on: August 15, 2023, 03:49:55 AM »
"fixed rpm is in smeupdates-testing
yum update smeserver-qpsmtpd --enablerepo=smeupdates-testing"


Unfortunately this patch did not work for me.

what does gives
rpm -q smeserver-qpsmtpd

Is it all client or only few of them? Are those failing having a special character in common ?

also logs could help during the connection error
tail -f /var/log/qpsmtpd/current
or
tail -f /var/log/sqpsmtpd/current
depending on the port you are using

as a temporary measure you could rollback:
yum downgrade smeserver-qpsmtpd-2.7.0-11.el7.sme

« Last Edit: August 15, 2023, 03:56:17 AM by Jean-Philippe Pialasse »

Offline Sergio Piñon

  • 14
  • +0/-0
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #9 on: August 15, 2023, 09:47:44 PM »
Greetings, I tried everything you suggested but it didn't work for me.
With the "yum downgrade smeserver-qpsmtpd-2.7.0-11.el7.sme", that's how it works correctly for me.

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #10 on: August 15, 2023, 10:02:52 PM »
i will re ask the same question because you did not answer and they are very important in solving your issue, while the downgrade is to allow to workaround and let your user able to work.

1/ Is it all clients or only few of them? Are those failing having a special character in common ?

2/also logs could help during the connection error
tail -f /var/log/qpsmtpd/current
or
tail -f /var/log/sqpsmtpd/current
depending on the port you are using (and by could help i mean copy pasted here with sensitive information removed)


3/ i will add an important question: is webmail enabled or disabled on your server (check server-manager)?

4 and another important question: is imap enabled on your server or not (check server-manager)?



Offline Sergio Piñon

  • 14
  • +0/-0
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #11 on: August 15, 2023, 10:20:11 PM »
1.- All clients could not send emails but could receive them. All clients have a password "*" at the end.
2.- I couldn't see the logs as you indicate. But in outlook 2010 it asked for authentication but it didn't work,resetting the password and removing the "*".
3.- I enabled "webmail" and from there I could send emails without problem.
4.- I have "IMAP" disabled
Thanks!!

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #12 on: August 15, 2023, 11:27:54 PM »
1.- All clients could not send emails but could receive them. All clients have a password "*" at the end.
2.- I couldn't see the logs as you indicate. But in outlook 2010 it asked for authentication but it didn't work,resetting the password and removing the "*".
3.- I enabled "webmail" and from there I could send emails without problem.
4.- I have "IMAP" disabled
Thanks!!
thanks for the detailed answer, I know how to fix it !

Offline ReetP

  • *
  • 3,704
  • +5/-0
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #13 on: August 16, 2023, 12:02:54 AM »
1.- All clients could not send emails but could receive them. All clients have a password "*" at the end.
2.- I couldn't see the logs as you indicate. But in outlook 2010 it asked for authentication but it didn't work,resetting the password and removing the "*".
3.- I enabled "webmail" and from there I could send emails without problem.
4.- I have "IMAP" disabled
Thanks!!

Thank you for such a concise response :-)

As JP said, he knows how to fix it now!

This is a complex issue..... I thought I had it fixed but evidently not!! Please do help testing new packages. We can help - just ask!

As far as IMAP/POP goes the world is moving away from POP (a shame M$ doesn't help by adding better support to its client). IMAP has many advantages - keep all your mail centrally - and well worth looking at.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 2,712
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: update with smeserver-qpsmtpd-2.7.0-12
« Reply #14 on: August 16, 2023, 04:38:46 AM »
https://bugs.koozali.org/show_bug.cgi?id=12398

fix will be soon in smeupdates-testing as smeserver-qpsmtpd-2.7.0-14.el7.sme