Koozali.org: home of the SME Server

SMTP 25 port athentication with no encryption doesnt work after update

Offline antraxso

  • 3
  • +0/-0
Hi,

yesterday i updated my server, made all the comands as usual (yum update, post-upgrade, reboot etc). But after the update SMTP server doesnt accept connections on port 25 with no encryption and plain authentication. Before the update this worked for more than 1 year and many updated were made.
When users email clients tries to connect to the server, they receive error, that no authentication is supported by server. What is causing this and maybe there is a solution?
TlsBeforeAuth is set to 0
authentication is enabled on qpsmtpd

Offline bunkobugsy

  • *
  • 283
  • +4/-0
recent updates
make sure all email clients send on 465 SSL with authentication
from the lan side clients/apps/copiers can also send on 25 but WITHOUT authentication, TLS is optional

Offline antraxso

  • 3
  • +0/-0
and there are no ways to disable this? :/
That means that we need to buy SSL certificate from third party, as some devices doesnt accept the self issued certificates.

Offline bunkobugsy

  • *
  • 283
  • +4/-0
and there are no ways to disable this? :/
That means that we need to buy SSL certificate from third party, as some devices doesnt accept the self issued certificates.

Read this https://wiki.koozali.org/Letsencrypt#Rush_jobs
« Last Edit: April 12, 2024, 12:14:04 PM by bunkobugsy »

Offline Jean-Philippe Pialasse

  • *
  • 2,818
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
nothing related  between not using self signed certificate and user auth not available on port 25 by default.



this was a regression to allow auth on port 25 in early 2023 that has been patched recently. You still have choice to enable it in manager but you will face huge amount of bruteforce attack and ddos.

you can accept the self signed certificate  as you have to do for auth on port 25 which uses starttls for port 465.  auth on port 25 does not mean no encryption, just explicit encryption instead of implicit, and most used port with higher amount of kiddie scripts trying to bruteforce

however i do encourage to use let’s encrypt certificate

Offline ReetP

  • *
  • 3,805
  • +5/-0
and there are no ways to disable this? :/

Only if you want to open yourself to a mountain of hack attempts.

Note that backend authentication systems have been changed as well - this is all to keep you secure.

Quote
That means that we need to buy SSL certificate from third party, as some devices don't accept the self issued certificates.

Yup - they are trying to tell you something, and there is a good chance that quite a lot of clients will drop plain unauthenticated connections in due course.... the push for better security is relentless, like it or not. The same will be true for http connections soon. Going the same way the Dodo did.

But you do NOT need to buy a certificate.

Letsencrypt certs are free and SME has had the ability to use them for several years. There is no real excuse not too, unless you run some sort of internal only, airgapped server. Even then there are methods to deploy to it.

You really should not be accepting any authentication on port 25 in 2024. Use 465 and enjoy some more security. If you are in the EU then it possibly even falls under GDPR.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline antraxso

  • 3
  • +0/-0
Thanks to all for help and clarification. Activated the Letsencrypt certificate and all is ok now. Many thanks!