Koozali.org: home of the SME Server

After March 22nd Pyzor timeouts with "reading response timed-out"

Offline Michail Pappas

  • *
  • 344
  • +1/-0
Taking a look on my SME 10 spamd logs, each and every pyzor mail check after March 22nd, 8am CET seems to fail with a timeout, for example:
Code: [Select]
Apr 21 08:24:01 mail spamd[10172]: spamd: connection from 127.0.0.1 [127.0.0.1]:42550 to port 783, fd 5
Apr 21 08:24:02 mail spamd[10172]: spamd: checking message <pUhpu000000000000000000000000000000000000000000000SCA1NC00U-CNIsrKQR2eWVkmj_3ukw@sfdc.net> for qpsmtpd:1005
Apr 21 08:24:07 mail spamd[10172]: pyzor: failure to parse response "public.pyzor.org:24441\t(504, 'Reading response timed-out.')"
Apr 21 08:24:07 mail spamd[10172]: spamd: clean message (3.1/4.0) for qpsmtpd:1005 in 5.6 seconds, 22293 bytes.
Apr 21 08:24:07 mail spamd[10172]: spamd: result: .  3 - DMARC_NONE,FREEMAIL_FORGED_FROMDOMAIN,FREEMAIL_FROM,HEADER_FROM_DIFFERENT_DOMAINS,HTML_MESSAGE,PDS_OTHER_BAD_TLD,RCVD_IN_DNSWL_NONE,SPF_HELO_NONE,SPF_PASS scantime=5.6,size=22293,user=qpsmtpd,uid=1005,required_score=4.0,rhost=127.0.0.1,raddr=127.0.0.1,rport=42550,mid=<pUhpu000000000000000000000000000000000000000000000SCA1NC00U-CNIsrKQR2eWVkmj_3ukw@sfdc.net>,autolearn=no autolearn_force=no
Apr 21 08:24:07 mail spamd[10164]: prefork: child states: II

Has the Pyzor network gone down permanently? If so, should I "clean" SME configuration somehow, with relation to Pyzor setup?

There's always the chance that the government WAN I'm in blocks somehow pyzor access...

EDIT: Some additional testing from the same LAN shows that public.pyzor.org is up, but port 24441/TCP is blocked:
Code: [Select]
> Test-NetConnection -port 24441 public.pyzor.org
WARNING: TCP connect to (154.61.86.89 : 24441) failed                                                                                                                                                                                           
ComputerName           : public.pyzor.org
RemoteAddress          : 154.61.86.89
RemotePort             : 24441
InterfaceAlias         : Ethernet
SourceAddress          : 10.x.y.z
PingSucceeded          : True
PingReplyDetails (RTT) : 82 ms
TcpTestSucceeded       : False
« Last Edit: April 24, 2024, 08:26:40 AM by Michail Pappas »

Offline Fumetto

  • *
  • 879
  • +1/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #1 on: April 24, 2024, 04:39:43 PM »
Same here
Code: [Select]
> Test-NetConnection -port 24441 public.pyzor.org                                                      AVVISO: TCP connect to (154.61.86.89 : 24441) failed                                                                                                                                                                                           
ComputerName           : public.pyzor.org
RemoteAddress          : 154.61.86.89
RemotePort             : 24441
InterfaceAlias         : Ethernet
SourceAddress          : 192.168.13.209
PingSucceeded          : True
PingReplyDetails (RTT) : 51 ms
TcpTestSucceeded       : False

Offline ReetP

  • *
  • 3,786
  • +5/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #2 on: April 24, 2024, 05:13:27 PM »
No idea but try these:

https://www.pyzor.org/en/latest/client.html

Code: [Select]
pyzor check < "some.eml"
66.250.40.33:24441   (504, 'Reading response timed-out.')

Code: [Select]
pyzor ping
66.250.40.33:24441   (504, 'Reading response timed-out.')

Presume they may have issues though I see nothing in my logs about it.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 2,814
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #3 on: April 24, 2024, 06:04:38 PM »
ping works for me.
do you happen to notice where the server is situated. 
Any geofilter preventing connection form or to NL ?
Code: [Select]
dig public.pyzor.org +short
154.61.86.89
geoiplook 154.61.86.89
NL
pyzor ping
public.pyzor.org:24441  (200, 'OK')

Offline ReetP

  • *
  • 3,786
  • +5/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #4 on: April 24, 2024, 07:34:55 PM »
I maybe blocking them, but it rotates server IPs?

I might need to specifically pinhole my firewall to test.

Or maybe set TCPPort/UDPPort in spamassassin service?
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Michail Pappas

  • *
  • 344
  • +1/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #5 on: April 25, 2024, 07:06:07 AM »
Hmmm:

Code: [Select]
# dig +short public.pyzor.org
154.61.86.89

# pyzor ping
public.pyzor.org:24441  (504, 'Reading response timed-out.')

Since this is the same server Jean-Philippe receives successful responses, could it be that the pyzor admins are blocking/rate limiting things?

Offline ReetP

  • *
  • 3,786
  • +5/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #6 on: April 25, 2024, 12:10:20 PM »
I can now get the following on my cloiud servers

Code: [Select]
pyzor -d ping
Code: [Select]
2024-04-25 11:56:59,590 (15740) INFO No servers specified, defaulting to public.pyzor.org.
2024-04-25 https://forums.contribs.org/Themes/Koozali/images/bbc/code.gif11:56:59,598 (15740) WARNING No accounts are setup.  All commands will be executed by the anonymous user.
2024-04-25 11:56:59,598 (15740) DEBUG sending: 'Op: ping\nThread: 41991\nPV: 2.1\nUser: anonymous\nTime: 1714039019\nSig: 9fca9621d08585949f3b2bcce494f1ac69bf3e0f\n\n'
2024-04-25 11:56:59,623 (15740) DEBUG received: b'Code: 200\nDiag: OK\nPV: 2.1\nThread: 41991\n\n'/('154.61.86.89', 24441)
public.pyzor.org:24441 (200, 'OK')


Interestingly though the ping on the home box shows

Code: [Select]
pyzor -d ping

Code: [Select]
2024-04-25 11:56:47,102 (6668) WARNING No accounts are setup.  All commands will be executed by the anonymous user.
2024-04-25 11:56:47,116 (6668) DEBUG sending: 'Op: ping\nThread: 47938\nPV: 2.1\nUser: anonymous\nTime: 1714039007\nSig: 76a17e74ef403f6ff98419264ceadde6fd370af2\n\n'
2024-04-25 11:56:52,141 (6668) ERROR ('66.250.40.33', 24441) TimeoutError: Reading response timed-out.
66.250.40.33:24441 (504, 'Reading response timed-out.')


Seems the IP address has not resolved correctly?

Code: [Select]
nslookup public.pyzor.org
Code: [Select]
Server: 192.168.10.1
Address: 192.168.10.1#53

Non-authoritative answer:
Name: public.pyzor.org
Address: 154.61.86.89


Hmmmm - very odd. Why is pyzor using a different IP address?

So I created a pyzorserver.txt file in /root

I added the latest IP 154.61.86.89

And then ran

Code: [Select]
pyzor -d --servers-file /root/pyzorservers.txt ping
Code: [Select]
2024-04-25 12:03:55,123 (7228) INFO No servers specified, defaulting to public.pyzor.org.
2024-04-25 12:03:55,124 (7228) WARNING No accounts are setup.  All commands will be executed by the anonymous user.
2024-04-25 12:03:55,126 (7228) DEBUG sending: 'Op: ping\nThread: 22040\nPV: 2.1\nUser: anonymous\nTime: 1714039435\nSig: b81f57d4f777e13efaa4c07080eaf0ee34b18943\n\n'
2024-04-25 12:03:55,179 (7228) DEBUG received: b'Code: 200\nDiag: OK\nPV: 2.1\nThread: 22040\n\n'/('154.61.86.89', 24441)
public.pyzor.org:24441 (200, 'OK')

OK :-)

So it isn't getting the right address for some reason.

So then I check and lo.

In /root/.pyzor I have a file called servers - dated 28 Feb 2004!

It contains this:

Code: [Select]
66.250.40.33:24441
Doh!!

Removed that and

Code: [Select]
pyzor -d ping
Code: [Select]
2024-04-25 12:08:10,164 (7596) INFO No servers specified, defaulting to public.pyzor.org.
2024-04-25 12:08:10,164 (7596) WARNING No accounts are setup.  All commands will be executed by the anonymous user.
2024-04-25 12:08:10,166 (7596) DEBUG sending: 'Op: ping\nThread: 32195\nPV: 2.1\nUser: anonymous\nTime: 1714039690\nSig: e43618a68d5e69a9cd3539c4d693b6a6492100f4\n\n'
2024-04-25 12:08:10,219 (7596) DEBUG received: b'Code: 200\nDiag: OK\nPV: 2.1\nThread: 32195\n\n'/('154.61.86.89', 24441)
public.pyzor.org:24441 (200, 'OK')


So I imagine they changed servers or closed one down which led to a temporary 504. Mine was probably not working correctly for a long time!

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline ReetP

  • *
  • 3,786
  • +5/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #7 on: April 25, 2024, 12:12:03 PM »
PS my UK office server ALSO had a /root/pyzor/servers file with a fixed IP - that one dated 8 Mar 2004 !
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Michail Pappas

  • *
  • 344
  • +1/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #8 on: April 25, 2024, 01:18:30 PM »
Glad it worked for you mate, still strange it does not work for me. Command
Code: [Select]
pyzor -d --servers-file /root/pyzorservers.txt ping

should prolly be:
Code: [Select]
pyzor -d --servers-file=/root/pyzorservers.txt ping

However, in either case the command failed with:
Code: [Select]
2024-04-25 14:13:29,751 (1990) INFO No servers specified, defaulting to public.pyzor.org.
2024-04-25 14:13:29,751 (1990) WARNING No accounts are setup.  All commands will be executed by the anonymous user.
2024-04-25 14:13:29,752 (1990) DEBUG sending: 'Op: ping\nThread: 8176\nPV: 2.1\nUser: anonymous\nTime: 1714043609\nSig: 537b1fe353eba884e164cd718836179d02b75fcc\n\n'
2024-04-25 14:13:34,760 (1990) ERROR ('public.pyzor.org', 24441)        TimeoutError: Reading response timed-out.
public.pyzor.org:24441  (504, 'Reading response timed-out.')

Of interest was the fact that the last line refers to public.pyzor.org and not to the ip address 154.61.86.89 contained in /root/pyzorservers.txt

So, so far this works for you, with the exception of Fumetto, who could perhaps delete ~/.pyzor and tryi a pyzor ping again.

Doing a find / -name .pyzor yielded also /var/spool/spamd/.pyzor. This directory contains a servers file, which in turn contains public.pyzor.org:24441.

Still trying to find someone within the WAN to duplicate this behaviour.

Offline Michail Pappas

  • *
  • 344
  • +1/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #9 on: May 31, 2024, 10:25:28 AM »
It was a WAN issue after, they fixed it but I've started receiving 504 timeouts from May 29th. I'm trying to isolate whether this is a pyzor server issue, or a WAN firewall regression, so can someone do a pyzor ping and report back whether it's ok?

Offline ReetP

  • *
  • 3,786
  • +5/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #10 on: May 31, 2024, 11:13:58 AM »

Code: [Select]
pyzor -d ping
Code: [Select]
2024-05-31 11:12:26,601 (17554) INFO No servers specified, d
efaulting to public.pyzor.org.
2024-05-31 11:12:26,611 (17554) WARNING No accounts are setu
p.  All commands will be executed by the anonymous user.
2024-05-31 11:12:26,613 (17554) DEBUG sending: 'Op: ping\nTh
read: 61188\nPV: 2.1\nUser: anonymous\nTime: 1717146746\nSig
: e83ea8b7c4b41d8edea36aaec3cc434c151b9e97\n\n'
2024-05-31 11:12:26,672 (17554) DEBUG received: b'Code: 200\
nDiag: OK\nPV: 2.1\nThread: 61188\n\n'/('154.61.86.89', 2444
1)

public.pyzor.org:24441  (200, 'OK')
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Michail Pappas

  • *
  • 344
  • +1/-0
Re: After March 22nd Pyzor timeouts with "reading response timed-out"
« Reply #11 on: May 31, 2024, 12:14:51 PM »
Thanks a lot matey!