Koozali.org: home of the SME Server

BackupPC install fails - public key for rpm not installed

Offline Curtis

  • 16
  • +0/-0
BackupPC install fails - public key for rpm not installed
« on: April 26, 2024, 02:49:36 PM »
Hello, all.  I have a working fully updated install of SME 10.1 running on trusted hardware.  Attempting to install BackupPC, per instructions:
Code: [Select]
yum --enablerepo=smecontribs install smeserver-BackupPCreturns:
Code: [Select]
Transaction Summary
================================================================================
Install  1 Package (+48 Dependent packages)

Total size: 6.7 M
Installed size: 35 M
Is this ok [y/d/N]: y
Downloading packages:
warning: /var/cache/yum/x86_64/7/smecontribs/packages/BackupPC4-4.4.0-2.el7.fws.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7cb6de2c: NOKEY

Public key for BackupPC4-4.4.0-2.el7.fws.x86_64.rpm is not installed

I have cleared the yum cache and the issue persists.  I assume it is a problem on the repo end, but I would appreciate any helpful insight. 

Offline Jean-Philippe Pialasse

  • *
  • 2,818
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com

Offline Jean-Philippe Pialasse

  • *
  • 2,818
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: BackupPC install fails - public key for rpm not installed
« Reply #2 on: April 28, 2024, 05:52:46 AM »

Offline Curtis

  • 16
  • +0/-0
Re: BackupPC install fails - public key for rpm not installed
« Reply #3 on: April 29, 2024, 10:35:26 PM »
Thank you, Jean-Philippe.  I was in a bind to get a weekend backup going, so I did the unthinkable and installed with the yum "--nogpgcheck flag".  Bad practice, I realize. 

I will uninstall and reinstall from your mirror (once my backup server is idle) and report my findings.  Thanks again!

Offline Curtis

  • 16
  • +0/-0
Re: BackupPC install fails - public key for rpm not installed
« Reply #4 on: May 13, 2024, 08:12:14 PM »
or test this new rpm as a fix

https://bugs.koozali.org/show_bug.cgi?id=12653

After applying the yum rpm from the smeupdates-testing repo, BackupPC installed flawlessly.  Thank you for your help!