Koozali.org: home of the SME Server

Nextcloud PHP

Offline simone686

  • ***
  • 78
  • +0/-0
Nextcloud PHP
« on: May 15, 2024, 08:37:13 AM »
Salve a tutti...

ho avuto un problema con un server e adesso dopo aver reinstallato e rimesso tutto a posto installando NEXTCLOUD mi dice

This version of Nextcloud requires at least PHP 8.0<br/>You are currently running 7.4.33. Please update your PHP version.

Non voglio pasticciare troppo quindi vi chiedo un aiuto.

Grazie

Offline ReetP

  • *
  • 3,760
  • +5/-0
Re: Nextcloud PHP
« Reply #1 on: May 15, 2024, 05:05:44 PM »
If you use the contrib and update each version of NextCloud the contrib will set the correct version of PHP for you.

You should have this installed.

smeserver-nextcloud-1.2.0-29.el7.sme.noarch

So upgrade Nextcloud and then:

Code: [Select]
signal-event smeserver-nextcloud-update
signal-event post-upgrade;signal-event reboot

Do not use v28+for now.

Stay at NC 27.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline simone686

  • ***
  • 78
  • +0/-0
Re: Nextcloud PHP
« Reply #2 on: May 15, 2024, 05:56:17 PM »
Grazie per la risposta.
La versione installata è quella..ho rilanciato i comandi che mi hai scritto..ma se provo a lanciare questo comando
occ config:system:set default_phone_region --value="it"

mi da sempre
This version of Nextcloud requires at least PHP 8.0<br/>You are currently running 7.4.33. Please update your PHP version.

Offline Jean-Philippe Pialasse

  • *
  • 2,806
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Nextcloud PHP
« Reply #3 on: May 15, 2024, 08:23:11 PM »
what version of nextcloud have you currently? check that in the administration panel in next cloud as admin user.

SME will use php 7.4 as long as you do not upgrade (using web gui) to a nextcloud version compatible with php8+ then with John’s command you can change that and process to further nextcloud uograde using the web gui

see wiki as always https://wiki.koozali.org/Nextcloud#Web_or_GUI_upgrade_from_NC25_to_NC26

as told by John we suggest to stay at NC27 for few weeks before going NC28 and wait more to upgrade to NC29 as it is still really early release.

Offline simone686

  • ***
  • 78
  • +0/-0
Re: Nextcloud PHP
« Reply #4 on: May 16, 2024, 12:08:18 PM »
Buongiorno

ho provato a rilanciare il comando per installare nextcloud e mi ha detto che smeserver-nextcloud-1.2.0-29.el7.sme.noarch era già installato. Non ho mai provato ad accedere alla Gui di Nextcloud.

Offline Jean-Philippe Pialasse

  • *
  • 2,806
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Nextcloud PHP
« Reply #5 on: May 16, 2024, 01:15:54 PM »
NC should be upgraded using its own interface.

where do you read « This version of Nextcloud requires at least PHP 8.0<br/>You are currently running 7.4.33. Please update your PHP version » if not in web GUI?

Offline simone686

  • ***
  • 78
  • +0/-0
Re: Nextcloud PHP
« Reply #6 on: May 16, 2024, 03:02:17 PM »
In the CLI when i try to execute

occ config:system:set default_phone_region --value="it"

Offline Jean-Philippe Pialasse

  • *
  • 2,806
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Nextcloud PHP
« Reply #7 on: May 16, 2024, 03:53:57 PM »

Offline TerryF

  • grumpy old man
  • *
  • 1,828
  • +6/-0
Re: Nextcloud PHP
« Reply #8 on: May 16, 2024, 10:57:36 PM »
Bug has been verified, see bug comments
--
qui scribit bis legit

Offline simone686

  • ***
  • 78
  • +0/-0
Re: Nextcloud PHP
« Reply #9 on: May 17, 2024, 11:58:58 AM »
Grazie...

per l'installazione in corso come mi devo comportare ? Faccio un update con smetest abilitato, rimuovo e reinstallo con smetest abilitato o esiste altra procedura ?


Offline TerryF

  • grumpy old man
  • *
  • 1,828
  • +6/-0
Re: Nextcloud PHP
« Reply #10 on: May 17, 2024, 01:39:03 PM »
updated smeserver-nextcloud has been released, now in smecontribs
--
qui scribit bis legit