Koozali.org: home of the SME Server

Réactiver l'accès au partage de fichiers via SMBv1 (SMB1) pour les Windows XP

Offline sdak

  • 7
  • +0/-0
Bonjour,

Je souhaite réactiver l'accès au partage de fichiers via SMBv1 pour les Windows XP. Pour ce faire, j'ai utilisé les commandes suivantes :

config setprop smb ServerMinProtocol NT1
config setprop smb ClientMinProtocol NT1
signal-event console-save
service smb restart
service nmb restart

A l'issue, les Windows XP peuvent demander une ressource mais l'authentification ne fonctionne pas. La réponse du net use avec naturellement des comptes valides :

L'erreur système 1326 s'est produite.
Échec d'ouverture de session : nom d'utilisateur inconnu ou mot de passe incorrect.

Y-a-t-il d'autres paramètres à changer pour réactiver l'authentification y compris une modification du registre du Windows XP en question ? Où pourrais-je trouver des logs concernant le refus d'authentification (rien dans log.smb ni log.nmb) ?

Naturellement, je sais qu'à ce jour avoir un Windows XP sur un réseau est déraisonnable et que réactiver le protocole SMBv1 l'est tout autant mais je n'ai pas trop le choix pour répondre rapidement à ma problématique.

Merci pour votre aide.

Offline ReetP

  • *
  • 3,291
  • +5/-0
You don't mention your Koozali SME version - presumably v9 -  but either way please see No 3 in my signature.

Quote
3. Don't ask for support on Unsupported versions of software

That is both server and desktop software.

Extended support for XP expired 7 years ago.

Win 7 expired in 2019.

SME v9 expired in Nov 2020.

Sorry but you have had more than enough time to resolve all this and upgrade.

That is the correct way to resolve your issues.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline sdak

  • 7
  • +0/-0
Bonjour,
J'en ai bien conscience et l'avais bien précisé dans ma question. Pourquoi vous perdez votre temps à me répondre si ça vous dérange ? Sans parasiter le forum je postais simplement ma question au cas ou quelqu'un avait déjà été confronté au problème et non pas pour qu'une personne cherche une solution à ma place. Pour finir le SMB1 a été désactivé sur SME 10 et c'est donc la version qui pose problème, en 9 pas de soucis.

Offline ReetP

  • *
  • 3,291
  • +5/-0
Because that is the answer. It isn't the one you want, but it is still the answer.

There are posts on how to enable SMB1 in v10 if you bother to search.

But I am not going to help you with an unsupported OS.

Upgrade. For your own benefit.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline sdak

  • 7
  • +0/-0
Pour ceux que cela intéresse, la solution est de rajouter la ligne suivante à la config. de Samba :

ntlm auth = ntlmv1-permitted

Il ne semble pas y avoir de paramètre dans la config. de SME donc il faut ajouter ce paramètre dans
les "templates-custom".

Offline ReetP

  • *
  • 3,291
  • +5/-0
It does not require a custom template.

There is a solution but you just haven't bothered reading enough.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 2,161
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
en fait oui et non ....

windows xp ne gere pas nativement le NTLMv2, il faut lui forcer, hors samba 4 requiert par defaut cette version

la bonne facon de faire serait de modifier les postes XP :
- en les upgradant vers une fedora, opensuse voir ubuntu

alternativement, une moins bonne facon de faire serait :
- en les upgradant vers un windows 10 ou 11.

alternativement une encore moins bonne option en editant la clef:
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/LSA/LMCompatibilityLevel  = 5 ; puis rebooter.

et en dernier diminuer encore plus la securité de l'echange de mot de passe samba en utilisant ce parametre via un templates-custom


voila de la lecture à ce sujet https://support.microsoft.com/en-us/topic/security-guidance-for-ntlmv1-and-lm-network-authentication-da2168b6-4a31-0088-fb03-f081acde6e73

Offline sdak

  • 7
  • +0/-0
Merci Jean-Philippe pour ta réponse exhaustive et modérée.

Offline Jean-Philippe Pialasse

  • *
  • 2,161
  • +8/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
ca fait plaisir d'avoir des nouvelles après l'aire des newsgroups et la fin de freenode.