Koozali.org, home of the SME Server

Scalix on SME


Scalix on SME
« on: July 05, 2004, 10:46:10 AM »

Anyone tried Scalix on SME ?


might just be the sought after MS Exchange alternative ?


« Reply #1 on: July 12, 2004, 12:35:47 AM »
trying to install now however it requires sendmail which is no problem but the install wizard looks for the file /etc/redhat-release I copied the file from a full standard rehat 7.3 install and it still dosent work "redhat-release is not owned by any package" anyone know of a work around for this?




Scalix on SME
« Reply #2 on: July 12, 2004, 07:12:09 AM »
hi steve

i think that you need to create a scalix username and group !

then try chmoding it and giving ownership and group permission to scalix for /etc/redhat-release?


Scalix on SME
« Reply #3 on: July 13, 2004, 07:07:56 AM »
any luck with it ?


that didnt work
« Reply #4 on: July 13, 2004, 05:01:59 PM »
Well that didn't work however I took the redht-release stock rpm and installed and that fixed the problem you have to install xwindows to use the scalix-wizard the install routine. now I have another problem when I uninstall qmail and install sendmail useing the e-smith-postfix contrib the dns portion of SME gets all screwed up any ideals on this one.



Offline sonoracomm

  • *
  • 208
  • +0/-0
    • http://www.sonoracomm.com
Scalix on SME
« Reply #5 on: July 14, 2004, 12:17:13 AM »
If anyone has success with this, I'm sure many others would be interested!



Scalix on SME
« Reply #6 on: July 14, 2004, 01:06:01 AM »
I have installed the Scalix system on a stock Redhat 7.3 system and it is great I would sure like to figure out how to make it work with SME server.


Scalix on SME
« Reply #7 on: February 19, 2006, 02:18:31 PM »
There's a tip about getting scalix to work on centos here

It's a bit out of date. Version 10 seems to install most of the stuff in the above guide automatically.

I tried it with the community edition, version 10 on SME server 7rc3

(EDITED - The howto that works is below).

Offline Franco

  • *
  • 1,171
  • +0/-0
    • http://contribs.org
Scalix on SME
« Reply #8 on: February 19, 2006, 07:26:43 PM »
Another tip from the same forum suggests the use of Java 1.4 and not 1.5, what version do you have it running?

These are the requirements to have it running on CentOS, and some report success.


Scalix on SME
« Reply #9 on: February 20, 2006, 08:24:53 AM »

Have you tried:

Jakarta Tomcat needs to be running for scalix. You need to manually start up tomcat from your tomcat directory \*tomcatdir*\bin\startup.sh.
Scalix webaccess (http://[localhost.domain.com]:8080/webmail) and the Scalix Administration Console (SAC) both need tomcat to run.




Scalix 10 on SME 7rc3 - works (ish)
« Reply #10 on: February 24, 2006, 12:37:08 AM »
[updated 28-Mar-06] Fixed some problems
[updated 29-Mar-06] Stopped some extra services, can now send / receive
[updated 30-Mar-06] Configure sendmail

Thanks for the suggestions, guys.
I finally got it working. But it seems to have broken some of the SME stuff:
This how-to is NOT RECOMMENDED on anything other than a test server. It can send and receive email, but does not integrate properly into the SME ldap (yet).

==== BEGIN HOWTO ====

# Using scalix 10 and SME server 7 pre-release 3 (other versions will
# probably work)

pico -w /etc/yum.conf

# change the relevant sections as shown

[addons], [base] and [centosplus]

# remove qmail. (in a nasty way)
rpm -e qmail --nodeps

# Yum some required dependencies
yum install sendmail tcl tk compat-libstdc++-296 compat-libstdc++-33 cyrus-sasl-plain

# Get the scalix installer
# Scroll to the bottom, pick the Redhat Enterprise 3 or 4 version, enter
# your email address, and agree to the licence.

# Download and unpack the scalix tar.gz file
wget [link], tar -xzvf *.gz

# Change release version to fool scalix. (otherwise won't install)
cp /etc/redhat-release /etc/redhat-release.orig
pico /etc/redhat-release
# (Replace with "Red Hat Enterprise Linux ES release 4 (Nahant)" without
# quotes.)

# "Remember" changes to /etc/redhat-release on restart
cp -f /etc/redhat-release /etc/motd

# Stop SME conflicting services and also disable on startup.
cd /etc/init.d/

./imap svdisable
./pop3 svdisable
service ldap svdisable
./qpsmtpd svdisable
./smtp-auth-proxy svdisable
./sqpsmtpd svdisable

# NOTE: This may not actually disable the services.
# The SME developers might know...

# Change ldap port - service is stopped anyway, you can skip this
# pico /etc/e-smith/db/configuration/defaults/ldap/TCPPort
# change from 389 to 390

# Configure Tomcat:
# go to your scalix install directory and
# Accept the default settings, (except for warning, pick install anyway)

# Add scalix commands to shell path

# Run again to configure tomcat:

# Select option 3 - reconfigure
# Components > 1,2,3
# Accept defaults, but answer "no" to
#Do you want to integrate Tomcat with Apache using Scalix JK connector?
# and "yes" to "Are you sure you want to remove it (the JK connector)"
# Accept the other defaults.

# Make scalix startup automatically on restart
ln -s /etc/init.d/scalix /etc/rc.d/rc7.d/S82scalix
ln -s /etc/init.d/scalix-tomcat /etc/rc.d/rc7.d/S82scalix-tomcat
ln -s /etc/init.d/sendmail /etc/rc.d/rc7.d/S56sendmail

ln -s /etc/init.d/scalix /etc/rc.d/rc6.d/K03scalix
ln -s /etc/init.d/scalix-tomcat /etc/rc.d/rc6.d/K03scalix-tomcat
ln -s /etc/init.d/sendmail /etc/rc.d/rc6.d/K03sendmail

# Configure tcpwrappers to work with sendmail:
mkdir -p /etc/e-smith/templates-custom/etc/hosts.allow
pico /etc/e-smith/templates/etc/hosts.allow/sendmail
Code: [Select]


expand-template /etc/hosts.allow

# Then go to administration console:

# set up your users. then logon to webmail:

=== Post installation tasks (optional) ===
All of this info was lifted from the Scalix Knowledgebase

# * Get SSL working with scalix

cd /usr/java/jre1.5.0_04/bin
./keytool -genkey -alias tomcat -keyalg RSA

# (Enter the information required. Make a note of your keystore
# password - eg "newpassword")

pico -w /opt/scalix-tomcat/conf/server.xml

# Scroll down and uncomment the ssl section, also add
# keystorePass="newpassword"(as shown below)
Code: [Select]

<!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->

<Connector port="8443" MaxThreads="150" minSpareThreads="25" maxSpareThreads="75" enableLookups="false" disableUploadTimeout="true" acceptCount="100" debug="1" scheme="https" secure="true" clientAuth="false" sslProtocol="TLS" keystorePass="newpassword" />

<!-- Define a Coyote/JK2 AJP 1.3 Connector on port 8009 -->

service scalix-tomcat restart

# Now you can access sac and webmail over SSL as follows:
# Administration console:

# Webmail:

# Integrate clamav
pico -w /etc/group

# add clamav to the end of the scalix line so it reads something like:

cd /var/opt/scalix/rules

Code: [Select]

VIRUS-UNCLEANED=0 VIRUS-FOUND=1 ACTION=ALLOW NOTIFY="A virus was found in your message. It was successfully cleaned and sent to the recipient. However we highly recommend that you install or update your virus protection software and scan your computer for viruses."

pico ndninfo.txt
Code: [Select]

A virus was found in your message. The virus could not be cleaned and thus the message was not sent to the recipient.  We highly recommend that you install or update your virus protection software and scan your computer for viruses.

cp /opt/scalix/examples/general/omvscan.map /var/opt/scalix/rules
chown root omvscan.map
chmod 555 omvscan.map

# Restart clam
service clamd restart

#(clamav appears to work. Have tested by sending the clam.exe test file
# from the clamav tarball and got the "your message contains a virus"
# message. Need to test sending an infected msg TO the scalix server)

# * Integrate Spam Assassin
# Install some things:
yum install sendmail-devel

mkdir /root/rpm
cd /root/rpm
wget http://dag.wieers.com/packages/spamass-milter/spamass-milter-0.3.0-1.2.el4.rf.i386.rpm

(if it's not there try googling for spamass-milter.rpm - you want the redhat 4 version)

rpm -Uvh *.rpm

cd /var/opt/scalix/sys/
cp smtpd.cfg smtpd.cfg.orig
pico -w smtpd.cfg

Scroll to the bottom, add this line ...
... above the line: RELAY accept

cp /etc/mail/sendmail.cf /etc/mail/sendmail.cf.orig
pico -w /etc/mail/sendmail.cf
Change selected lines to the following:

O OperatorChars=.:%@!^/[]+
(delete the last =)

O InputMailFilters=Spamassassin
(delete #, append =Spamassassin)
then below O InputMailFilters=Spamassassin, add the following lines
Code: [Select]

# Milter options
#O Milter.LogLevel
O Milter.macros.connect=b, j, _, {daemon_name}, {if_name}, {if_addr}
O Milter.macros.helo={tls_version}, {cipher}, {cipher_bits}, {cert_subject}, {cert_issuer}
O Milter.macros.envfrom=i, {auth_type}, {auth_authen}, {auth_ssf}, {auth_author}, {mail_mailer}, {mail_host}, {mail_addr}
O Milter.macros.envrcpt={rcpt_mailer}, {rcpt_host}, {rcpt_addr}

In the section MAIL FILTER DEFINITIONS, add the following line:
Code: [Select]
Xspamassassin, S=local:/var/run/spamass.sock, F=, T=C:15m;S:4m;R:4m;E:10m

chkconfig --add spamass-milter
chkconfig --level 345 spamass-milter on

ln -s /etc/rc.d/init.d/spamass-milter /etc/rc.d/rc7.d/S91spamass-milter
ln -s /etc/rc.d/init.d/spamass-milter /etc/rc.d/rc6.d/K04spamass-milter

# Turn spam filtering on in the server manager
# Email > Change email filtering settings
# Enable spam filtering, alter other settings as you see fit,
# scroll down, click save

cd /etc/rc.d/init.d/

./sendmail restart
./spamass-milter restart

# Check spamd is running
netstat -lnp | grep spamd
# If you don't get a line like "tcp 0 0"
# then run the following command
/usr/bin/spamd -d
omoff -d 0 smtpd
omon smtpd

(That seems to work. Log files look ok. )

=== end post installation tasks ===

==== END HOWTO =====

[UPDATE] I added some extra services to the "stop services" list, following the suggestions made by other posts in this forum (see below). Send / receive works from webmail and Outlook connector on local accounts. I haven't tested anything else.

I can log into Horde using the scalix admin details. This means it might be possible to point other SME services to the scalix LDAP and get a working system  

However, at the moment, several SME services are broken.

[UPDATE] Scalix now reloads on restart. Hooray! However, I will leave the old "fix" instructions as a reference.

To reinstall scalix, keeping existing mailboxes:

(Just in case SME ldap started, somehow)
service ldap stop

Option 4 (uninstall)
Remove everything but the mailbox store.

Accept defaults, use existing mailbox store

Select option 3 - reconfigure
Components > 1,2,3
Accept defaults, but answer "no" to
Do you want to integrate Tomcat with Apache using Scalix JK connector?
and "yes" to "Are you sure you want to remove it (the JK connector)"
Accept the other defaults.

It will then come back up again with all your users and emails intact

Anyone got any ideas about any of this?

[UPDATE] It has been suggested that having both LDAP servers running at the same time is the way to go. I think we would be better trying to get the SME server services to use the scalix ldap, after scalix has been installed.



« Reply #11 on: February 25, 2006, 12:54:26 AM »
Is selinux enabled on your system?  That fixed my problem on FC4, I then enabled the jk connector and was able to get to my stuff without the :8080

Somthing to try...


LDAP problems
« Reply #12 on: February 25, 2006, 04:24:17 AM »
Another thing is that scalix runs its on ldap server on port 389, which seems to break it if you try and change the port.  This is probably why you could log in with sxadmin crendentials to horde, it killed the sme ldap.

You might be able to get it to work by assigning another ip to the eth interface and only allow either ldap server to listen on one ip.  Just an idea, i am not sure that would work...

I have made scalix on another machine authenticate to the sme ldap server, which somewhat defeats the purpose.

This task seems very interesting as a contrib because any of the opensource groupware seems overcomplicated compared to scalix!


LDAP problems
« Reply #13 on: February 26, 2006, 01:10:07 AM »
Thanks strombergtec! LDAP clash sounds like the issue.

Ok, so to get scalix to work with sme, one would have to either:
[1] Have both scalix and SME LDAP servers running simeltaneously
[2] Have scalix LDAP server, and get SME components to talk to it
[3] Have SME LDAP server, and get Scalix components to talk to it

And you say you have gotten [3] working. Can you post a howto?
It seems like a good strategy as you would not have to import your existing SME users into the (new) Scalix LDAP.



How i got scalix running
« Reply #14 on: February 26, 2006, 03:47:13 PM »
I had 2 seperate hardware boxes running,  that was the only way i could make it work.  

To have scalix auth to the sme box the scalix ldap must still be running.

You can see what scalix processes are running with "omstat -a" you will see ldap in that list.

The only way seems to be if we could make the 2 ldap's coexist on the same machine, without changing from port 389.