Koozali.org: home of the SME Server

I broke my roundcube :(

Offline Jean-Philippe Pialasse

  • *
  • 2,818
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: I broke my roundcube :(
« Reply #45 on: March 28, 2024, 02:36:05 PM »

Offline david000

  • ****
  • 200
  • +0/-0
Re: I broke my roundcube :(
« Reply #46 on: March 28, 2024, 02:45:09 PM »
https://github.com/roundcube/classic

Thank you for that. So it looks like I just need to apply the command:

Code: [Select]
composer require "roundcube/classic:~1.6.0"
Actually it should be:

Code: [Select]
composer require "roundcube/classic:~1.6.26"


Offline Jean-Philippe Pialasse

  • *
  • 2,818
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: I broke my roundcube :(
« Reply #47 on: March 28, 2024, 07:56:18 PM »
nope. use it as is. 

Note: make sure to use version of the skin that matches the Roundcube version. If it is not available use the closest lower version number. For example, if your Roundcube version is 1.6.5, use skin version 1.6.x (with max X that exists), if 1.6.x does not exist use 1.5.x and so on. Using 1.7.x and up might not work.


also as we are using root you might alter a little the command for it to work


Offline david000

  • ****
  • 200
  • +0/-0
Re: I broke my roundcube :(
« Reply #48 on: March 29, 2024, 11:16:29 AM »
nope. use it as is. 

Note: make sure to use version of the skin that matches the Roundcube version. If it is not available use the closest lower version number. For example, if your Roundcube version is 1.6.5, use skin version 1.6.x (with max X that exists), if 1.6.x does not exist use 1.5.x and so on. Using 1.7.x and up might not work.


also as we are using root you might alter a little the command for it to work

I'll put some time aside and have a look. I must admit I don't understand their use of the .x for the version but will have a look.

Offline Jean-Philippe Pialasse

  • *
  • 2,818
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: I broke my roundcube :(
« Reply #49 on: March 29, 2024, 07:35:54 PM »
the ~ is the important part.
The tilde (~) is used to specify a “compatible with” version range

Code: [Select]

cd /usr/share/roundcubemail
export COMPOSER_ROOT_VERSION=`rpm -q roundcubemail --queryformat "%{VERSION}"`

COMPOSER_ALLOW_SUPERUSER=1 /usr/bin/php81  -d allow_url_fopen=1 /usr/local/bin/composer require "roundcube/classic:~1.6.0"

cp plugins/classic skins/
« Last Edit: March 29, 2024, 07:45:28 PM by Jean-Philippe Pialasse »

Offline david000

  • ****
  • 200
  • +0/-0
Re: I broke my roundcube :(
« Reply #50 on: April 08, 2024, 10:47:10 AM »
the ~ is the important part.
The tilde (~) is used to specify a “compatible with” version range

Code: [Select]

cd /usr/share/roundcubemail
export COMPOSER_ROOT_VERSION=`rpm -q roundcubemail --queryformat "%{VERSION}"`

COMPOSER_ALLOW_SUPERUSER=1 /usr/bin/php81  -d allow_url_fopen=1 /usr/local/bin/composer require "roundcube/classic:~1.6.0"

cp plugins/classic skins/

Thank you for that. And that should install the 'classic' skin ?

Offline Jean-Philippe Pialasse

  • *
  • 2,818
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: I broke my roundcube :(
« Reply #51 on: April 08, 2024, 04:03:34 PM »
yes

Offline david000

  • ****
  • 200
  • +0/-0
Re: I broke my roundcube :(
« Reply #52 on: April 08, 2024, 07:20:03 PM »
yes

Thank you. I'll let you know how it goes.