Koozali.org: home of the SME Server

Awstats not showing 1 domain stats

Offline jameswilson

  • *
  • 788
  • +0/-0
    • Security Warehouse, trade security equipment
Awstats not showing 1 domain stats
« on: May 03, 2024, 04:02:37 AM »
Hi all
Ive added awstats but it isnt working for one domain.

It processing thousands of logs and working for all the others but 1 (is leading www.*)if relevant doesnt show.

Unsure where to start looking for what ive done wrong.

James

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Awstats not showing 1 domain stats
« Reply #1 on: May 03, 2024, 04:32:47 AM »
is the www. in domains or hosts?

Offline jameswilson

  • *
  • 788
  • +0/-0
    • Security Warehouse, trade security equipment
Re: Awstats not showing 1 domain stats
« Reply #2 on: May 03, 2024, 08:52:17 AM »
Hi JP
Its in domains on the sme panel and domains only (if relevant) on lets encrypt

Offline jameswilson

  • *
  • 788
  • +0/-0
    • Security Warehouse, trade security equipment
Re: Awstats not showing 1 domain stats
« Reply #3 on: May 03, 2024, 01:39:10 PM »
is the www. in domains or hosts?
i notice however its listed under the admin user as www.securitywarehouse.co.uk

and the same domain listed twice in the admin pages
Code: [Select]
securitywarehouse.co.uk                 xxxxxx       ...             
support.securitywarehouse.co.uk xxxx ...
store.securitywarehouse.co.uk         xxxxx         ...         
store-test.securitywarehouse.co.uk xxxxxxx ...
securitywarehouse.co.uk                 xxxxxx ...               

Updated on 05/03/2024 at 17:30 in 13 secs. 2524 new logs processed.

james
« Last Edit: May 03, 2024, 07:04:25 PM by jameswilson »

Offline jameswilson

  • *
  • 788
  • +0/-0
    • Security Warehouse, trade security equipment
Re: Awstats not showing 1 domain stats
« Reply #4 on: May 07, 2024, 07:29:58 PM »
maybe i can remove awstats (i can do that through yum)But is there a way to remove all config files so all is recreated. I did rename the server through the console maybe thats caused an issue?

James

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Awstats not showing 1 domain stats
« Reply #5 on: May 08, 2024, 01:00:58 AM »
i think the issue is not awstats related, i mean removing and reinstlaling won’t help.
issue is rather the way your domains are set as domains and hosts in SME

my guess as you did not answer the question is that
www.securitywarehouse.co.uk is set in domains

securitywarehouse.co.uk is set in hosts.


awstats is set per VirtualHosts. and we set the Virtualhosts per domain in db domains (domains.tld) with each related hosts in db hosts (*.domains.tld) as an alias for this virtualhost in httpd
« Last Edit: May 08, 2024, 01:05:18 AM by Jean-Philippe Pialasse »

Offline jameswilson

  • *
  • 788
  • +0/-0
    • Security Warehouse, trade security equipment
Re: Awstats not showing 1 domain stats
« Reply #6 on: May 09, 2024, 12:50:15 AM »
i think the issue is not awstats related, i mean removing and reinstlaling won’t help.
issue is rather the way your domains are set as domains and hosts in SME

my guess as you did not answer the question is that
www.securitywarehouse.co.uk is set in domains

securitywarehouse.co.uk is set in hosts.


awstats is set per VirtualHosts. and we set the Virtualhosts per domain in db domains (domains.tld) with each related hosts in db hosts (*.domains.tld) as an alias for this virtualhost in httpd

Yes that is correct. What should I do to correct it?

Offline ReetP

  • *
  • 3,805
  • +5/-0
Re: Awstats not showing 1 domain stats
« Reply #7 on: May 09, 2024, 09:39:32 AM »
securitywarehouse.co.uk is your domain

www is a host at that domain.

When you set up a domain the server automagically sets some hosts for you eg www,ftp,mail etc

So you have everything the wrong way round.

Not sure the best solution here.

JP may know so wait for him to pop up later.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Awstats not showing 1 domain stats
« Reply #8 on: May 09, 2024, 02:02:47 PM »
all hits to www should be  accounted in the main domain as they both go to the same virtualhost.

if you had a domain2 pointing to same ibay. this would be currently for sme a different virtualhost and awstats would account for it separately. 

why would you account www.domain and domain separetly if they display same content?

Offline jameswilson

  • *
  • 788
  • +0/-0
    • Security Warehouse, trade security equipment
Re: Awstats not showing 1 domain stats
« Reply #9 on: May 09, 2024, 03:22:54 PM »
Quote
why would you account www.domain and domain separetly if they display same content?

lack of knowledge?
named the server then added the domain.
I can rename the server to be something different domain name wise if needed

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Awstats not showing 1 domain stats
« Reply #10 on: May 10, 2024, 01:32:49 PM »
why it would be needed?
again, why would you like to account the two separately when pointing to same content

Offline jameswilson

  • *
  • 788
  • +0/-0
    • Security Warehouse, trade security equipment
Re: Awstats not showing 1 domain stats
« Reply #11 on: May 15, 2024, 04:30:47 PM »
why it would be needed?
again, why would you like to account the two separately when pointing to same content
Hi JP
I dont but the stats for www. dont show in the stats

Offline ReetP

  • *
  • 3,805
  • +5/-0
Re: Awstats not showing 1 domain stats
« Reply #12 on: May 15, 2024, 05:01:30 PM »
Can you post the output from

Code: [Select]
db domains show
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline jameswilson

  • *
  • 788
  • +0/-0
    • Security Warehouse, trade security equipment
Re: Awstats not showing 1 domain stats
« Reply #13 on: May 15, 2024, 07:06:41 PM »
Code: [Select]
[root@cov1-2 catalog]# db domains show
securitywarehouse.co.uk=domain
    Content=sw-zen
    Description=secware
    Nameservers=internet
secware.co.uk=domain
    Content=Primary
    Description=Primary domain
    Nameservers=localhost
    Removable=no
    SystemPrimaryDomain=yes
store-test.securitywarehouse.co.uk=domain
    Content=store-test
    Description=secware test domain
    Nameservers=internet
    letsencryptSSLcert=enabled
store.securitywarehouse.co.uk=domain
    Content=store-sw
    Description=store sw
    Nameservers=internet
    letsencryptSSLcert=enabled
support.securitywarehouse.co.uk=domain
    Content=support-sw
    Description=Support secware
    Nameservers=internet
    letsencryptSSLcert=enabled
sw-zen2.securitywarehouse.co.uk=domain
    Content=sw-zen2
    Description=secware zen2
    Nameservers=internet
test.securitywarehouse.co.uk=domain
    Content=test-install
    Description=test sw ibay
    Nameservers=internet
webstats.securitywarehouse.co.uk=domain
    Content=webstats
    Description=webstats
    Nameservers=internet
www.securitywarehouse.co.uk=domain
    Content=sw-zen
    Description=secware
    Nameservers=corporate
    letsencryptSSLcert=enabled

Thanks for looking

Offline Jean-Philippe Pialasse

  • *
  • 2,819
  • +11/-0
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Awstats not showing 1 domain stats
« Reply #14 on: May 15, 2024, 09:43:09 PM »
and what gives
Code: [Select]
db hosts show |grep wwwI am pretty sure you have: www.securitywarehouse.co.uk=host

some information about apache and apache log

on apache logs (what awstat uses) the domain name you see at the very beginning is the Virtualhost ServerName, whether you use an alias or the virtualhost name as a match it will only display the virtualhost ServerName. (SME put all matching host as serveralias in the virtualhost for servername directive)

in apache configuration file, if you get multiple matches for the same thing it has a really complexe way of solving this depending on in what type of context it is encountered  (file, virtualhost, alias...) but for virtualhost it has tendency to merge them and with a serveralias matching another ServerName, there are chance that this is the first occurrence in the file that will win.

and again comes my question for the third time, and i will try to rephrase again :
why in the world would you need to have the www accounted separetly when it points to the exact same content ?
« Last Edit: May 15, 2024, 09:54:36 PM by Jean-Philippe Pialasse »