Koozali.org, home of the SME Server

Scalix on SME


So has anyone cracked this one yet?
« Reply #15 on: March 27, 2006, 03:48:20 PM »
I am very keen to try to get this to work. I am busy d/l the new scalix 10 and sme 7rc1. i have had some experience with scalix plus i have friends and employers who are partnered with scalix and can hopefully give some insight and advice, they have also been on training done by scalix. scalix on sme would be awesome. Sure you need x to install which is pretty annoying but you can do it with command line but complicated. prob easier to just install x, install scalix and uninstall x again. once it's installed it's all web gui and cli from there.

these damn d/l's are taking forever.

i am not too familiar with ldap configuration. but is it possible to have both the ldap's running on the same server but making sme work on another port. have i got that right, the main prob is that they use the same port and getting confused?

but i think the best would be for sme to read scalix's ldap as sme would be more open and easier to config. as i understand it, scalix is semi oss. most of the core systems and web mail is closed. figured this out when my company wanted to change the default font in the webmail.

i have the next 4 days to work on this, so hopefully somebody has some ideas. i'll also have an update once i have gotten everything installed and maybe some ideas from my friends


scalix on sme
« Reply #16 on: March 27, 2006, 04:18:53 PM »
I agree that getting this to work with sme would be big for both sme and scalix.  For me the showstopper is that the scalix ldap server port number seems to be hardcoded into scalix.  If you try to change it, it will break!

If there is another way to go about this i would definately help if i can!

Maybe for us groupware hungry individuals we should find one that works and focus on it.  I like opengroupware because it is almost stable and could easily be rolled up for sme.  Though if scalix worked I would love that!


Progress So far
« Reply #17 on: March 28, 2006, 06:57:20 PM »
I got mail between webmail accounts to work. Figured out that scalix smtp could not start properly as sme smtp was still on. stopped:

and had no more errors (methodname=send) when trying to send a webmail and all mail worked great.

But the ldap problem is still there. When I install scalix according to the howto everything works fine, but once I reboot i cannot log into sxadmin or webmail. keep getting incorrect username problems. even if I don't let sme ldap server start on boot. also removed that from the rc7.d dir.

does anyone know where scalix stores it's ldap conf file, might be a clue to how it starts. as far as I can tell you should be able to run scalix ldap from anywhere on any port. where did somebody on this post change the scalix ldap port?

gonna try changing sme ldap port and see what happens. just annoying cos the only way so far to get scalix working again is to re-install scalix. but at reboot all is broken again


Scalix on SME
« Reply #18 on: March 28, 2006, 07:37:03 PM »
Are you sure the scalix ldap is running (check with "omstat")?  I had tried to change the scalix ldap port but it would not start, you will have to change the sme ldap port...  Not sure what that will break? Might want to ask one of the dev's.  

Did you use the j2re package provided with scalix?  I had a problem with that of FC4?

Could any of your partner friends talk scalix into helping us out?  I could definately see a benefit for them making a scalix install package for sme!  As most offices want more that just email and don't want multiple servers.


Scalix on SME
« Reply #19 on: March 28, 2006, 09:07:41 PM »
my friend was a bit busy today, couldn't really give me any real answers. not so sure they would be able to get real snwers out of scalix either. there would hev to be some money in it for them i think, so if a client specifically askes for it. i know when we started migrating our exchange to scalix and insisted on centos our partner said scalix doesn't really support it but they will. and so since we bought 200 licenses from them they made it work. but centos is easy, this isn't.

 how did you change that scalix ldap port? i am a bit lost here, I know linux but a lot of this stuff I have never had to deal with. ldap is very new to me. IS it possible to run 2 ldap servers from the same server? can some of the dev's let us know that if we change sme's ldap port things will break.

i am starting a new post on scalix's forum with what we have done so far, maybe somebody there will pick it up and help us out. if we lucky maybe even florian, the guy who trained my friends.


Scalix on SME
« Reply #20 on: March 28, 2006, 10:11:15 PM »
OK so i tried changing the scalix ldap. changed it in  
and /etc/opt/scalix/webmail/swa.properties
restarted ldap with omoff and omon
when  i try to log in with webmail, firefox keeps telling me that a pop-up is being blocked even though blocking is off. couldn't get any further. btw when i did a netstat i could see both sme ldap on port 389 and scalix ldap on 390
changed it all back and it worked again

then i changed ldap port in /etc/openldap/ldap.conf to 390 and started /etc/rc.d/init.d/ldap and here i am dumbfounded. even though the conf file says 390 ldap keeps starting up on 389 according to netstat. why does it do this, i even changed the e-smith template so that it doesn't overwrite the setting. i tried a reboot and still running on 389, am I missing something?
course reboot now killed scalix again so I have to reinstall.

going to bed now, if anybody has any ideas i would really love to hear them


« Reply #21 on: March 29, 2006, 09:21:19 AM »
Thanks for your help. I have incorporated your suggestions into the howto.
We're pretty close. Scalix webmail works and even though restarting still breaks scalix, it can be fixed without losing mailboxes.

I need help from a (SME and or scalix) god to do the following:

[1] Sort out the LDAP issues.
I suspect that getting the SME services to use the scalix LDAP will be the best approach. I say that because Horde appears to automatically use the scalix LDAP, so it might be easy to get the other services to do so.

[2] Integrate ClamAV / Spamassasin with scalix.
[UPDATE] I think I've done this, after reading through the scalix knowledgebase. I've updated the howto accordingly, but haven't tested these yet. I also got SSL working.

Calling all ye gods. Anyone up for the task?


Scalix on SME
« Reply #22 on: March 29, 2006, 01:20:38 PM »
Yeah your right, i only had to re-install the scalix server component  and keep the message store  and it works again.

doing some reading up on ldap to see if I can figure it out.

started this thread: http://www.scalix.com/community/viewtopic.php?p=8761#8761 on scalix community forum. got a sorta hopefull reply.


Solved two problems
« Reply #23 on: March 30, 2006, 02:16:37 AM »
I managed to get scalix to start automatically on sme server restart.

Here's what you need to do:
[1] Stop SME conflicting services and also disable on startup)
cd /etc/init.d/

./imap svdisable
./pop3 svdisable
service ldap svdisable
./qpsmtpd svdisable
./smtp-auth-proxy svdisable
./sqpsmtpd svdisable

[2] Make scalix startup automatically on restart
ln -s /etc/init.d/scalix /etc/rc.d/rc7.d/S51scalix
ln -s /etc/init.d/scalix-tomcat /etc/rc.d/rc7.d/S51scalix-tomcat
ln -s /etc/init.d/sendmail /etc/rc.d/rc7.d/S50sendmail

ln -s /etc/init.d/scalix /etc/rc.d/rc6.d/K03scalix
ln -s /etc/init.d/scalix-tomcat /etc/rc.d/rc6.d/K03scalix-tomcat
ln -s /etc/init.d/sendmail /etc/rc.d/rc6.d/K03sendmail

I have amended the how-to accordingly. Now we just need to get the SME services to talk to the Scalix LDAP (maybe), and spamassasin / clamav integration.

[update] re: send/receive email to/from a remote email address? I just made another edit to the install howto. You have to add sendmail to /etc/hosts.allow before it will send email to external networks.

Here's how:
Configure tcpwrappers to work with sendmail:
mkdir -p /etc/e-smith/templates-custom/etc/hosts.allow
pico /etc/e-smith/templates/etc/hosts.allow/sendmail
Code: [Select]


expand-template /etc/hosts.allow



Updated howto
« Reply #24 on: March 30, 2006, 09:29:55 AM »
Hi there.
I just extensively updated the howto. There are numerous enhancements and fixes. It's well worth a look.

We're at the stage now where Scalix basically works with SME, including SSH, spamassassin and clamav. (although I haven't really tested the last two yet, there may be some minor config bugs to sort out).

This is fairly exciting. If we tidy this up a bit more and package the whole thing into an install script, this could really rock!



Scalix on SME
« Reply #25 on: March 30, 2006, 11:57:45 AM »
Awesome, well done silasp, reboot and it all still works. i have done all that you suggested, gonna test the spamassassin and clamav and will let you know. i had an issue with the ssl though, when i try those webpages firefox wants to d/l a BIN file, is this a firefox issue or is there something wrong in the config?

just a note, someone did mention that selinux is the reason why they couldn't run the jk connector, is that the same issue here, if yes how can we disable it or make it work? I couldn't find any selinux stuff on the box but i might be looking in the wrong places.

I agree that getting sme to talk to scalix ldap is the solution, having two ldap's is silly plus then we have to setup ldap synching. but getting sme to talk to scalix is beyond me at the moment, i have to learn it eventually but right now i don't have the time. I will be on holiday from fri 31 till 18 april with no pc at hand so unfortunately i won't be able to help. but lets hope that your request to the sme gods is answered and someone helps us out with that one.

but otherwise well done for getting this working. i will let you know bout the mail filter software


Scalix on SME
« Reply #26 on: March 30, 2006, 07:24:36 PM »
after spam and antivirus integration i couldn't send mail anymore, i rebooted and saw that half the services did not start, i started them and then mail worked again, rebooted again and now firefox won't allow the pop-up sac and swa to open even though po-ups are off


« Reply #27 on: April 03, 2006, 09:16:02 AM »
Thanks for the feedback. Ok, solved the problem with the services not starting - discovered that clamd needs to start before scalix, otherwise the service router does not start.

Also made a couple of other little fixes: restarting clamd, enabling spamd from the user panel (service spamd start does not work properly), and others I have no doubt forgotten.

Have another look at the how-to post.

As for the popup issue, I think it is with firefox. I'm using Firefox on windows 2000, allowing all pop-ups from 192.168.1.x (the scalix server) and I haven't had any issues . It should work with hostnames too.



scalix raw
« Reply #28 on: April 04, 2006, 05:39:57 AM »
Has anyone noticed the "scalix raw" complete with permission to redistribute packages?  It also allows you to set the ldap port during setup!  This must be pretty new to their site, as i have not noticed it before.

Could possibly be rolled into an easy to install contrib!

Offline kadybee

  • *
  • 40
  • +0/-0
Scalix on SME
« Reply #29 on: April 06, 2006, 12:32:44 AM »
All this work in getting Scalix to an SME server is admirable and I look forward to seeing it finished.  

In the meantime, those wanting to 'play' with Scalix might be interested in trying a 'creative' solution:

I installed Centos 4 on a box, installed Scalix to that and then installed VMWare's new Server (still in Beta) and SME7 as a virtual.

They talk to each other nicely as two separate machines.  Others may see  a number of other advantages in running this sort of environment.